summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-05-25 13:01:33 +0000
committerJeroen Roovers <jer@gentoo.org>2014-05-25 13:01:33 +0000
commit86f9160205c04c100c377705a1261c8b4bd113f2 (patch)
tree5ce3c606e314ce7fcf17730a8e6c8d11ff21810f /x11-wm
parentx86 stable wrt bug #510778 (diff)
downloadgentoo-2-86f9160205c04c100c377705a1261c8b4bd113f2.tar.gz
gentoo-2-86f9160205c04c100c377705a1261c8b4bd113f2.tar.bz2
gentoo-2-86f9160205c04c100c377705a1261c8b4bd113f2.zip
Reflect upstream system-autodetect.mk changes in sed scripts. Run configuration changes in src_configure().
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/notion/ChangeLog9
-rw-r--r--x11-wm/notion/notion-3_p2013030200.ebuild18
-rw-r--r--x11-wm/notion/notion-9999.ebuild30
3 files changed, 33 insertions, 24 deletions
diff --git a/x11-wm/notion/ChangeLog b/x11-wm/notion/ChangeLog
index 6a91eb85384d..466dde126638 100644
--- a/x11-wm/notion/ChangeLog
+++ b/x11-wm/notion/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-wm/notion
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/notion/ChangeLog,v 1.8 2013/07/21 14:07:01 jer Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/notion/ChangeLog,v 1.9 2014/05/25 13:01:33 jer Exp $
+
+ 25 May 2014; Jeroen Roovers <jer@gentoo.org> notion-3_p2013030200.ebuild,
+ notion-9999.ebuild:
+ Reflect upstream system-autodetect.mk changes in sed scripts. Run
+ configuration changes in src_configure().
29 May 2013; Michael Weber <xmw@gentoo.org> notion-3_p2013030200.ebuild,
notion-9999.ebuild:
diff --git a/x11-wm/notion/notion-3_p2013030200.ebuild b/x11-wm/notion/notion-3_p2013030200.ebuild
index e4d542361250..7523730dd4b1 100644
--- a/x11-wm/notion/notion-3_p2013030200.ebuild
+++ b/x11-wm/notion/notion-3_p2013030200.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/notion/notion-3_p2013030200.ebuild,v 1.3 2013/05/29 06:32:20 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/notion/notion-3_p2013030200.ebuild,v 1.4 2014/05/25 13:01:33 jer Exp $
-EAPI="4"
+EAPI=5
-inherit eutils toolchain-funcs multilib
+inherit eutils multilib toolchain-funcs
DESCRIPTION="Notion is a tiling, tabbed window manager for the X window system"
HOMEPAGE="http://notion.sourceforge.net"
@@ -45,6 +45,10 @@ src_prepare() {
-i ioncore/Makefile || die
export STRIPPROG=true
+ tc-export CC
+}
+
+src_configure() {
use nls || export DEFINES=" -DCF_NO_LOCALE -DCF_NO_GETTEXT"
if ! use xinerama ; then
@@ -54,8 +58,6 @@ src_prepare() {
if ! use xrandr ; then
sed -e 's/mod_xrandr//g' -i modulelist.mk || die
fi
-
- tc-export CC
}
src_compile() {
@@ -64,7 +66,7 @@ src_compile() {
}
src_install() {
- emake DESTDIR="${D}" install
+ default
exeinto /etc/X11/Sessions
doexe "${FILESDIR}"/notion
@@ -75,5 +77,5 @@ src_install() {
pkg_postinst() {
elog "If you want notion to have an ability to view a file based on its"
- elog "guessed MIME type you need 'run-mailcap' program in your system."
+ elog "guessed MIME type you should emerge app-misc/run-mailcap."
}
diff --git a/x11-wm/notion/notion-9999.ebuild b/x11-wm/notion/notion-9999.ebuild
index 560c8fa573f1..1dc764b625ee 100644
--- a/x11-wm/notion/notion-9999.ebuild
+++ b/x11-wm/notion/notion-9999.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/notion/notion-9999.ebuild,v 1.7 2013/05/29 06:32:20 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/notion/notion-9999.ebuild,v 1.8 2014/05/25 13:01:33 jer Exp $
-EAPI="4"
+EAPI=5
EGIT_REPO_URI="git://notion.git.sourceforge.net/gitroot/notion/notion"
EGIT_HAS_SUBMODULES="1"
-inherit eutils git-2 toolchain-funcs multilib
+inherit eutils git-2 multilib toolchain-funcs
DESCRIPTION="Notion is a tiling, tabbed window manager for the X window system"
HOMEPAGE="http://notion.sourceforge.net"
@@ -33,18 +33,22 @@ src_prepare() {
-e "/^CFLAGS/{s:-Os:: ; s:-g::}" \
-e "/^LDFLAGS=/{s:=:+=: ; s:-Wl,--as-needed::}" \
-e "/^CC=/s:=:?=:" \
- -e "s:^\(PREFIX=\).*$:\1${ROOT}usr:" \
- -e "s:^\(ETCDIR=\).*$:\1${ROOT}etc/notion:" \
- -e "s:^\(LIBDIR=\).*:\1\$(PREFIX)/$(get_libdir):" \
- -e "s:^\(DOCDIR=\).*:\1\$(PREFIX)/share/doc/${PF}:" \
- -e "s:^\(LUA_DIR=\).*$:\1\$(PREFIX)/usr:" \
- -e "s:^\(VARDIR=\).*$:\1${ROOT}var/cache/${PN}:" \
+ -e "/^PREFIX/s:=.*$:= \${ROOT}usr:" \
+ -e "/^ETCDIR/s:=.*$:= \${ROOT}etc/notion:" \
+ -e "/^LIBDIR/s:=.*:= \$(PREFIX)/$(get_libdir):" \
+ -e "/^DOCDIR/s:=.*:= \$(PREFIX)/share/doc/${PF}:" \
+ -e "/^LUA_DIR/s:=.*$:= \$(PREFIX)/usr:" \
+ -e "/^VARDIR/s:=.*$:= \${ROOT}var/cache/${PN}:" \
-e "s:^\(X11_PREFIX=\).*:\1\$(PREFIX)/usr:" \
-i system-autodetect.mk || die
sed -e 's/gcc/$(CC)/g' \
-i ioncore/Makefile || die
export STRIPPROG=true
+ tc-export CC
+}
+
+src_configure() {
use nls || export DEFINES=" -DCF_NO_LOCALE -DCF_NO_GETTEXT"
if ! use xinerama ; then
@@ -54,8 +58,6 @@ src_prepare() {
if ! use xrandr ; then
sed -e 's/mod_xrandr//g' -i modulelist.mk || die
fi
-
- tc-export CC
}
src_compile() {
@@ -64,7 +66,7 @@ src_compile() {
}
src_install() {
- emake DESTDIR="${D}" install
+ default
exeinto /etc/X11/Sessions
doexe "${FILESDIR}"/notion
@@ -75,5 +77,5 @@ src_install() {
pkg_postinst() {
elog "If you want notion to have an ability to view a file based on its"
- elog "guessed MIME type you need 'run-mailcap' program in your system."
+ elog "guessed MIME type you should emerge app-misc/run-mailcap."
}