summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2014-05-16 02:03:55 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2014-05-16 02:03:55 +0000
commit589aa36e6b8e257636e327227d99f0fbef7947a5 (patch)
tree42b0fefa635bca3854d397352fa8f7cc912d824c /x11-wm
parentVersion bump, makes resolution detection more reliable. (diff)
downloadgentoo-2-589aa36e6b8e257636e327227d99f0fbef7947a5.tar.gz
gentoo-2-589aa36e6b8e257636e327227d99f0fbef7947a5.tar.bz2
gentoo-2-589aa36e6b8e257636e327227d99f0fbef7947a5.zip
Version bump, restores Win-D shortcut
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key CF0ADD61)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/muffin/ChangeLog8
-rw-r--r--x11-wm/muffin/muffin-2.2.3.ebuild85
2 files changed, 92 insertions, 1 deletions
diff --git a/x11-wm/muffin/ChangeLog b/x11-wm/muffin/ChangeLog
index 909423e7231b..da455e0f049b 100644
--- a/x11-wm/muffin/ChangeLog
+++ b/x11-wm/muffin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-wm/muffin
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/muffin/ChangeLog,v 1.18 2014/05/07 02:16:52 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/muffin/ChangeLog,v 1.19 2014/05/16 02:03:55 tetromino Exp $
+
+*muffin-2.2.3 (16 May 2014)
+
+ 16 May 2014; Alexandre Rostovtsev <tetromino@gentoo.org>
+ +muffin-2.2.3.ebuild:
+ Version bump, restores Win-D shortcut
07 May 2014; Alexandre Rostovtsev <tetromino@gentoo.org> muffin-2.2.2.ebuild:
Introspection dep fix
diff --git a/x11-wm/muffin/muffin-2.2.3.ebuild b/x11-wm/muffin/muffin-2.2.3.ebuild
new file mode 100644
index 000000000000..98287c5d7b4c
--- /dev/null
+++ b/x11-wm/muffin/muffin-2.2.3.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/muffin/muffin-2.2.3.ebuild,v 1.1 2014/05/16 02:03:55 tetromino Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit autotools eutils gnome2 python-any-r1
+
+DESCRIPTION="Compositing window manager forked from Mutter for use with Cinnamon"
+HOMEPAGE="http://cinnamon.linuxmint.com/"
+
+SRC_URI="https://github.com/linuxmint/muffin/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="+introspection test xinerama"
+KEYWORDS="~amd64 ~x86"
+
+COMMON_DEPEND="
+ >=x11-libs/pango-1.2[X,introspection?]
+ >=x11-libs/cairo-1.10:=[X]
+ x11-libs/gdk-pixbuf:2[introspection?]
+ >=x11-libs/gtk+-3.3.7:3[X,introspection?]
+ >=dev-libs/glib-2.25.10:2
+ >=gnome-extra/cinnamon-desktop-1.0:0=[introspection?]
+ >=media-libs/clutter-1.9.10:1.0=[introspection?]
+ >=media-libs/cogl-1.9.6:1.0=[introspection?]
+ >=media-libs/libcanberra-0.26[gtk3]
+ >=x11-libs/startup-notification-0.7:=
+ >=x11-libs/libXcomposite-0.2
+ >=gnome-base/gsettings-desktop-schemas-3.3.0[introspection?]
+
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ virtual/opengl
+
+ gnome-extra/zenity
+
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
+ xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="${COMMON_DEPEND}
+ ${PYTHON_DEPS}
+ >=app-text/gnome-doc-utils-0.8
+ sys-devel/gettext
+ >=dev-util/intltool-0.35
+ virtual/pkgconfig
+ test? ( app-text/docbook-xml-dtd:4.5 )
+ xinerama? ( x11-proto/xineramaproto )
+ x11-proto/xextproto
+ x11-proto/xproto
+"
+RDEPEND="${COMMON_DEPEND}
+ !x11-misc/expocity
+"
+
+src_prepare() {
+ epatch_user
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README* *.txt doc/*.txt"
+ gnome2_src_configure \
+ --disable-static \
+ --enable-shape \
+ --enable-sm \
+ --enable-startup-notification \
+ --enable-xsync \
+ --enable-verbose-mode \
+ --with-libcanberra \
+ $(use_enable introspection) \
+ $(use_enable xinerama)
+}