summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2011-08-04 22:27:34 +0000
committerMichael Weber <xmw@gentoo.org>2011-08-04 22:27:34 +0000
commit52d794574692a3dc1b152bcb0f7370f6649c12cf (patch)
treea527b2bb58ecb357265af6983185982f194fead9 /x11-wm
parentAdd a x86 freebsd 8.2 prefix profile (diff)
downloadgentoo-2-52d794574692a3dc1b152bcb0f7370f6649c12cf.tar.gz
gentoo-2-52d794574692a3dc1b152bcb0f7370f6649c12cf.tar.bz2
gentoo-2-52d794574692a3dc1b152bcb0f7370f6649c12cf.zip
Version bump, cleanups
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/cwm/ChangeLog9
-rw-r--r--x11-wm/cwm/cwm-20110726.ebuild34
-rw-r--r--x11-wm/cwm/cwm-99999999.ebuild11
-rw-r--r--x11-wm/cwm/files/cwm-20110726-Makefile.patch36
4 files changed, 81 insertions, 9 deletions
diff --git a/x11-wm/cwm/ChangeLog b/x11-wm/cwm/ChangeLog
index 5fbc945f35dd..112eadde54b3 100644
--- a/x11-wm/cwm/ChangeLog
+++ b/x11-wm/cwm/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-wm/cwm
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/cwm/ChangeLog,v 1.15 2011/08/04 21:29:29 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/cwm/ChangeLog,v 1.16 2011/08/04 22:27:34 xmw Exp $
+
+*cwm-20110726 (04 Aug 2011)
+
+ 04 Aug 2011; Michael Weber <xmw@gentoo.org> +cwm-20110726.ebuild,
+ +files/cwm-20110726-Makefile.patch, cwm-99999999.ebuild:
+ Adapted changes in Makefile, Version bump to new tarball, remove old version,
+ ebuild cleanup
04 Aug 2011; Michael Weber <xmw@gentoo.org> cwm-20110515.ebuild:
Fix HOMEPAGE
diff --git a/x11-wm/cwm/cwm-20110726.ebuild b/x11-wm/cwm/cwm-20110726.ebuild
new file mode 100644
index 000000000000..417e55dcbe2a
--- /dev/null
+++ b/x11-wm/cwm/cwm-20110726.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/cwm/cwm-20110726.ebuild,v 1.1 2011/08/04 22:27:34 xmw Exp $
+
+EAPI=2
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="OpenBSD fork of calmwm, a clean and lightweight window manager"
+HOMEPAGE="http://www.openbsd.org/cgi-bin/cvsweb/xenocara/app/cwm/
+ http://github.com/chneukirchen/cwm"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~sparc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libXft
+ x11-libs/libXinerama
+ x11-libs/libXrandr"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-devel/bison"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-Makefile.patch
+ export LDADD="${LDFLAGS}"
+ tc-export CC
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+}
diff --git a/x11-wm/cwm/cwm-99999999.ebuild b/x11-wm/cwm/cwm-99999999.ebuild
index 4048b825bd1d..74cde09ff61d 100644
--- a/x11-wm/cwm/cwm-99999999.ebuild
+++ b/x11-wm/cwm/cwm-99999999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/cwm/cwm-99999999.ebuild,v 1.1 2011/02/18 15:37:05 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/cwm/cwm-99999999.ebuild,v 1.2 2011/08/04 22:27:34 xmw Exp $
EAPI=2
@@ -11,7 +11,7 @@ inherit eutils toolchain-funcs git
DESCRIPTION="OpenBSD fork of calmwm, a clean and lightweight window manager"
HOMEPAGE="http://www.openbsd.org/cgi-bin/cvsweb/xenocara/app/cwm/
- https://github.com/chneukirchen/cwm.git"
+ http://github.com/chneukirchen/cwm"
SRC_URI=""
LICENSE="ISC"
@@ -27,14 +27,9 @@ DEPEND="${RDEPEND}
sys-devel/bison"
src_prepare() {
- epatch "${FILESDIR}"/${PN}-20110213-Makefile.patch
-}
-
-src_compile() {
+ epatch "${FILESDIR}"/${PN}-20110726-Makefile.patch
export LDADD="${LDFLAGS}"
- #export YACC=""
tc-export CC
- emake || die
}
src_install() {
diff --git a/x11-wm/cwm/files/cwm-20110726-Makefile.patch b/x11-wm/cwm/files/cwm-20110726-Makefile.patch
new file mode 100644
index 000000000000..5298ce521572
--- /dev/null
+++ b/x11-wm/cwm/files/cwm-20110726-Makefile.patch
@@ -0,0 +1,36 @@
+--- cwm-20110726/Makefile
++++ cwm-20110726/Makefile
+@@ -15,16 +15,14 @@
+ kbfunc.o mousefunc.o font.o strlcpy.o strlcat.o y.tab.o \
+ strtonum.o fgetln.o
+
+-X11BASE= /usr
+
+-CPPFLAGS+= -I${X11BASE}/include -I${X11BASE}/include/freetype2 -I.
++CPPFLAGS+= $(shell pkg-config --cflags-only-I xft)
+
+-CFLAGS+= -Wall -O2 -g
++CFLAGS+=
+
+-LDADD+= -L${X11BASE}/lib -lXft -lXrender -lX11 -lxcb -lXau -lXdmcp \
+- -lfontconfig -lexpat -lfreetype -lz -lXinerama -lXrandr -lXext
++LDADD+= $(shell pkg-config --libs xft xinerama xrandr )
+
+-MANDIR= ${X11BASE}/man/man
++MANDIR= /usr/share/man
+ MAN= cwm.1 cwmrc.5
+
+ CLEANFILES= cwm.cat1 cwmrc.cat5
+@@ -45,9 +43,9 @@
+ $(CC) -c $(CFLAGS) $(CPPFLAGS) $<
+
+ install: ${PROG}
+- install -m 755 cwm /usr/local/bin/
+- install -m 644 cwm.1 /usr/local/man/man1
+- install -m 644 cwmrc.5 /usr/local/man/man5
++ install -D -m 755 cwm $(DESTDIR)$(BINDIR)/cwm
++ install -D -m 644 cwm.1 $(DESTDIR)$(MANDIR)/man1/cwm.1
++ install -D -m 644 cwmrc.5 $(DESTDIR)$(MANDIR)/man5/cwmrc.5
+
+ #.include <bsd.prog.mk>
+ #.include <bsd.xorg.mk>