summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-08-28 03:16:13 +0000
committerMike Frysinger <vapier@gentoo.org>2013-08-28 03:16:13 +0000
commit479bd30133d686ab3ffc9db982288ca446c739e9 (patch)
tree89cc03d4f3ec493b908dbed25df34029f685091f /x11-wm
parentVersion bump. (diff)
downloadgentoo-2-479bd30133d686ab3ffc9db982288ca446c739e9.tar.gz
gentoo-2-479bd30133d686ab3ffc9db982288ca446c739e9.tar.bz2
gentoo-2-479bd30133d686ab3ffc9db982288ca446c739e9.zip
Version bump #479850 by Valery.
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/enlightenment/ChangeLog7
-rw-r--r--x11-wm/enlightenment/enlightenment-0.17.4.ebuild89
2 files changed, 95 insertions, 1 deletions
diff --git a/x11-wm/enlightenment/ChangeLog b/x11-wm/enlightenment/ChangeLog
index abf123811352..3b0bf0ee2a99 100644
--- a/x11-wm/enlightenment/ChangeLog
+++ b/x11-wm/enlightenment/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-wm/enlightenment
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/enlightenment/ChangeLog,v 1.184 2013/05/20 11:34:48 tommy Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/enlightenment/ChangeLog,v 1.185 2013/08/28 03:16:13 vapier Exp $
+
+*enlightenment-0.17.4 (28 Aug 2013)
+
+ 28 Aug 2013; Mike Frysinger <vapier@gentoo.org> +enlightenment-0.17.4.ebuild:
+ Version bump #479850 by Valery.
*enlightenment-0.17.3 (20 May 2013)
diff --git a/x11-wm/enlightenment/enlightenment-0.17.4.ebuild b/x11-wm/enlightenment/enlightenment-0.17.4.ebuild
new file mode 100644
index 000000000000..ef6cc887a492
--- /dev/null
+++ b/x11-wm/enlightenment/enlightenment-0.17.4.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/enlightenment/enlightenment-0.17.4.ebuild,v 1.1 2013/08/28 03:16:13 vapier Exp $
+
+EAPI=5
+
+MY_P=${P/_beta3/-omega}
+
+inherit autotools enlightenment
+
+DESCRIPTION="Enlightenment DR17 window manager"
+SRC_URI="http://download.enlightenment.org/releases/${MY_P}.tar.bz2"
+
+LICENSE="BSD-2"
+KEYWORDS="~amd64 ~arm ~x86"
+SLOT="0.17/${PV}"
+
+# The @ is just an anchor to expand from
+__EVRY_MODS=""
+__CONF_MODS="
+ +@applications +@dialogs +@display +@edgebindings
+ +@interaction +@intl +@keybindings +@menus
+ +@paths +@performance +@randr +@shelves +@theme
+ +@window-manipulation +@window-remembers"
+__NORM_MODS="
+ @access +@backlight +@battery +@clock +@comp +@connman +@cpufreq +@dropshadow
+ +@everything +@fileman +@fileman-opinfo +@gadman +@ibar +@ibox +@illume2
+ +@mixer +@msgbus +@notification +@pager +@quickaccess @shot +@start
+ +@syscon +@systray +@tasks +@temperature +@tiling +@winlist +@wizard +@xkbswitch"
+IUSE_E_MODULES="
+ ${__CONF_MODS//@/enlightenment_modules_conf-}
+ ${__NORM_MODS//@/enlightenment_modules_}"
+
+IUSE="emotion pam spell static-libs +udev ukit ${IUSE_E_MODULES}"
+
+RDEPEND="
+ pam? ( sys-libs/pam )
+ >=dev-libs/eet-1.7.8
+ >=dev-libs/efreet-1.7.8
+ >=dev-libs/eio-1.7.8
+ >=dev-libs/eina-1.7.8[mempool-chained]
+ || ( >=dev-libs/ecore-1.7.8[X,evas,inotify] >=dev-libs/ecore-1.7.4[xcb,evas,inotify] )
+ >=media-libs/edje-1.7.8
+ >=dev-libs/e_dbus-1.7.8[libnotify,udev?]
+ ukit? ( >=dev-libs/e_dbus-1.7.8[udev] )
+ enlightenment_modules_connman? ( >=dev-libs/e_dbus-1.7.8[connman] )
+ enlightenment_modules_shot? ( >=dev-libs/ecore-1.7.8[curl] )
+ || ( >=media-libs/evas-1.7.8[eet,X,jpeg,png] >=media-libs/evas-1.7.8[eet,xcb,jpeg,png] )
+ >=dev-libs/eeze-1.7.8
+ emotion? ( >=media-libs/emotion-1.7.8 )
+ x11-libs/xcb-util-keysyms"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/quickstart.diff
+ enlightenment_src_prepare
+}
+
+src_configure() {
+ E_ECONF+=(
+ --disable-install-sysactions
+ --disable-elementary
+ $(use_enable doc)
+ --disable-device-hal
+ $(use_enable emotion)
+ --disable-mount-hal
+ $(use_enable nls)
+ $(use_enable pam)
+ --enable-device-udev
+ $(use_enable udev mount-eeze)
+ $(use_enable ukit mount-udisks)
+ --disable-physics
+ )
+ local u c
+ for u in ${IUSE_E_MODULES} ; do
+ u=${u#+}
+ c=${u#enlightenment_modules_}
+ E_ECONF+=( $(use_enable ${u} ${c}) )
+ done
+ enlightenment_src_configure
+}
+
+src_install() {
+ enlightenment_src_install
+ insinto /etc/enlightenment
+ newins "${FILESDIR}"/gentoo-sysactions.conf sysactions.conf
+}