summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2013-05-29 06:32:20 +0000
committerMichael Weber <xmw@gentoo.org>2013-05-29 06:32:20 +0000
commit3e167110a909bb16fa0dbc1cc2c7a3339ac5b8ef (patch)
treec3b35f3f63e4f48de514f20172ec1c06c9e4d15f /x11-wm
parentsci-chemistry/coot: Drop version restriction from clipper dep (diff)
downloadgentoo-2-3e167110a909bb16fa0dbc1cc2c7a3339ac5b8ef.tar.gz
gentoo-2-3e167110a909bb16fa0dbc1cc2c7a3339ac5b8ef.tar.bz2
gentoo-2-3e167110a909bb16fa0dbc1cc2c7a3339ac5b8ef.zip
Fix arrunlib/gcc handling (bug 465260, thanks Michael Mair-Keimberger)
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/notion/ChangeLog6
-rw-r--r--x11-wm/notion/notion-3_p2013030200.ebuild9
-rw-r--r--x11-wm/notion/notion-9999.ebuild9
3 files changed, 21 insertions, 3 deletions
diff --git a/x11-wm/notion/ChangeLog b/x11-wm/notion/ChangeLog
index 7ceb9c9927ee..f0adb5a15222 100644
--- a/x11-wm/notion/ChangeLog
+++ b/x11-wm/notion/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-wm/notion
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/notion/ChangeLog,v 1.6 2013/05/11 07:55:07 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/notion/ChangeLog,v 1.7 2013/05/29 06:32:20 xmw Exp $
+
+ 29 May 2013; Michael Weber <xmw@gentoo.org> notion-3_p2013030200.ebuild,
+ notion-9999.ebuild:
+ Fix arrunlib/gcc handling (bug 465260, thanks Michael Mair-Keimberger)
11 May 2013; Patrick Lauer <patrick@gentoo.org> notion-3_p2013030200.ebuild,
notion-9999.ebuild:
diff --git a/x11-wm/notion/notion-3_p2013030200.ebuild b/x11-wm/notion/notion-3_p2013030200.ebuild
index 40c690fc962e..e4d542361250 100644
--- a/x11-wm/notion/notion-3_p2013030200.ebuild
+++ b/x11-wm/notion/notion-3_p2013030200.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/notion/notion-3_p2013030200.ebuild,v 1.2 2013/05/11 07:55:07 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/notion/notion-3_p2013030200.ebuild,v 1.3 2013/05/29 06:32:20 xmw Exp $
EAPI="4"
@@ -41,6 +41,8 @@ src_prepare() {
-e "s:^\(VARDIR=\).*$:\1${ROOT}var/cache/${PN}:" \
-e "s:^\(X11_PREFIX=\).*:\1\$(PREFIX)/usr:" \
-i system-autodetect.mk || die
+ sed -e 's/gcc/$(CC)/g' \
+ -i ioncore/Makefile || die
export STRIPPROG=true
use nls || export DEFINES=" -DCF_NO_LOCALE -DCF_NO_GETTEXT"
@@ -56,6 +58,11 @@ src_prepare() {
tc-export CC
}
+src_compile() {
+ emake CC="$(tc-getCC)" AR="$(tc-getAR)" \
+ RANLIB="$(tc-getRANLIB)"
+}
+
src_install() {
emake DESTDIR="${D}" install
diff --git a/x11-wm/notion/notion-9999.ebuild b/x11-wm/notion/notion-9999.ebuild
index 2f0789034737..560c8fa573f1 100644
--- a/x11-wm/notion/notion-9999.ebuild
+++ b/x11-wm/notion/notion-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/notion/notion-9999.ebuild,v 1.6 2013/05/11 07:55:07 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/notion/notion-9999.ebuild,v 1.7 2013/05/29 06:32:20 xmw Exp $
EAPI="4"
@@ -41,6 +41,8 @@ src_prepare() {
-e "s:^\(VARDIR=\).*$:\1${ROOT}var/cache/${PN}:" \
-e "s:^\(X11_PREFIX=\).*:\1\$(PREFIX)/usr:" \
-i system-autodetect.mk || die
+ sed -e 's/gcc/$(CC)/g' \
+ -i ioncore/Makefile || die
export STRIPPROG=true
use nls || export DEFINES=" -DCF_NO_LOCALE -DCF_NO_GETTEXT"
@@ -56,6 +58,11 @@ src_prepare() {
tc-export CC
}
+src_compile() {
+ emake CC="$(tc-getCC)" AR="$(tc-getAR)" \
+ RANLIB="$(tc-getRANLIB)"
+}
+
src_install() {
emake DESTDIR="${D}" install