summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2007-01-27 14:54:29 +0000
committerCédric Krier <cedk@gentoo.org>2007-01-27 14:54:29 +0000
commit39f38993c0f5846930d19c289eb54c7fb513a3cb (patch)
treefc760013e240756e9d435b5d72ec18d729dd5518 /x11-wm
parentFix the linker script so that it handles the .gnu.hash section (thanks to Vap... (diff)
downloadgentoo-2-39f38993c0f5846930d19c289eb54c7fb513a3cb.tar.gz
gentoo-2-39f38993c0f5846930d19c289eb54c7fb513a3cb.tar.bz2
gentoo-2-39f38993c0f5846930d19c289eb54c7fb513a3cb.zip
Version bump
(Portage version: 2.1.1-r2)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/dwm/ChangeLog7
-rw-r--r--x11-wm/dwm/dwm-3.2.2.ebuild93
-rw-r--r--x11-wm/dwm/files/digest-dwm-3.2.23
3 files changed, 102 insertions, 1 deletions
diff --git a/x11-wm/dwm/ChangeLog b/x11-wm/dwm/ChangeLog
index 00c554ad277a..9b299b25eefe 100644
--- a/x11-wm/dwm/ChangeLog
+++ b/x11-wm/dwm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-wm/dwm
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/dwm/ChangeLog,v 1.7 2007/01/21 11:28:08 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/dwm/ChangeLog,v 1.8 2007/01/27 14:54:29 cedk Exp $
+
+*dwm-3.2.2 (27 Jan 2007)
+
+ 27 Jan 2007; Cedric Krier <cedk@gentoo.org> +dwm-3.2.2.ebuild:
+ Version bump
21 Jan 2007; Markus Rothe <corsair@gentoo.org> dwm-3.1.ebuild:
Added ~ppc64
diff --git a/x11-wm/dwm/dwm-3.2.2.ebuild b/x11-wm/dwm/dwm-3.2.2.ebuild
new file mode 100644
index 000000000000..bf5583a9558d
--- /dev/null
+++ b/x11-wm/dwm/dwm-3.2.2.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/dwm/dwm-3.2.2.ebuild,v 1.1 2007/01/27 14:54:29 cedk Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="a dynamic window manager for X11"
+HOMEPAGE="http://suckless.org/view/dynamic+window+manager"
+SRC_URI="http://suckless.org/download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="savedconfig"
+
+DEPEND="x11-libs/libX11"
+RDEPEND=${DEPEND}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i \
+ -e "s/.*strip.*//" \
+ Makefile || die "sed failed"
+
+ sed -i \
+ -e "s/CFLAGS = -Os/CFLAGS +=/" \
+ -e "s/LDFLAGS =/LDFLAGS +=/" \
+ config.mk || die "sed failed"
+
+ if use savedconfig; then
+ local conf root
+ [[ -r config.h ]] && rm config.h
+ for conf in ${PF} ${P} ${PN}; do
+ for root in "${PORTAGE_CONFIGROOT}" "${ROOT}" /; do
+ configfile=${root}etc/portage/savedconfig/${conf}.config.h
+ if [[ -r ${configfile} ]]; then
+ elog "Found your ${configfile} and using it."
+ cp ${configfile} "${S}"/config.h
+ return 0
+ fi
+ done
+ done
+ ewarn "Could not locate user configfile, so we will save a default one."
+ fi
+}
+
+src_compile() {
+ local msg
+ use savedconfig && msg=", please check the configfile"
+ emake CC=$(tc-getCC) || die "emake failed${msg}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install || die "emake install failed"
+
+ insinto /usr/share/${PN}
+ newins config.h ${PF}.config.h
+
+ exeinto /etc/X11/Sessions
+ newexe "${FILESDIR}"/dwm-session dwm
+
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}"/dwm.desktop
+
+ dodoc README
+}
+
+pkg_preinst() {
+ if use savedconfig; then
+ mv "${D}"/usr/share/${PN}/${PF}.config.h "${T}"/ || die
+ fi
+}
+
+pkg_postinst() {
+ if use savedconfig; then
+ local config_dir="${PORTAGE_CONFIGROOT:-${ROOT}}/etc/portage/savedconfig"
+ elog "Saving this build config to ${config_dir}/${PF}.config.h"
+ einfo "Read this ebuild for more info on how to take advantage of this option."
+ mkdir -p "${config_dir}"
+ cp "${T}"/${PF}.config.h "${config_dir}"/${PF}.config.h
+ fi
+ einfo "This ebuild has support for user defined configs"
+ einfo "Please read this ebuild for more details and re-emerge as needed"
+ einfo "if you want to add or remove functionality for ${PN}"
+ if ! has_version x11-misc/dmenu; then
+ elog "Installing ${PN} without x11-misc/dmenu"
+ einfo "To have a menu you can install x11-misc/dmenu"
+ fi
+ einfo "You can custom status bar with a script in HOME/.dwm/dwmrc"
+ einfo "the ouput is redirected to the standard input of dwm"
+}
diff --git a/x11-wm/dwm/files/digest-dwm-3.2.2 b/x11-wm/dwm/files/digest-dwm-3.2.2
new file mode 100644
index 000000000000..4626ab813100
--- /dev/null
+++ b/x11-wm/dwm/files/digest-dwm-3.2.2
@@ -0,0 +1,3 @@
+MD5 14b9bbfc0d36117c135de5eaba50c880 dwm-3.2.2.tar.gz 17388
+RMD160 755433e752a2ef7574f16ef26303bf66766e6891 dwm-3.2.2.tar.gz 17388
+SHA256 dc7086619242fe1e661dcb27e850a2f431fcee8dbf246b46ea9d5d23784fd6cc dwm-3.2.2.tar.gz 17388