summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2010-05-27 16:51:03 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2010-05-27 16:51:03 +0000
commit213bd49252c10d18c304c3da853ea342c975515e (patch)
tree18829318dec7579b040c25a30d25198a28e919b2 /x11-wm
parentInstall Perl stuff in vendor-dir (bug #294892). Use newer configure flags. Re... (diff)
downloadgentoo-2-213bd49252c10d18c304c3da853ea342c975515e.tar.gz
gentoo-2-213bd49252c10d18c304c3da853ea342c975515e.tar.bz2
gentoo-2-213bd49252c10d18c304c3da853ea342c975515e.zip
Respect user flags wrt bug 237698, do not pre-strip files wrt bug 252118
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/aewm/ChangeLog7
-rw-r--r--x11-wm/aewm/aewm-1.2.7.ebuild22
-rw-r--r--x11-wm/aewm/files/aewm-1.2.7-ldflags.patch38
3 files changed, 62 insertions, 5 deletions
diff --git a/x11-wm/aewm/ChangeLog b/x11-wm/aewm/ChangeLog
index 4e5032c229b5..eb2ac1baba12 100644
--- a/x11-wm/aewm/ChangeLog
+++ b/x11-wm/aewm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-wm/aewm
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/aewm/ChangeLog,v 1.24 2010/01/17 16:16:45 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/aewm/ChangeLog,v 1.25 2010/05/27 16:51:03 xarthisius Exp $
+
+ 27 May 2010; Kacper Kowalik <xarthisius@gentoo.org> aewm-1.2.7.ebuild,
+ +files/aewm-1.2.7-ldflags.patch:
+ Respect user flags wrt bug 237698, do not pre-strip files wrt bug 252118.
+ Thanks Diego for reporting.
17 Jan 2010; Ulrich Mueller <ulm@gentoo.org> aewm-1.2.7.ebuild:
Change LICENSE, "aewm" is the same as "MIT 9wm".
diff --git a/x11-wm/aewm/aewm-1.2.7.ebuild b/x11-wm/aewm/aewm-1.2.7.ebuild
index 128d7035fb28..b9d6c8bff16d 100644
--- a/x11-wm/aewm/aewm-1.2.7.ebuild
+++ b/x11-wm/aewm/aewm-1.2.7.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/aewm/aewm-1.2.7.ebuild,v 1.9 2010/01/17 16:16:45 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/aewm/aewm-1.2.7.ebuild,v 1.10 2010/05/27 16:51:03 xarthisius Exp $
+
+inherit eutils toolchain-funcs
DESCRIPTION="A minimalistic X11 window manager."
HOMEPAGE="http://www.red-bean.com/~decklin/software/aewm/"
@@ -36,11 +38,23 @@ src_unpack() {
sed -i \
-e 's/lucidasans-10/-adobe-helvetica-bold-r-normal--*-120-*-*-*-*-*-*/' \
src/aewmrc.sample || die "sed failed"
+
+ # QA: Remove stripping
+ sed -i \
+ -e 's/install -s/install /' \
+ {src,clients}/Makefile || die "sed failed"
+
+ epatch "${FILESDIR}"/${P}-ldflags.patch
+}
+
+src_compile() {
+ tc-export CC
+ emake CC="${CC}" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" || die
}
src_install() {
- dodir /usr/bin
- dodir /usr/share/man/man1
+ dodir /usr/bin || die
+ dodir /usr/share/man/man1 || die
emake \
DESTDIR="${D}" \
@@ -48,5 +62,5 @@ src_install() {
XROOT="/usr" \
install || die "emake install failed"
- dodoc DESIGN NEWS README TODO
+ dodoc DESIGN NEWS README TODO || die
}
diff --git a/x11-wm/aewm/files/aewm-1.2.7-ldflags.patch b/x11-wm/aewm/files/aewm-1.2.7-ldflags.patch
new file mode 100644
index 000000000000..e10808f00acb
--- /dev/null
+++ b/x11-wm/aewm/files/aewm-1.2.7-ldflags.patch
@@ -0,0 +1,38 @@
+Respect user LDFLAGS
+
+http://bugs.gentoo.org/show_bug.cgi?id=237698
+
+--- src/Makefile
++++ src/Makefile
+@@ -49,7 +49,7 @@
+ all: $(PROG)
+
+ $(PROG): $(OBJS)
+- $(CC) $(OBJS) $(LDPATH) $(LIBS) -o $@
++ $(CC) $(CFLAGS) $(LDFLAGS) $(OBJS) $(LDPATH) $(LIBS) -o $@
+
+ $(OBJS): %.o: %.c $(HEADERS)
+ $(CC) $(CFLAGS) $(DEFINES) $(INCLUDES) -c $< -o $@
+--- clients/Makefile
++++ clients/Makefile
+@@ -48,16 +48,16 @@
+ set-gnome-pda: $(MYLIBDIR)/panel.o $(AELIBDIR)/gnome-pda.o
+
+ $(GTKPROGS): %: %.o
+- $(CC) $^ $(GTKLIBS) -o $@
++ $(CC) $(CFLAGS) $(LDFLAGS) $^ $(GTKLIBS) -o $@
+
+ $(XAWPROGS): %: %.o
+- $(CC) $^ $(XAWLIBS) -o $@
++ $(CC) $(CFLAGS) $(LDFLAGS) $^ $(XAWLIBS) -o $@
+
+ $(X11PROGS): %: %.o
+- $(CC) $^ $(X11LIBS) -o $@
++ $(CC) $(CFLAGS) $(LDFLAGS) $^ $(X11LIBS) -o $@
+
+ $(ETCPROGS): %: %.o
+- $(CC) $^ -o $@
++ $(CC) $(CFLAGS) $(LDFLAGS) $^ -o $@
+
+ # --------------------------------------------------------------------
+