summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2009-05-09 13:54:09 +0000
committerCédric Krier <cedk@gentoo.org>2009-05-09 13:54:09 +0000
commit1fe96b8040451bc008945ec11c2bf9b4b49ce77f (patch)
treec6218720c7790c4b0d1686e6e289e331e70e8721 /x11-wm
parentalpha/sparc stable wrt #264646 (diff)
downloadgentoo-2-1fe96b8040451bc008945ec11c2bf9b4b49ce77f.tar.gz
gentoo-2-1fe96b8040451bc008945ec11c2bf9b4b49ce77f.tar.bz2
gentoo-2-1fe96b8040451bc008945ec11c2bf9b4b49ce77f.zip
Version bump
(Portage version: 2.1.6.7/cvs/Linux i686)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/dwm/ChangeLog7
-rw-r--r--x11-wm/dwm/dwm-5.5.ebuild80
2 files changed, 86 insertions, 1 deletions
diff --git a/x11-wm/dwm/ChangeLog b/x11-wm/dwm/ChangeLog
index 4b467509b33a..2c73dda907dc 100644
--- a/x11-wm/dwm/ChangeLog
+++ b/x11-wm/dwm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-wm/dwm
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/dwm/ChangeLog,v 1.59 2009/02/15 15:57:11 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/dwm/ChangeLog,v 1.60 2009/05/09 13:54:09 cedk Exp $
+
+*dwm-5.5 (09 May 2009)
+
+ 09 May 2009; Cédric Krier <cedk@gentoo.org> +dwm-5.5.ebuild:
+ Version bump
15 Feb 2009; Markus Meier <maekke@gentoo.org> dwm-5.3.1.ebuild:
x86 stable, bug #258305
diff --git a/x11-wm/dwm/dwm-5.5.ebuild b/x11-wm/dwm/dwm-5.5.ebuild
new file mode 100644
index 000000000000..424e99f83938
--- /dev/null
+++ b/x11-wm/dwm/dwm-5.5.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/dwm/dwm-5.5.ebuild,v 1.1 2009/05/09 13:54:09 cedk Exp $
+
+inherit toolchain-funcs savedconfig
+
+DESCRIPTION="a dynamic window manager for X11"
+HOMEPAGE="http://www.suckless.org/dwm/"
+SRC_URI="http://code.suckless.org/dl/dwm/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="xinerama"
+
+DEPEND="x11-libs/libX11
+ xinerama? (
+ x11-proto/xineramaproto
+ x11-libs/libXinerama
+ )"
+RDEPEND="${DEPEND}
+ x11-apps/xsetroot"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i \
+ -e "s/CFLAGS = -std=c99 -pedantic -Wall -Os/CFLAGS += -std=c99 -pedantic -Wall -g/" \
+ -e "s/LDFLAGS = -s/LDFLAGS += -g/" \
+ -e "s/#XINERAMALIBS =/XINERAMALIBS ?=/" \
+ -e "s/#XINERAMAFLAGS =/XINERAMAFLAGS ?=/" \
+ config.mk || die "sed failed"
+
+ if use savedconfig; then
+ restore_config config.h
+ fi
+}
+
+src_compile() {
+ local msg
+ use savedconfig && msg=", please check the configfile"
+ if use xinerama; then
+ emake CC=$(tc-getCC) || die "emake failed${msg}"
+ else
+ emake CC=$(tc-getCC) XINERAMAFLAGS="" XINERAMALIBS="" \
+ || die "emake failed${msg}"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install || die "emake install failed"
+
+ insinto /usr/share/${PN}
+ newins config.h ${PF}.config.h
+
+ exeinto /etc/X11/Sessions
+ newexe "${FILESDIR}"/dwm-session2 dwm
+
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}"/dwm.desktop
+
+ dodoc README
+
+ save_config config.h
+}
+
+pkg_postinst() {
+ einfo "This ebuild has support for user defined configs"
+ einfo "Please read this ebuild for more details and re-emerge as needed"
+ einfo "if you want to add or remove functionality for ${PN}"
+ if ! has_version x11-misc/dmenu; then
+ elog "Installing ${PN} without x11-misc/dmenu"
+ einfo "To have a menu you can install x11-misc/dmenu"
+ fi
+ einfo "You can custom status bar with a script in HOME/.dwm/dwmrc"
+ einfo "the ouput is redirected to the standard input of dwm"
+ einfo "Since dwm-5.4, status info in the bar must be set like this:"
+ einfo "xsetroot -name \"\`date\` \`uptime | sed 's/.*,//'\`\""
+}