summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorDavid Shakaryan <omp@gentoo.org>2008-04-24 08:57:32 +0000
committerDavid Shakaryan <omp@gentoo.org>2008-04-24 08:57:32 +0000
commit1c716753af399f4eb0664509399121e7401875ad (patch)
tree195cb0af04201137f19fddc795c2163ffd5b61ab /x11-wm
parentCompile with GCC 4.3; patch from Fedora. (bug #217980) (diff)
downloadgentoo-2-1c716753af399f4eb0664509399121e7401875ad.tar.gz
gentoo-2-1c716753af399f4eb0664509399121e7401875ad.tar.bz2
gentoo-2-1c716753af399f4eb0664509399121e7401875ad.zip
Compile with GCC 4.3; patch from Fedora. (bug #217978)
(Portage version: 2.1.5_rc3)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/blackbox/ChangeLog8
-rw-r--r--x11-wm/blackbox/blackbox-0.70.1.ebuild13
-rw-r--r--x11-wm/blackbox/files/blackbox-0.70.1-gcc-4.3.patch106
3 files changed, 123 insertions, 4 deletions
diff --git a/x11-wm/blackbox/ChangeLog b/x11-wm/blackbox/ChangeLog
index 6e0b3a80df4b..704486c7d282 100644
--- a/x11-wm/blackbox/ChangeLog
+++ b/x11-wm/blackbox/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-wm/blackbox
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/blackbox/ChangeLog,v 1.59 2007/07/22 04:11:16 omp Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/blackbox/ChangeLog,v 1.60 2008/04/24 08:57:32 omp Exp $
+
+ 24 Apr 2008; David Shakaryan <omp@gentoo.org>
+ +files/blackbox-0.70.1-gcc-4.3.patch, blackbox-0.70.1.ebuild:
+ Compile with GCC 4.3; patch from Fedora. (bug #217978)
22 Jul 2007; David Shakaryan <omp@gentoo.org> blackbox-0.70.0.ebuild:
Remove virtual/x11 from dependencies.
diff --git a/x11-wm/blackbox/blackbox-0.70.1.ebuild b/x11-wm/blackbox/blackbox-0.70.1.ebuild
index abad7bda3b6f..511aacc4d97f 100644
--- a/x11-wm/blackbox/blackbox-0.70.1.ebuild
+++ b/x11-wm/blackbox/blackbox-0.70.1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/blackbox/blackbox-0.70.1.ebuild,v 1.7 2007/06/14 19:51:33 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/blackbox/blackbox-0.70.1.ebuild,v 1.8 2008/04/24 08:57:32 omp Exp $
+
+inherit eutils
DESCRIPTION="A small, fast, full-featured window manager for X"
HOMEPAGE="http://blackboxwm.sourceforge.net/"
@@ -22,6 +24,13 @@ DEPEND="${RDEPEND}
PROVIDE="virtual/blackbox"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-gcc-4.3.patch"
+}
+
src_compile() {
econf \
--sysconfdir=/etc/X11/${PN} \
diff --git a/x11-wm/blackbox/files/blackbox-0.70.1-gcc-4.3.patch b/x11-wm/blackbox/files/blackbox-0.70.1-gcc-4.3.patch
new file mode 100644
index 000000000000..1026bd5c80ee
--- /dev/null
+++ b/x11-wm/blackbox/files/blackbox-0.70.1-gcc-4.3.patch
@@ -0,0 +1,106 @@
+diff -Naupr blackbox-0.70.1.orig/lib/Image.cc blackbox-0.70.1/lib/Image.cc
+--- blackbox-0.70.1.orig/lib/Image.cc 2005-04-08 17:41:09.000000000 +0200
++++ blackbox-0.70.1/lib/Image.cc 2008-02-24 08:31:28.000000000 +0100
+@@ -42,8 +42,9 @@
+
+ #include <assert.h>
+ #include <math.h>
+-#include <stdio.h>
+-#include <stdlib.h>
++#include <cstdio>
++#include <cstdlib>
++#include <cstring>
+
+ // #define COLORTABLE_DEBUG
+ // #define MITSHM_DEBUG
+diff -Naupr blackbox-0.70.1.orig/lib/Resource.cc blackbox-0.70.1/lib/Resource.cc
+--- blackbox-0.70.1.orig/lib/Resource.cc 2005-04-06 23:16:50.000000000 +0200
++++ blackbox-0.70.1/lib/Resource.cc 2008-02-24 08:33:11.000000000 +0100
+@@ -28,7 +28,8 @@
+ #include <X11/Xlib.h>
+ #include <X11/Xresource.h>
+
+-#include <stdio.h>
++#include <cstdio>
++#include <cstring>
+
+
+ bt::Resource::Resource(void)
+diff -Naupr blackbox-0.70.1.orig/lib/XDG.cc blackbox-0.70.1/lib/XDG.cc
+--- blackbox-0.70.1.orig/lib/XDG.cc 2005-04-06 16:04:38.000000000 +0200
++++ blackbox-0.70.1/lib/XDG.cc 2008-02-24 08:34:11.000000000 +0100
+@@ -25,7 +25,8 @@
+ #include "Util.hh"
+ #include "XDG.hh"
+
+-#include <stdlib.h>
++#include <cstdlib>
++#include <algorithm>
+
+
+ // make sure directory names end with a slash
+diff -Naupr blackbox-0.70.1.orig/src/BlackboxResource.cc blackbox-0.70.1/src/BlackboxResource.cc
+--- blackbox-0.70.1.orig/src/BlackboxResource.cc 2005-10-18 09:34:46.000000000 +0200
++++ blackbox-0.70.1/src/BlackboxResource.cc 2008-02-24 08:34:49.000000000 +0100
+@@ -33,6 +33,8 @@
+ #include <X11/Xutil.h>
+ #include <X11/cursorfont.h>
+
++#include <cstring>
++
+
+ BlackboxResource::BlackboxResource(const std::string& rc): rc_file(rc) {
+ screen_resources = 0;
+diff -Naupr blackbox-0.70.1.orig/src/main.cc blackbox-0.70.1/src/main.cc
+--- blackbox-0.70.1.orig/src/main.cc 2005-01-03 10:42:57.000000000 +0100
++++ blackbox-0.70.1/src/main.cc 2008-02-24 08:37:16.000000000 +0100
+@@ -34,7 +34,8 @@
+ #include "blackbox.hh"
+ #include "../version.h"
+
+-#include <stdio.h>
++#include <cstdio>
++#include <cstring>
+
+
+ static void showHelp(int exitval) {
+diff -Naupr blackbox-0.70.1.orig/src/Screen.cc blackbox-0.70.1/src/Screen.cc
+--- blackbox-0.70.1.orig/src/Screen.cc 2005-10-18 10:07:22.000000000 +0200
++++ blackbox-0.70.1/src/Screen.cc 2008-02-24 08:35:46.000000000 +0100
+@@ -45,8 +45,9 @@
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <assert.h>
+-#include <ctype.h>
+ #include <dirent.h>
++#include <cctype>
++#include <cstring>
+
+
+ static bool running = true;
+diff -Naupr blackbox-0.70.1.orig/src/ScreenResource.cc blackbox-0.70.1/src/ScreenResource.cc
+--- blackbox-0.70.1.orig/src/ScreenResource.cc 2005-04-13 07:54:08.000000000 +0200
++++ blackbox-0.70.1/src/ScreenResource.cc 2008-02-24 08:36:31.000000000 +0100
+@@ -33,6 +33,8 @@
+
+ #include <assert.h>
+
++#include <cstring>
++
+
+ static const int iconify_width = 9;
+ static const int iconify_height = 9;
+diff -Naupr blackbox-0.70.1.orig/util/bsetroot.cc blackbox-0.70.1/util/bsetroot.cc
+--- blackbox-0.70.1.orig/util/bsetroot.cc 2005-03-15 08:01:37.000000000 +0100
++++ blackbox-0.70.1/util/bsetroot.cc 2008-02-24 08:38:41.000000000 +0100
+@@ -30,7 +30,9 @@
+ #include <cctype>
+
+ #include <X11/Xatom.h>
+-#include <stdio.h>
++#include <cstdio>
++#include <cstdlib>
++#include <cstring>
+
+
+ // ignore all X errors