summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-10-18 21:52:54 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-10-18 21:52:54 +0000
commit14a2dbcaab8da5986b7706246803cde9b5179ab5 (patch)
tree129059702661a7fb9b6eb1bb8b2074ad33e83e90 /x11-wm
parentnew snapshot (diff)
downloadgentoo-2-14a2dbcaab8da5986b7706246803cde9b5179ab5.tar.gz
gentoo-2-14a2dbcaab8da5986b7706246803cde9b5179ab5.tar.bz2
gentoo-2-14a2dbcaab8da5986b7706246803cde9b5179ab5.zip
new snapshot
(Portage version: 2.2.0_alpha68/cvs/Linux x86_64)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/openbox/ChangeLog8
-rw-r--r--x11-wm/openbox/openbox-3.5.0_p20111019.ebuild63
-rw-r--r--x11-wm/openbox/openbox-9999.ebuild5
3 files changed, 71 insertions, 5 deletions
diff --git a/x11-wm/openbox/ChangeLog b/x11-wm/openbox/ChangeLog
index 5352e52be338..f44e3300b8fc 100644
--- a/x11-wm/openbox/ChangeLog
+++ b/x11-wm/openbox/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-wm/openbox
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/openbox/ChangeLog,v 1.233 2011/10/18 20:57:22 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/openbox/ChangeLog,v 1.234 2011/10/18 21:52:54 hwoarang Exp $
+
+*openbox-3.5.0_p20111019 (18 Oct 2011)
+
+ 18 Oct 2011; Markos Chandras <hwoarang@gentoo.org>
+ +openbox-3.5.0_p20111019.ebuild, openbox-9999.ebuild:
+ new snapshot
18 Oct 2011; Jeroen Roovers <jer@gentoo.org> openbox-3.5.0-r1.ebuild:
Stable for HPPA (bug #383475).
diff --git a/x11-wm/openbox/openbox-3.5.0_p20111019.ebuild b/x11-wm/openbox/openbox-3.5.0_p20111019.ebuild
new file mode 100644
index 000000000000..723a77a79289
--- /dev/null
+++ b/x11-wm/openbox/openbox-3.5.0_p20111019.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/openbox/openbox-3.5.0_p20111019.ebuild,v 1.1 2011/10/18 21:52:54 hwoarang Exp $
+
+EAPI="2"
+WANT_AUTOMAKE="1.9"
+inherit multilib autotools eutils
+
+DESCRIPTION="A standards compliant, fast, light-weight, extensible window manager"
+HOMEPAGE="http://openbox.org/"
+SRC_URI="http://dev.gentoo.org/~hwoarang/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug imlib nls session startup-notification static-libs"
+
+RDEPEND="dev-libs/glib:2
+ >=dev-libs/libxml2-2.0
+ dev-python/pyxdg
+ >=media-libs/fontconfig-2
+ x11-libs/libXft
+ x11-libs/libXrandr
+ x11-libs/libXt
+ >=x11-libs/pango-1.8[X]
+ imlib? ( media-libs/imlib2 )
+ startup-notification? ( >=x11-libs/startup-notification-0.8 )
+ x11-libs/libXinerama"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ dev-util/pkgconfig
+ x11-proto/xextproto
+ x11-proto/xf86vidmodeproto
+ x11-proto/xineramaproto"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-gnome-session-3.4.9.patch
+ sed -i -e "s:-O0 -ggdb ::" "${S}"/m4/openbox.m4 || die
+ eautopoint
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --docdir=/usr/share/doc/${PF} \
+ $(use_enable debug) \
+ $(use_enable imlib imlib2) \
+ $(use_enable nls) \
+ $(use_enable startup-notification) \
+ $(use_enable session session-management) \
+ $(use_enable static-libs static) \
+ --with-x
+}
+
+src_install() {
+ dodir /etc/X11/Sessions
+ echo "/usr/bin/openbox-session" > "${D}/etc/X11/Sessions/${PN}"
+ fperms a+x /etc/X11/Sessions/${PN}
+ emake DESTDIR="${D}" install || die "emake install failed"
+ ! use static-libs && rm "${D}"/usr/$(get_libdir)/lib{obt,obrender}.la
+}
diff --git a/x11-wm/openbox/openbox-9999.ebuild b/x11-wm/openbox/openbox-9999.ebuild
index d17066437911..21fddf9d16ac 100644
--- a/x11-wm/openbox/openbox-9999.ebuild
+++ b/x11-wm/openbox/openbox-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/openbox/openbox-9999.ebuild,v 1.12 2011/09/20 22:49:27 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/openbox/openbox-9999.ebuild,v 1.13 2011/10/18 21:52:54 hwoarang Exp $
EAPI="2"
WANT_AUTOMAKE="1.9"
@@ -36,12 +36,9 @@ DEPEND="${RDEPEND}
src_prepare() {
epatch "${FILESDIR}"/${PN}-gnome-session-3.4.9.patch
- epatch "${FILESDIR}"/${PN}-as-needed.patch
# Lets try to replace docbook-to-man with docbook2man.pl since
# Gentoo does not provide (why?) a docbook-to-man package
sed -i -e "s:docbook-to-man:docbook2man.pl:" "${S}"/Makefile.am
- # Use the patch from 3.5.0 package until it hits master branch
- epatch "${FILESDIR}"/${PN}-3.5.0-configure-imlib2.patch
eautopoint
eautoreconf
}