summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Kolmodin <kolmodin@gentoo.org>2008-09-06 19:04:11 +0000
committerLennart Kolmodin <kolmodin@gentoo.org>2008-09-06 19:04:11 +0000
commit300fee43c102867cbc7ec0b7e15880b7d201d434 (patch)
treed762fbf230b8df97c97b1c4e821f56e16566e524 /x11-wm/xmonad
parentfix high score location. patch from Dannee McGuire via bug #236878 (diff)
downloadgentoo-2-300fee43c102867cbc7ec0b7e15880b7d201d434.tar.gz
gentoo-2-300fee43c102867cbc7ec0b7e15880b7d201d434.tar.bz2
gentoo-2-300fee43c102867cbc7ec0b7e15880b7d201d434.zip
Bump xmonad to version 0.8
(Portage version: 2.1.4.4)
Diffstat (limited to 'x11-wm/xmonad')
-rw-r--r--x11-wm/xmonad/ChangeLog7
-rw-r--r--x11-wm/xmonad/xmonad-0.8.ebuild57
2 files changed, 63 insertions, 1 deletions
diff --git a/x11-wm/xmonad/ChangeLog b/x11-wm/xmonad/ChangeLog
index 23637f8f8e6e..fe369e7e6dde 100644
--- a/x11-wm/xmonad/ChangeLog
+++ b/x11-wm/xmonad/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-wm/xmonad
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/xmonad/ChangeLog,v 1.7 2008/08/07 22:03:15 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/xmonad/ChangeLog,v 1.8 2008/09/06 19:04:11 kolmodin Exp $
+
+*xmonad-0.8 (06 Sep 2008)
+
+ 06 Sep 2008; Lennart Kolmodin <kolmodin@gentoo.org> +xmonad-0.8.ebuild:
+ Bump to newest version
07 Aug 2008; Jeroen Roovers <jer@gentoo.org> xmonad-0.7.ebuild:
Marked ~hppa too.
diff --git a/x11-wm/xmonad/xmonad-0.8.ebuild b/x11-wm/xmonad/xmonad-0.8.ebuild
new file mode 100644
index 000000000000..8cd77b0ceaa5
--- /dev/null
+++ b/x11-wm/xmonad/xmonad-0.8.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/xmonad/xmonad-0.8.ebuild,v 1.1 2008/09/06 19:04:11 kolmodin Exp $
+
+CABAL_FEATURES="bin lib profile haddock"
+
+inherit haskell-cabal eutils
+
+DESCRIPTION="A lightweight X11 window manager"
+HOMEPAGE="http://www.xmonad.org/"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~sparc ~x86"
+
+DEPEND="dev-haskell/mtl
+ >=dev-haskell/x11-1.4.1
+ >=dev-lang/ghc-6.6
+ >=dev-haskell/cabal-1.2"
+RDEPEND="${DEPEND}"
+
+SAMPLE_CONFIG="xmonad.hs"
+SAMPLE_CONFIG_LOC="man"
+
+src_install() {
+ cabal_src_install
+
+ echo -e "#!/bin/sh\n/usr/bin/xmonad" > "${T}/${PN}"
+ exeinto /etc/X11/Sessions
+ doexe "${T}/${PN}"
+
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}/${PN}.desktop"
+
+ doman man/xmonad.1
+
+ dodoc CONFIG README "${SAMPLE_CONFIG_LOC}/${SAMPLE_CONFIG}"
+}
+
+pkg_postinst() {
+ ghc-package_pkg_postinst
+
+ elog "A sample ${SAMPLE_CONFIG} configuration file can be found here:"
+ elog " /usr/share/doc/${PF}/${SAMPLE_CONFIG}"
+ elog "The parameters in this file are the defaults used by xmonad."
+ elog "To customize xmonad, copy this file to:"
+ elog " ~/.xmonad/${SAMPLE_CONFIG}"
+ elog "After editing, use 'mod-q' to dynamically restart xmonad "
+ elog "(where the 'mod' key defaults to 'Alt')."
+ elog ""
+ elog "Read the README or man page for more information, and to see "
+ elog "other possible configurations go to:"
+ elog " http://haskell.org/haskellwiki/Xmonad/Config_archive"
+ elog "Please note that many of these configurations will require the "
+ elog "x11-wm/xmonad-contrib package to be installed."
+}