summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-06-04 03:33:03 +0000
committerAchim Gottinger <achim@gentoo.org>2001-06-04 03:33:03 +0000
commitb1560dad189ce2b107c03ce6afc20081a07c4979 (patch)
tree24751ccd78f3fa895d818efd6bd43947884c8497 /x11-wm/xfce
parentAdded yet another game, it's a dirty job but someone has to do it :-) (diff)
downloadgentoo-2-b1560dad189ce2b107c03ce6afc20081a07c4979.tar.gz
gentoo-2-b1560dad189ce2b107c03ce6afc20081a07c4979.tar.bz2
gentoo-2-b1560dad189ce2b107c03ce6afc20081a07c4979.zip
*** empty log message ***
Diffstat (limited to 'x11-wm/xfce')
-rw-r--r--x11-wm/xfce/files/digest-xfce-3.8.31
-rw-r--r--x11-wm/xfce/xfce-3.8.3.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/x11-wm/xfce/files/digest-xfce-3.8.3 b/x11-wm/xfce/files/digest-xfce-3.8.3
new file mode 100644
index 000000000000..1e6d508b6814
--- /dev/null
+++ b/x11-wm/xfce/files/digest-xfce-3.8.3
@@ -0,0 +1 @@
+MD5 f708f02e3a0aa290c030980d5f685b40 xfce-3.8.3.tar.gz
diff --git a/x11-wm/xfce/xfce-3.8.3.ebuild b/x11-wm/xfce/xfce-3.8.3.ebuild
new file mode 100644
index 000000000000..1b11a442d6f6
--- /dev/null
+++ b/x11-wm/xfce/xfce-3.8.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Ben Lutgens <ben@sistina.com>
+# /home/cvsroot/gentoo-x86/x11-wm/blackbox/blackbox-0.61.1.ebuild,v 1.1 2001/04/20 18:51:22 drobbins Exp
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="XFce is a lightweight desktop environment for various UNIX systems."
+SRC_URI="http://prdownloads.sourceforge.net/xfce/${A}"
+HOMEPAGE="http://www.xfce.org/"
+
+DEPEND="virtual/x11
+ >=x11-libs/gtk+-1.2
+ gnome? ( >=gnome-base/gdk-pixbuf-0.10 )"
+
+if [ -z "`use gnome`" ]
+then
+ DEPEND="${DEPEND} >=media-libs/imlib-1.9.10"
+fi
+
+src_compile() {
+ local myconf
+ if [ "`use gnome`" ]
+ then
+ myconf="--enable-imlib=no --enable-gdk-pixbuf=/opt/gnome"
+ fi
+ try ./configure --prefix=/usr/X11R6 --mandir=/usr/X11R6/share/man --host=${CHOST} \
+ --with-data-dir=/usr/X11R6/share/xfce --with-conf-dir=/etc/X11/xfce \
+ --with-locale-dir=/usr/X11R6/share/locale ${myconf}
+ try make
+}
+
+src_install () {
+ try make DESTDIR=${D} install
+ dodoc ChangeLog* AUTHORS LICENSE README* TODO*
+ exeinto /usr/X11R6/bin/wm
+ doexe ${FILESDIR}/xfce
+ dodir /etc/skel/.xfce
+}