summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-03-12 12:54:06 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-03-12 12:54:06 +0000
commit92a829ec36379ee3f99daea7fcb4bb38a4bbcafb (patch)
tree0920a7921cb2e76bd3f6b2194be1dd8b1a52a2ea /x11-wm/xfce
parentUpdated version of sylpheed-claws and added consideration of the nls USE (diff)
downloadgentoo-2-92a829ec36379ee3f99daea7fcb4bb38a4bbcafb.tar.gz
gentoo-2-92a829ec36379ee3f99daea7fcb4bb38a4bbcafb.tar.bz2
gentoo-2-92a829ec36379ee3f99daea7fcb4bb38a4bbcafb.zip
xfce ebuild updated to check for and optionally disable nls, based on the user's USE toggles
Diffstat (limited to 'x11-wm/xfce')
-rw-r--r--x11-wm/xfce/ChangeLog7
-rw-r--r--x11-wm/xfce/xfce-3.8.11-r2.ebuild48
2 files changed, 54 insertions, 1 deletions
diff --git a/x11-wm/xfce/ChangeLog b/x11-wm/xfce/ChangeLog
index 55c6b831bade..43a89957eaf4 100644
--- a/x11-wm/xfce/ChangeLog
+++ b/x11-wm/xfce/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-wm/xfce
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/xfce/ChangeLog,v 1.2 2002/02/14 22:13:04 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/xfce/ChangeLog,v 1.3 2002/03/12 12:54:06 seemant Exp $
+
+*xfce-3.8.11-r2 (12 Mar 2002)
+
+ 12 Mar 2002; Seemant Kulleen <seemant@gentoo.org> ChangeLog:
+ Copied over the -r1 ebuild and added a check for the nls toggle in USE.
*xfce-3.8.11-r1 (14 Feb 2002)
diff --git a/x11-wm/xfce/xfce-3.8.11-r2.ebuild b/x11-wm/xfce/xfce-3.8.11-r2.ebuild
new file mode 100644
index 000000000000..e87489622bec
--- /dev/null
+++ b/x11-wm/xfce/xfce-3.8.11-r2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Ben Lutgens <ben@sistina.com>
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/xfce/xfce-3.8.11-r2.ebuild,v 1.1 2002/03/12 12:54:06 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="XFce is a lightweight desktop environment for various UNIX systems."
+SRC_URI="http://prdownloads.sourceforge.net/xfce/${P}.tar.gz"
+HOMEPAGE="http://www.xfce.org/"
+
+DEPEND="virtual/x11
+ >=x11-libs/gtk+-1.2.10-r4
+ gnome? ( >=media-libs/gdk-pixbuf-0.11.0-r1 )
+ nls? ( sys-devel/gettext )"
+
+ use gnome || DEPEND="${DEPEND} >=media-libs/imlib-1.9.10-r1"
+
+src_compile() {
+ local myconf
+
+ if [ "`use gnome`" ]
+ then
+ myconf="--enable-imlib=no --enable-gdk-pixbuf=/usr"
+ myconf="${myconf} --enable-gdm"
+ fi
+
+ use nls || myconf="${myconf} --disable-nls"
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --with-data-dir=/usr/share/xfce \
+ --with-conf-dir=/etc/xfce \
+ --enable-xft \
+ --with-locale-dir=/usr/share/locale \
+ ${myconf} || die
+ emake || die
+}
+
+src_install () {
+ try make DESTDIR=${D} install
+ dodoc ChangeLog* AUTHORS LICENSE README* TODO*
+ dodir /etc/skel/.xfce
+
+ exeinto /etc/X11/Sessions
+ doexe $FILESDIR/xfce
+
+}