summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-03-27 13:35:21 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-03-27 13:35:21 +0000
commit0b31bbd59d35ab71c577a8279b75d881b5c8878c (patch)
tree1d4ea86278b4193f8034c75e39c72ecf2bb90c92 /x11-wm/xfce
parentUngzipped HTML docs (diff)
downloadgentoo-2-0b31bbd59d35ab71c577a8279b75d881b5c8878c.tar.gz
gentoo-2-0b31bbd59d35ab71c577a8279b75d881b5c8878c.tar.bz2
gentoo-2-0b31bbd59d35ab71c577a8279b75d881b5c8878c.zip
Version update.
Diffstat (limited to 'x11-wm/xfce')
-rw-r--r--x11-wm/xfce/ChangeLog8
-rw-r--r--x11-wm/xfce/files/digest-xfce-3.8.141
-rw-r--r--x11-wm/xfce/xfce-3.8.14.ebuild58
3 files changed, 66 insertions, 1 deletions
diff --git a/x11-wm/xfce/ChangeLog b/x11-wm/xfce/ChangeLog
index afd7be45d539..5b9ba53f0181 100644
--- a/x11-wm/xfce/ChangeLog
+++ b/x11-wm/xfce/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-wm/xfce
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/xfce/ChangeLog,v 1.4 2002/03/18 04:59:03 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/xfce/ChangeLog,v 1.5 2002/03/27 13:35:21 seemant Exp $
+
+*xfce-3.8.14 (27 Mar 2002)
+
+ 27 Mar 2002; Seemant Kulleen <seemant@gentoo.org> xfce-3.8.14.ebuild :
+
+ norbert@nrpil.tmfweb.nl (Norbert Pil) submitted the version update.
*xfce-3.8.11-r3 (17 Mar 2002)
diff --git a/x11-wm/xfce/files/digest-xfce-3.8.14 b/x11-wm/xfce/files/digest-xfce-3.8.14
new file mode 100644
index 000000000000..c93a3fd12f1d
--- /dev/null
+++ b/x11-wm/xfce/files/digest-xfce-3.8.14
@@ -0,0 +1 @@
+MD5 e92f08aa1aa404d3246cfb21cc9a237e xfce-3.8.14.tar.gz 4575761
diff --git a/x11-wm/xfce/xfce-3.8.14.ebuild b/x11-wm/xfce/xfce-3.8.14.ebuild
new file mode 100644
index 000000000000..f0db7e668d9e
--- /dev/null
+++ b/x11-wm/xfce/xfce-3.8.14.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Ben Lutgens <ben@sistina.com>
+# /space/gentoo/cvsroot/gentoo-x86/x11-wm/xfce/xfce-3.8.11-r2.ebuild,v 1.1 2002/03/12 12:54:06 seemant Exp
+
+S=${WORKDIR}/${P}
+DESCRIPTION="XFce is a lightweight desktop environment for various UNIX systems."
+SRC_URI="http://prdownloads.sourceforge.net/xfce/${P}.tar.gz"
+HOMEPAGE="http://www.xfce.org/"
+
+DEPEND="virtual/x11
+ >=x11-libs/gtk+-1.2.10-r4
+ gnome? ( dev-libs/libxml2 )
+ gnome? ( >=media-libs/gdk-pixbuf-0.11.0-r1 )
+ arts? ( kde-base/kdelibs )
+ nls? ( sys-devel/gettext )"
+
+ use gnome || DEPEND="${DEPEND} >=media-libs/imlib-1.9.10-r1"
+RDEPEND=""
+
+src_compile() {
+ local myconf
+
+ if [ "`use gnome`" ]
+ then
+ myconf="--enable-imlib=no --enable-gdk-pixbuf=/usr"
+ myconf="${myconf} --enable-gdm"
+ myconf="${myconf} --enable-libxml2"
+ fi
+
+ use nls || myconf="${myconf} --disable-nls"
+ use arts && myconf="${myconf} --enable-arts"
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --with-data-dir=/usr/share/xfce \
+ --with-conf-dir=/etc/xfce \
+ --disable-xft \
+ --with-locale-dir=/usr/share/locale \
+ ${myconf} || die
+
+ cd docs
+ cp Makefile Makefile.orig
+ sed "s:/usr/share/xfce:/usr/share/doc/${PF}:" Makefile.orig > Makefile
+ cd ..
+
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ dodoc ChangeLog* AUTHORS LICENSE README* TODO*
+ dodir /etc/skel/.xfce
+
+ exeinto /etc/X11/Sessions
+ doexe $FILESDIR/xfce
+}