summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2005-05-28 18:43:04 +0000
committerMamoru Komachi <usata@gentoo.org>2005-05-28 18:43:04 +0000
commit49c93f812a880eec1a0508a162a31fac4abe2e55 (patch)
tree29818ff0819b9b25e4c08b79ba410397c3a77541 /x11-wm/windowlab/windowlab-1.30.ebuild
parentsome revamping for fontconfig changes (diff)
downloadgentoo-2-49c93f812a880eec1a0508a162a31fac4abe2e55.tar.gz
gentoo-2-49c93f812a880eec1a0508a162a31fac4abe2e55.tar.bz2
gentoo-2-49c93f812a880eec1a0508a162a31fac4abe2e55.zip
Version bumped; bug #93650.
(Portage version: 2.0.51.19)
Diffstat (limited to 'x11-wm/windowlab/windowlab-1.30.ebuild')
-rw-r--r--x11-wm/windowlab/windowlab-1.30.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-wm/windowlab/windowlab-1.30.ebuild b/x11-wm/windowlab/windowlab-1.30.ebuild
new file mode 100644
index 000000000000..0f4dcb687474
--- /dev/null
+++ b/x11-wm/windowlab/windowlab-1.30.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/windowlab/windowlab-1.30.ebuild,v 1.1 2005/05/28 18:43:03 usata Exp $
+
+IUSE=""
+
+DESCRIPTION="WindowLab is a small and simple window manager of novel design."
+HOMEPAGE="http://www.nickgravgaard.com/windowlab/"
+SRC_URI="http://www.nickgravgaard.com/${PN}/${P}.tar"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+
+DEPEND="virtual/x11"
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ dobin windowlab
+
+ newman windowlab.1x windowlab.1
+ dodoc CHANGELOG README
+
+ dodir /etc/X11/windowlab
+ insinto /etc/X11/windowlab
+ newins menurc.sample menurc
+
+ dodir /etc/X11/Sessions
+ echo "/usr/bin/${PN}" > ${D}/etc/X11/Sessions/${PN}
+ fperms a+x /etc/X11/Sessions/${PN}
+}