summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-04-06 10:04:49 +0000
committerPacho Ramos <pacho@gentoo.org>2013-04-06 10:04:49 +0000
commit88c48392c47f7435801d1ff0b81ad874209a0091 (patch)
treed098737a9696d77b6ff297841d70205a87f4ad16 /x11-wm/sawfish
parentRemove old. (diff)
downloadgentoo-2-88c48392c47f7435801d1ff0b81ad874209a0091.tar.gz
gentoo-2-88c48392c47f7435801d1ff0b81ad874209a0091.tar.bz2
gentoo-2-88c48392c47f7435801d1ff0b81ad874209a0091.zip
Fix pangox-compat deps (#460498 by ustcscgy) and firefox resizing problem (#462016 by David Albrecht), drop old.
(Portage version: 2.1.11.60/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'x11-wm/sawfish')
-rw-r--r--x11-wm/sawfish/ChangeLog9
-rw-r--r--x11-wm/sawfish/files/sawfish-1.9.1-firefox.patch20
-rw-r--r--x11-wm/sawfish/sawfish-1.9.1-r1.ebuild59
3 files changed, 87 insertions, 1 deletions
diff --git a/x11-wm/sawfish/ChangeLog b/x11-wm/sawfish/ChangeLog
index 72a5a49c1e2a..268ffcdd7cba 100644
--- a/x11-wm/sawfish/ChangeLog
+++ b/x11-wm/sawfish/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-wm/sawfish
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/sawfish/ChangeLog,v 1.122 2013/04/01 18:26:07 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/sawfish/ChangeLog,v 1.123 2013/04/06 10:04:48 pacho Exp $
+
+*sawfish-1.9.1-r1 (06 Apr 2013)
+
+ 06 Apr 2013; Pacho Ramos <pacho@gentoo.org>
+ +files/sawfish-1.9.1-firefox.patch, +sawfish-1.9.1-r1.ebuild:
+ Fix pangox-compat deps (#460498 by ustcscgy) and firefox resizing problem
+ (#462016 by David Albrecht), drop old.
01 Apr 2013; Agostino Sarubbo <ago@gentoo.org> sawfish-1.9.1.ebuild:
Stable for sparc, wrt bug #458984
diff --git a/x11-wm/sawfish/files/sawfish-1.9.1-firefox.patch b/x11-wm/sawfish/files/sawfish-1.9.1-firefox.patch
new file mode 100644
index 000000000000..6fb27bb820cc
--- /dev/null
+++ b/x11-wm/sawfish/files/sawfish-1.9.1-firefox.patch
@@ -0,0 +1,20 @@
+X-Git-Url: http://git.tuxfamily.org/sawfish/main.git?p=sawfish%2Fmain.git;p=sawfish%2Fmain.git;a=blobdiff_plain;f=src%2Fwindows.c;h=053b95a9933b04a99301b300a5477e2ce3329cbd;hp=c6117e778ad157f9868c431efa934964b88897fd;hb=798c6992cc41f5ca7ec1bd4bd74d721a59820897;hpb=ec807ed20eecb401c3e11b3b04d375fc848ca4c1
+
+diff --git a/src/windows.c b/src/windows.c
+index c6117e7..053b95a 100644
+--- a/src/windows.c
++++ b/src/windows.c
+@@ -1297,6 +1297,13 @@ associated with WINDOW. Possible keys in the alist are `min-height',
+ hints = &VWIN(win)->hints;
+ flags = hints->flags;
+
++ /* workaround stuff like Firefox 17 that
++ * has enormous max-width/maxh-height */
++ if (hints->max_width >= 32767)
++ hints->max_width = 32767;
++ if (hints->max_height >= 32767)
++ hints->max_height = 32767;
++
+ /* Some sanity checking */
+ if ((flags & PMinSize)
+ && (hints->min_width < 0 || hints->min_height < 0))
diff --git a/x11-wm/sawfish/sawfish-1.9.1-r1.ebuild b/x11-wm/sawfish/sawfish-1.9.1-r1.ebuild
new file mode 100644
index 000000000000..cc8506a10d42
--- /dev/null
+++ b/x11-wm/sawfish/sawfish-1.9.1-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/sawfish/sawfish-1.9.1-r1.ebuild,v 1.1 2013/04/06 10:04:48 pacho Exp $
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="Extensible window manager using a Lisp-based scripting language"
+HOMEPAGE="http://sawfish.wikia.com/"
+SRC_URI="http://download.tuxfamily.org/sawfish/${P}.tar.xz"
+
+LICENSE="GPL-2 Artistic-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="nls xinerama"
+
+RDEPEND=">=dev-libs/librep-0.92.1
+ >=x11-libs/rep-gtk-0.90.7
+ || ( x11-libs/pangox-compat <x11-libs/pango-1.31[X] )
+ >=x11-libs/gtk+-2.24.0:2
+ x11-libs/libXtst
+ nls? ( sys-devel/gettext )
+ xinerama? ( x11-libs/libXinerama )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ virtual/pkgconfig"
+
+src_prepare() {
+ # Fix firefox resizing problems, bug #462016
+ epatch "${FILESDIR}/${P}-firefox.patch"
+}
+
+src_configure() {
+ set -- \
+ $(use_with xinerama) \
+ --with-gdk-pixbuf \
+ --disable-static
+
+ if ! use nls; then
+ # Use a space because configure script reads --enable-linguas="" as
+ # "install everything"
+ # Don't use --disable-linguas, because that means --enable-linguas="no",
+ # which means "install Norwegian translations"
+ set -- "$@" --enable-linguas=" "
+ elif [[ "${LINGUAS+set}" == "set" ]]; then
+ strip-linguas -i po
+ set -- "$@" --enable-linguas=" ${LINGUAS} "
+ else
+ set -- "$@" --enable-linguas=""
+ fi
+
+ econf "$@"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ prune_libtool_files --modules
+ dodoc AUTHORS ChangeLog DOC FAQ NEWS OPTIONS README README.IMPORTANT TODO
+}