summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2005-11-02 16:54:39 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2005-11-02 16:54:39 +0000
commit141aaaff65d697fa2f9807c48af580a9fbc7fd9a (patch)
tree71c7be97fcdfbb8128384badaae08c4d73effc94 /x11-wm/ratpoison
parentNew upstream version. (diff)
downloadgentoo-2-141aaaff65d697fa2f9807c48af580a9fbc7fd9a.tar.gz
gentoo-2-141aaaff65d697fa2f9807c48af580a9fbc7fd9a.tar.bz2
gentoo-2-141aaaff65d697fa2f9807c48af580a9fbc7fd9a.zip
Added useful Emacs autoloads.
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'x11-wm/ratpoison')
-rw-r--r--x11-wm/ratpoison/ChangeLog6
-rw-r--r--x11-wm/ratpoison/Manifest26
-rw-r--r--x11-wm/ratpoison/files/50ratpoison-gentoo.el6
3 files changed, 19 insertions, 19 deletions
diff --git a/x11-wm/ratpoison/ChangeLog b/x11-wm/ratpoison/ChangeLog
index 3a09b6e786bd..19f066ffd7a7 100644
--- a/x11-wm/ratpoison/ChangeLog
+++ b/x11-wm/ratpoison/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-wm/ratpoison
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/ratpoison/ChangeLog,v 1.31 2005/09/17 00:55:26 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/ratpoison/ChangeLog,v 1.32 2005/11/02 16:54:39 mkennedy Exp $
+
+ 02 Nov 2005; Matthew Kennedy <mkennedy@gentoo.org>
+ files/50ratpoison-gentoo.el:
+ Added useful Emacs autoloads.
17 Sep 2005; Ciaran McCreesh <ciaranm@gentoo.org> ChangeLog:
Converted to UTF-8, fixed encoding screwups
diff --git a/x11-wm/ratpoison/Manifest b/x11-wm/ratpoison/Manifest
index 3e77309cd0d7..f57a65641d92 100644
--- a/x11-wm/ratpoison/Manifest
+++ b/x11-wm/ratpoison/Manifest
@@ -1,22 +1,12 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 8e71189578c6957a1a66541c432f8b86 ratpoison-1.4.0_beta2.ebuild 1499
-MD5 480301c1bfce20a9a72b7c446c46b356 ratpoison-1.4.0_beta4.ebuild 1499
-MD5 d6dc62049d4af16eb42ce96b3aee90cd ratpoison-1.3.0.ebuild 1443
-MD5 0dc401dca3401344d482d660aedf9b3b metadata.xml 829
MD5 2588636b9469476c21a46a87962cc258 ChangeLog 4122
+MD5 4b1aa9334982625a7a6c31ecf3fb3a7e files/50ratpoison-gentoo.el 523
+MD5 e4205db91428787672e5463c32d4b701 files/digest-ratpoison-1.3.0 67
+MD5 e97b940b1d366b59e727dd7c8f727874 files/digest-ratpoison-1.4.0_beta2 73
MD5 68d1d603290ff4bc9e9221078e552364 files/digest-ratpoison-1.4.0_beta4 73
+MD5 129f353e076455306b034fd577a6cdd2 files/ratpoison.el-gentoo.patch 273
MD5 f2ca283925e8bbb408427e4a29c8592d files/ratpoison.xsession 19
MD5 a7dd337c32ae9d2fe627cf230b77965c files/ratpoisonrc 609
-MD5 129f353e076455306b034fd577a6cdd2 files/ratpoison.el-gentoo.patch 273
-MD5 e4205db91428787672e5463c32d4b701 files/digest-ratpoison-1.3.0 67
-MD5 ab1a7f36971489b5cffb75d84a2b2d0a files/50ratpoison-gentoo.el 82
-MD5 e97b940b1d366b59e727dd7c8f727874 files/digest-ratpoison-1.4.0_beta2 73
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1 (GNU/Linux)
-
-iD8DBQFDK2myLLFUmVNQ7rkRAhg7AJ9I+P735LP7xpDhdO6Eu+Smhlt1FgCgnbxc
-ky4CCR5cJWEAGv1+2FsVvdQ=
-=Idmc
------END PGP SIGNATURE-----
+MD5 0dc401dca3401344d482d660aedf9b3b metadata.xml 829
+MD5 d6dc62049d4af16eb42ce96b3aee90cd ratpoison-1.3.0.ebuild 1443
+MD5 8e71189578c6957a1a66541c432f8b86 ratpoison-1.4.0_beta2.ebuild 1499
+MD5 480301c1bfce20a9a72b7c446c46b356 ratpoison-1.4.0_beta4.ebuild 1499
diff --git a/x11-wm/ratpoison/files/50ratpoison-gentoo.el b/x11-wm/ratpoison/files/50ratpoison-gentoo.el
index 300e548d5013..b8885bd7adc4 100644
--- a/x11-wm/ratpoison/files/50ratpoison-gentoo.el
+++ b/x11-wm/ratpoison/files/50ratpoison-gentoo.el
@@ -2,3 +2,9 @@
;;; site-lisp configuration for ratpoison
(add-to-list 'load-path "@SITELISP@")
+
+(autoload 'ratpoisonrc-mode "ratpoison" "Mode for ratpoison configuration files." t)
+(autoload 'ratpoison-command "ratpoison" "Run a ratpoison command." t)
+(autoload 'ratpoison-command-on-region "ratpoison" "Run a ratpoison command contained in the region." t)
+(autoload 'ratpoison-info "ratpoison" "Call up the ratpoison info page." t)
+(autoload 'ratpoison-command-info "ratpoison" "Call up the info page listing the ratpoison commands." t) \ No newline at end of file