summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-08-05 15:16:48 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-08-05 15:16:48 +0000
commitb6c2977541ce59a4db8d2ccb1f7e2e7379a8c810 (patch)
tree1f8f53152594e7593dadf30d9b4e6b84b0c3831a /x11-wm/openbox
parent[This is a placeholder. Please ignore.] (diff)
downloadgentoo-2-b6c2977541ce59a4db8d2ccb1f7e2e7379a8c810.tar.gz
gentoo-2-b6c2977541ce59a4db8d2ccb1f7e2e7379a8c810.tar.bz2
gentoo-2-b6c2977541ce59a4db8d2ccb1f7e2e7379a8c810.zip
Version bump
(Portage version: 2.2.0_alpha50/cvs/Linux x86_64)
Diffstat (limited to 'x11-wm/openbox')
-rw-r--r--x11-wm/openbox/ChangeLog7
-rw-r--r--x11-wm/openbox/openbox-3.5.0.ebuild62
2 files changed, 68 insertions, 1 deletions
diff --git a/x11-wm/openbox/ChangeLog b/x11-wm/openbox/ChangeLog
index 36d5df47d1ae..ed9dd623fba1 100644
--- a/x11-wm/openbox/ChangeLog
+++ b/x11-wm/openbox/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-wm/openbox
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/openbox/ChangeLog,v 1.223 2011/08/02 11:03:07 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/openbox/ChangeLog,v 1.224 2011/08/05 15:16:48 hwoarang Exp $
+
+*openbox-3.5.0 (05 Aug 2011)
+
+ 05 Aug 2011; Markos Chandras <hwoarang@gentoo.org> +openbox-3.5.0.ebuild:
+ Version bump
*openbox-3.5.0_pre20110801 (02 Aug 2011)
diff --git a/x11-wm/openbox/openbox-3.5.0.ebuild b/x11-wm/openbox/openbox-3.5.0.ebuild
new file mode 100644
index 000000000000..9c61f6e72fdc
--- /dev/null
+++ b/x11-wm/openbox/openbox-3.5.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/openbox/openbox-3.5.0.ebuild,v 1.1 2011/08/05 15:16:48 hwoarang Exp $
+
+EAPI="2"
+WANT_AUTOMAKE="1.9"
+inherit multilib autotools eutils
+
+DESCRIPTION="A standards compliant, fast, light-weight, extensible window manager"
+HOMEPAGE="http://openbox.org/"
+SRC_URI="http://openbox.org/dist/openbox/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug imlib nls session startup-notification static-libs"
+
+RDEPEND="dev-libs/glib:2
+ >=dev-libs/libxml2-2.0
+ dev-python/pyxdg
+ >=media-libs/fontconfig-2
+ x11-libs/libXft
+ x11-libs/libXrandr
+ x11-libs/libXt
+ >=x11-libs/pango-1.8[X]
+ imlib? ( media-libs/imlib2 )
+ startup-notification? ( >=x11-libs/startup-notification-0.8 )
+ x11-libs/libXinerama"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ app-text/docbook2X
+ dev-util/pkgconfig
+ x11-proto/xextproto
+ x11-proto/xf86vidmodeproto
+ x11-proto/xineramaproto"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-gnome-session-3.4.9.patch
+ epatch "${FILESDIR}"/${PN}-as-needed.patch
+ eautopoint
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --docdir=/usr/share/doc/${PF} \
+ $(use_enable debug) \
+ $(use_enable imlib imlib2) \
+ $(use_enable nls) \
+ $(use_enable startup-notification) \
+ $(use_enable session session-management) \
+ $(use_enable static-libs static) \
+ --with-x
+}
+
+src_install() {
+ dodir /etc/X11/Sessions
+ echo "/usr/bin/openbox-session" > "${D}/etc/X11/Sessions/${PN}"
+ fperms a+x /etc/X11/Sessions/${PN}
+ emake DESTDIR="${D}" install || die "emake install failed"
+ ! use static-libs && rm "${D}"/usr/$(get_libdir)/lib{obt,obrender}.la
+}