summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Anderson <gentoofan23@gentoo.org>2009-03-08 19:53:05 +0000
committerThomas Anderson <gentoofan23@gentoo.org>2009-03-08 19:53:05 +0000
commit8299dd75847206b65c9cf7817b4b01252d79965c (patch)
tree649260a7e6347670c08b0b4750b6fc91d1a14c07 /x11-wm/openbox
parentEAPI=2, remove mymake, cleanup (diff)
downloadgentoo-2-8299dd75847206b65c9cf7817b4b01252d79965c.tar.gz
gentoo-2-8299dd75847206b65c9cf7817b4b01252d79965c.tar.bz2
gentoo-2-8299dd75847206b65c9cf7817b4b01252d79965c.zip
Transition to EAPI 2 usedeps
(Portage version: 2.1.6.7/cvs/Linux x86_64)
Diffstat (limited to 'x11-wm/openbox')
-rw-r--r--x11-wm/openbox/ChangeLog6
-rw-r--r--x11-wm/openbox/openbox-3.4.7.2.ebuild18
-rw-r--r--x11-wm/openbox/openbox-3.4.8_rc1.ebuild18
3 files changed, 15 insertions, 27 deletions
diff --git a/x11-wm/openbox/ChangeLog b/x11-wm/openbox/ChangeLog
index c565b22ca0aa..26bb713b5226 100644
--- a/x11-wm/openbox/ChangeLog
+++ b/x11-wm/openbox/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-wm/openbox
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/openbox/ChangeLog,v 1.176 2009/01/09 15:18:46 remi Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/openbox/ChangeLog,v 1.177 2009/03/08 19:53:05 gentoofan23 Exp $
+
+ 08 Mar 2009; Thomas Anderson <gentoofan23@gentoo.org>
+ openbox-3.4.7.2.ebuild, openbox-3.4.8_rc1.ebuild:
+ Transition to EAPI 2 usedeps
09 Jan 2009; Rémi Cardona <remi@gentoo.org> openbox-3.4.7.2.ebuild,
openbox-3.4.8_rc1.ebuild:
diff --git a/x11-wm/openbox/openbox-3.4.7.2.ebuild b/x11-wm/openbox/openbox-3.4.7.2.ebuild
index b2c7b9836e93..c8221198d58e 100644
--- a/x11-wm/openbox/openbox-3.4.7.2.ebuild
+++ b/x11-wm/openbox/openbox-3.4.7.2.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/openbox/openbox-3.4.7.2.ebuild,v 1.9 2009/01/09 15:18:46 remi Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/openbox/openbox-3.4.7.2.ebuild,v 1.10 2009/03/08 19:53:05 gentoofan23 Exp $
+EAPI="2"
inherit eutils
DESCRIPTION="A standards compliant, fast, light-weight, extensible window manager."
@@ -19,7 +20,7 @@ RDEPEND=">=dev-libs/glib-2.6
x11-libs/libXft
x11-libs/libXrandr
x11-libs/libXt
- >=x11-libs/pango-1.8
+ >=x11-libs/pango-1.8[X]
nls? ( sys-devel/gettext )
startup-notification? ( >=x11-libs/startup-notification-0.8 )
xinerama? ( x11-libs/libXinerama )"
@@ -29,20 +30,11 @@ DEPEND="${RDEPEND}
x11-proto/xf86vidmodeproto
xinerama? ( x11-proto/xineramaproto )"
-pkg_setup() {
- if ! built_with_use --missing true x11-libs/pango X; then
- eerror "Please rebuild x11-libs/pango with the X USE flag enabled."
- die "x11-libs/pango needs X USE flag"
- fi
-}
-
-src_compile() {
+src_configure() {
econf \
--docdir=/usr/share/doc/${PF} \
$(use_enable nls) \
- $(use_enable startup-notification) \
- || die "econf failed"
- emake || die "emake failed"
+ $(use_enable startup-notification)
}
src_install() {
diff --git a/x11-wm/openbox/openbox-3.4.8_rc1.ebuild b/x11-wm/openbox/openbox-3.4.8_rc1.ebuild
index df6148c23ef9..a27df187210e 100644
--- a/x11-wm/openbox/openbox-3.4.8_rc1.ebuild
+++ b/x11-wm/openbox/openbox-3.4.8_rc1.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/openbox/openbox-3.4.8_rc1.ebuild,v 1.2 2009/01/09 15:18:46 remi Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/openbox/openbox-3.4.8_rc1.ebuild,v 1.3 2009/03/08 19:53:05 gentoofan23 Exp $
+EAPI="2"
inherit eutils
MY_P=${P/_/-}
@@ -20,7 +21,7 @@ RDEPEND=">=dev-libs/glib-2.6
x11-libs/libXft
x11-libs/libXrandr
x11-libs/libXt
- >=x11-libs/pango-1.8
+ >=x11-libs/pango-1.8[X]
nls? ( sys-devel/gettext )
startup-notification? ( >=x11-libs/startup-notification-0.8 )
xinerama? ( x11-libs/libXinerama )"
@@ -32,20 +33,11 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${MY_P}"
-pkg_setup() {
- if ! built_with_use --missing true x11-libs/pango X; then
- eerror "Please rebuild x11-libs/pango with the X USE flag enabled."
- die "x11-libs/pango needs X USE flag"
- fi
-}
-
-src_compile() {
+src_configure() {
econf \
--docdir=/usr/share/doc/${PF} \
$(use_enable nls) \
- $(use_enable startup-notification) \
- || die "econf failed"
- emake || die "emake failed"
+ $(use_enable startup-notification)
}
src_install() {