summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-06-23 20:08:09 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-06-23 20:08:09 +0000
commit56fab8fce9b774ea5f44216cb10b5d7cfbe8608c (patch)
tree4fe7ee8bc48d2f1dc22e5c65efed4345a3d0ac87 /x11-wm/openbox/openbox-9999.ebuild
parentRemoved bindist flag, orpie should be compatible GPL-3 anyway (diff)
downloadgentoo-2-56fab8fce9b774ea5f44216cb10b5d7cfbe8608c.tar.gz
gentoo-2-56fab8fce9b774ea5f44216cb10b5d7cfbe8608c.tar.bz2
gentoo-2-56fab8fce9b774ea5f44216cb10b5d7cfbe8608c.zip
Add more use flags, remove .la files when building with shared libs
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'x11-wm/openbox/openbox-9999.ebuild')
-rw-r--r--x11-wm/openbox/openbox-9999.ebuild14
1 files changed, 9 insertions, 5 deletions
diff --git a/x11-wm/openbox/openbox-9999.ebuild b/x11-wm/openbox/openbox-9999.ebuild
index 6a47f22e097b..943a1494c5c4 100644
--- a/x11-wm/openbox/openbox-9999.ebuild
+++ b/x11-wm/openbox/openbox-9999.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/openbox/openbox-9999.ebuild,v 1.4 2010/06/22 09:16:21 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/openbox/openbox-9999.ebuild,v 1.5 2010/06/23 20:08:09 hwoarang Exp $
EAPI="2"
WANT_AUTOMAKE="1.9"
-inherit autotools eutils git
+inherit multilib autotools eutils git
DESCRIPTION="A standards compliant, fast, light-weight, extensible window manager"
HOMEPAGE="http://openbox.org/"
@@ -13,7 +13,7 @@ EGIT_REPO_URI="git://git.openbox.org/dana/openbox"
LICENSE="GPL-2"
SLOT="3"
KEYWORDS=""
-IUSE="imlib nls startup-notification"
+IUSE="debug imlib nls session startup-notification static-libs"
RDEPEND="dev-libs/glib:2
>=dev-libs/libxml2-2.0
@@ -44,15 +44,19 @@ src_prepare() {
src_configure() {
econf \
--docdir=/usr/share/doc/${PF} \
+ $(use_enable debug) \
$(use_enable imlib imlib2) \
$(use_enable nls) \
- $(use_enable startup-notification)
+ $(use_enable startup-notification) \
+ $(use_enable session session-management) \
+ $(use_enable static-libs static) \
+ --with-x
}
src_install() {
dodir /etc/X11/Sessions
echo "/usr/bin/openbox-session" > "${D}/etc/X11/Sessions/${PN}"
fperms a+x /etc/X11/Sessions/${PN}
-
emake DESTDIR="${D}" install || die "emake install failed"
+ ! use static-libs && rm "${D}"/usr/$(get_libdir)/lib{obt,obrender}.la
}