summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2013-04-09 06:49:12 +0000
committerMichael Weber <xmw@gentoo.org>2013-04-09 06:49:12 +0000
commitdb877da07835e00a0ae330eac1d7a82b25d3c3f6 (patch)
treeb1eed9d3f18e654ab366a41539b34feef3be5f40 /x11-wm/notion
parentInitial commit, wrt bug #361599. Ebuild and patch by René Neumann <gentoo AT... (diff)
downloadgentoo-2-db877da07835e00a0ae330eac1d7a82b25d3c3f6.tar.gz
gentoo-2-db877da07835e00a0ae330eac1d7a82b25d3c3f6.tar.bz2
gentoo-2-db877da07835e00a0ae330eac1d7a82b25d3c3f6.zip
Added snapshot as suggested by jer on bug 464788.
(Portage version: 2.2.0_alpha171/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'x11-wm/notion')
-rw-r--r--x11-wm/notion/ChangeLog9
-rw-r--r--x11-wm/notion/notion-3_p2013030200.ebuild72
2 files changed, 79 insertions, 2 deletions
diff --git a/x11-wm/notion/ChangeLog b/x11-wm/notion/ChangeLog
index 2aeadf245339..77a0735ee08c 100644
--- a/x11-wm/notion/ChangeLog
+++ b/x11-wm/notion/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-wm/notion
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/notion/ChangeLog,v 1.4 2012/10/08 12:34:30 xmw Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/notion/ChangeLog,v 1.5 2013/04/09 06:49:12 xmw Exp $
+
+*notion-3_p2013030200 (09 Apr 2013)
+
+ 09 Apr 2013; Michael Weber <xmw@gentoo.org> +notion-3_p2013030200.ebuild:
+ Added snapshot as suggested by jer on bug 464788.
08 Oct 2012; Michael Weber <xmw@gentoo.org> notion-9999.ebuild:
Fix install dirs (thanks nordwind, bug 437486), true as stip for cleaner
diff --git a/x11-wm/notion/notion-3_p2013030200.ebuild b/x11-wm/notion/notion-3_p2013030200.ebuild
new file mode 100644
index 000000000000..4011c8a588ef
--- /dev/null
+++ b/x11-wm/notion/notion-3_p2013030200.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/notion/notion-3_p2013030200.ebuild,v 1.1 2013/04/09 06:49:12 xmw Exp $
+
+EAPI="4"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Notion is a tiling, tabbed window manager for the X window system"
+HOMEPAGE="http://notion.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/files/${P/_p/-}-src.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls xinerama +xrandr"
+
+RDEPEND="dev-lang/lua
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+ nls? ( sys-devel/gettext )
+ xinerama? ( x11-libs/libXinerama )
+ xrandr? ( x11-libs/libXrandr )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${P/_p/-}
+
+src_prepare() {
+ sed -e "/^CFLAGS=/s:=:+=:" \
+ -e "/^CFLAGS/{s:-Os:: ; s:-g::}" \
+ -e "/^LDFLAGS=/{s:=:+=: ; s:-Wl,--as-needed::}" \
+ -e "/^CC=/s:=:?=:" \
+ -e "s:^\(PREFIX=\).*$:\1${ROOT}usr:" \
+ -e "s:^\(ETCDIR=\).*$:\1${ROOT}etc/notion:" \
+ -e "s:^\(LIBDIR=\).*:\1\$(PREFIX)/$(get_libdir):" \
+ -e "s:^\(DOCDIR=\).*:\1\$(PREFIX)/share/doc/${PF}:" \
+ -e "s:^\(LUA_DIR=\).*$:\1\$(PREFIX)/usr:" \
+ -e "s:^\(VARDIR=\).*$:\1${ROOT}var/cache/${PN}:" \
+ -e "s:^\(X11_PREFIX=\).*:\1\$(PREFIX)/usr:" \
+ -i system-autodetect.mk || die
+ export STRIPPROG=true
+
+ use nls || export DEFINES=" -DCF_NO_LOCALE -DCF_NO_GETTEXT"
+
+ if ! use xinerama ; then
+ sed -e 's/mod_xinerama//g' -i modulelist.mk || die
+ fi
+
+ if ! use xrandr ; then
+ sed -e 's/mod_xrandr//g' -i modulelist.mk || die
+ fi
+
+ tc-export CC
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ exeinto /etc/X11/Sessions
+ doexe "${FILESDIR}"/notion
+
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}"/notion.desktop
+}
+
+pkg_postinst() {
+ elog "If you want notion to have an ability to view a file based on its"
+ elog "guessed MIME type you need 'run-mailcap' program in your system."
+}