summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2011-09-30 16:35:42 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2011-09-30 16:35:42 +0000
commit415e800412a13ea47216d05391244b9e04881f88 (patch)
tree4f0c8f54ddae4b014d8bf5bded43fcde79c9a2c1 /x11-wm/mutter
parentstabilize for all since the revbump only installs a new noarch file, remove o... (diff)
downloadgentoo-2-415e800412a13ea47216d05391244b9e04881f88.tar.gz
gentoo-2-415e800412a13ea47216d05391244b9e04881f88.tar.bz2
gentoo-2-415e800412a13ea47216d05391244b9e04881f88.zip
Move from GNOME overlay for GNOME 3
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'x11-wm/mutter')
-rw-r--r--x11-wm/mutter/ChangeLog10
-rw-r--r--x11-wm/mutter/metadata.xml9
-rw-r--r--x11-wm/mutter/mutter-3.0.2.1.ebuild85
3 files changed, 104 insertions, 0 deletions
diff --git a/x11-wm/mutter/ChangeLog b/x11-wm/mutter/ChangeLog
new file mode 100644
index 000000000000..d7dae42d3998
--- /dev/null
+++ b/x11-wm/mutter/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for x11-wm/mutter
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/mutter/ChangeLog,v 1.1 2011/09/30 16:35:42 nirbheek Exp $
+
+*mutter-3.0.2.1 (30 Sep 2011)
+
+ 30 Sep 2011; Nirbheek Chauhan <nirbheek@gentoo.org> +mutter-3.0.2.1.ebuild,
+ +metadata.xml:
+ Move from GNOME overlay for GNOME 3
+
diff --git a/x11-wm/mutter/metadata.xml b/x11-wm/mutter/metadata.xml
new file mode 100644
index 000000000000..44825d13c084
--- /dev/null
+++ b/x11-wm/mutter/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnome</herd>
+ <use>
+ <flag name="introspection">Use <pkg>dev-libs/gobject-introspection</pkg>
+ for introspection</flag>
+ </use>
+</pkgmetadata>
diff --git a/x11-wm/mutter/mutter-3.0.2.1.ebuild b/x11-wm/mutter/mutter-3.0.2.1.ebuild
new file mode 100644
index 000000000000..d7bf6d4c1cd7
--- /dev/null
+++ b/x11-wm/mutter/mutter-3.0.2.1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/mutter/mutter-3.0.2.1.ebuild,v 1.1 2011/09/30 16:35:42 nirbheek Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+GNOME_TARBALL_SUFFIX="bz2"
+
+inherit eutils gnome2
+
+DESCRIPTION="GNOME 3 compositing window manager based on Clutter"
+HOMEPAGE="http://git.gnome.org/browse/mutter/"
+SRC_URI="${SRC_URI}
+ mirror://gentoo/${PN}-3.0.2-patches.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+introspection test xinerama"
+KEYWORDS="~amd64 ~x86"
+
+COMMON_DEPEND=">=x11-libs/pango-1.2[X,introspection?]
+ >=x11-libs/cairo-1.10[X]
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-2.91.7:3[introspection?]
+ >=gnome-base/gconf-2:2
+ >=dev-libs/glib-2.14:2
+ >=media-libs/clutter-1.2:1.0
+ >=media-libs/libcanberra-0.26[gtk3]
+ >=x11-libs/startup-notification-0.7
+ >=x11-libs/libXcomposite-0.2
+
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXrandr
+ x11-libs/libXrender
+
+ gnome-extra/zenity
+
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
+ xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="${COMMON_DEPEND}
+ >=app-text/gnome-doc-utils-0.8
+ sys-devel/gettext
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.35
+ test? ( app-text/docbook-xml-dtd:4.5 )
+ xinerama? ( x11-proto/xineramaproto )
+ x11-proto/xextproto
+ x11-proto/xproto"
+RDEPEND="${COMMON_DEPEND}
+ !x11-misc/expocity"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README *.txt doc/*.txt"
+ G2CONF="${G2CONF}
+ --disable-static
+ --enable-gconf
+ --enable-shape
+ --enable-sm
+ --enable-startup-notification
+ --enable-xsync
+ --enable-verbose-mode
+ --enable-compile-warnings=maximum
+ --with-libcanberra
+ $(use_enable introspection)
+ $(use_enable xinerama)"
+}
+
+src_prepare() {
+ # Fix argb window shadows: https://bugzilla.gnome.org/show_bug.cgi?id=635268
+ # The first two patches are from upstream git master branch:
+ epatch "${WORKDIR}/${PN}-3.0.2-frame-region-cairo-region.patch"
+ epatch "${WORKDIR}/${PN}-3.0.2-argb-windows-shadow.patch"
+ # The third is from comment 33 in the gnome bug and unbreaks XShape handling
+ epatch "${WORKDIR}/${PN}-3.0.2-fix-xshape.patch"
+
+ gnome2_src_prepare
+}