summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-01-25 08:42:11 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-01-25 08:42:11 +0000
commitb816effb4c6350fde1e24710e73ae4ac24bdb9f0 (patch)
treeb98676658abd4bba69fdfc77e44867ff05e0fd55 /x11-wm/muffin
parent0.7a should still be masked (diff)
downloadgentoo-2-b816effb4c6350fde1e24710e73ae4ac24bdb9f0.tar.gz
gentoo-2-b816effb4c6350fde1e24710e73ae4ac24bdb9f0.tar.bz2
gentoo-2-b816effb4c6350fde1e24710e73ae4ac24bdb9f0.zip
New package: Linux Mint's fork of x11-wm/mutter for use with Cinnamon.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'x11-wm/muffin')
-rw-r--r--x11-wm/muffin/ChangeLog11
-rw-r--r--x11-wm/muffin/metadata.xml9
-rw-r--r--x11-wm/muffin/muffin-1.0.0.ebuild75
3 files changed, 95 insertions, 0 deletions
diff --git a/x11-wm/muffin/ChangeLog b/x11-wm/muffin/ChangeLog
new file mode 100644
index 000000000000..effa17d4b17d
--- /dev/null
+++ b/x11-wm/muffin/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for x11-wm/muffin
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/muffin/ChangeLog,v 1.1 2012/01/25 08:42:11 tetromino Exp $
+
+*muffin-1.0.0 (25 Jan 2012)
+
+ 25 Jan 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ +muffin-1.0.0.ebuild, +files/muffin-1.0.0-ignore-shadow-and-padding.patch,
+ +metadata.xml:
+ New package: Linux Mint's fork of x11-wm/mutter for use with Cinnamon.
+
diff --git a/x11-wm/muffin/metadata.xml b/x11-wm/muffin/metadata.xml
new file mode 100644
index 000000000000..44825d13c084
--- /dev/null
+++ b/x11-wm/muffin/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnome</herd>
+ <use>
+ <flag name="introspection">Use <pkg>dev-libs/gobject-introspection</pkg>
+ for introspection</flag>
+ </use>
+</pkgmetadata>
diff --git a/x11-wm/muffin/muffin-1.0.0.ebuild b/x11-wm/muffin/muffin-1.0.0.ebuild
new file mode 100644
index 000000000000..2da02e733d8c
--- /dev/null
+++ b/x11-wm/muffin/muffin-1.0.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/muffin/muffin-1.0.0.ebuild,v 1.1 2012/01/25 08:42:11 tetromino Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="Compositing window manager forked from Mutter for use with Cinnamon"
+HOMEPAGE="http://cinnamon.linuxmint.com/"
+
+SRC_URI="https://github.com/linuxmint/muffin/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+introspection test xinerama"
+KEYWORDS="~amd64 ~x86"
+
+COMMON_DEPEND=">=x11-libs/pango-1.2[X,introspection?]
+ >=x11-libs/cairo-1.10[X]
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-2.91.7:3[introspection?]
+ >=gnome-base/gconf-2:2
+ >=dev-libs/glib-2.14:2
+ >=media-libs/clutter-1.7.5:1.0
+ >=media-libs/libcanberra-0.26[gtk3]
+ >=x11-libs/startup-notification-0.7
+ >=x11-libs/libXcomposite-0.2
+
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXrandr
+ x11-libs/libXrender
+
+ gnome-extra/zenity
+
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
+ xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="${COMMON_DEPEND}
+ >=app-text/gnome-doc-utils-0.8
+ sys-devel/gettext
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.35
+ test? ( app-text/docbook-xml-dtd:4.5 )
+ xinerama? ( x11-proto/xineramaproto )
+ x11-proto/xextproto
+ x11-proto/xproto"
+RDEPEND="${COMMON_DEPEND}
+ !x11-misc/expocity"
+
+S="${WORKDIR}/linuxmint-muffin-079b5bf"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README* *.txt doc/*.txt"
+ G2CONF="${G2CONF}
+ --disable-static
+ --enable-gconf
+ --enable-shape
+ --enable-sm
+ --enable-startup-notification
+ --enable-xsync
+ --enable-verbose-mode
+ --enable-compile-warnings=maximum
+ --with-libcanberra
+ $(use_enable introspection)
+ $(use_enable xinerama)"
+}