summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-01-04 14:52:51 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-01-04 14:52:51 +0000
commita801e80c2bda40041f37f0042faca8ccc6de4ce3 (patch)
tree14b06c25706bf24c097ae85fc38e84c518700439 /x11-wm/matwm2
parentUse -j1 for build (bug #299613). (diff)
downloadgentoo-2-a801e80c2bda40041f37f0042faca8ccc6de4ce3.tar.gz
gentoo-2-a801e80c2bda40041f37f0042faca8ccc6de4ce3.tar.bz2
gentoo-2-a801e80c2bda40041f37f0042faca8ccc6de4ce3.zip
Initial commit.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'x11-wm/matwm2')
-rw-r--r--x11-wm/matwm2/ChangeLog10
-rw-r--r--x11-wm/matwm2/files/matwm2-0.0.96-Makefile.patch23
-rw-r--r--x11-wm/matwm2/files/matwm2.desktop5
-rw-r--r--x11-wm/matwm2/matwm2-0.0.96.ebuild40
-rw-r--r--x11-wm/matwm2/metadata.xml9
5 files changed, 87 insertions, 0 deletions
diff --git a/x11-wm/matwm2/ChangeLog b/x11-wm/matwm2/ChangeLog
new file mode 100644
index 000000000000..273338a64a52
--- /dev/null
+++ b/x11-wm/matwm2/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for x11-wm/matwm2
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/matwm2/ChangeLog,v 1.1 2010/01/04 14:52:50 ssuominen Exp $
+
+*matwm2-0.0.96 (04 Jan 2010)
+
+ 04 Jan 2010; Samuli Suominen <ssuominen@gentoo.org> +matwm2-0.0.96.ebuild,
+ +files/matwm2-0.0.96-Makefile.patch, +files/matwm2.desktop:
+ Initial commit.
+
diff --git a/x11-wm/matwm2/files/matwm2-0.0.96-Makefile.patch b/x11-wm/matwm2/files/matwm2-0.0.96-Makefile.patch
new file mode 100644
index 000000000000..16d86a036d40
--- /dev/null
+++ b/x11-wm/matwm2/files/matwm2-0.0.96-Makefile.patch
@@ -0,0 +1,23 @@
+--- Makefile
++++ Makefile
+@@ -4,10 +4,8 @@
+ CC = cc
+ RM = rm -f
+
+-CFLAGS += -I$(XROOT)/include # remove the + for this and the next line if make complains about being unable to add to a non-existing macro
+-LDFLAGS += -lX11 -L$(XROOT)/lib
+ CFLAGS += -DSHAPE # comment out this line to disable shape support
+-LDFLAGS += -lXext # if shape support is disabled, this normally is no longer necessary and schould probally be commented out too
++LIBS += -lXext -lX11 # if shape support is disabled, this normally is no longer necessary and schould probally be commented out too
+
+ #CFLAGS += -DDEBUG -ggdb3 # -DDEBUG_EVENTS -DSYNC # for debugging
+ CFLAGS += -Wall -Wextra -Wno-unused-parameter
+@@ -19,7 +17,7 @@
+ all: matwm2
+
+ matwm2: $(OBJFILES) $(HEADERS)
+- $(CC) -o $@ $(OBJFILES) $(LDFLAGS)
++ $(CC) $(LDFLAGS) -o $@ $(OBJFILES) $(LIBS)
+
+ clean:
+ $(RM) matwm2 *.o
diff --git a/x11-wm/matwm2/files/matwm2.desktop b/x11-wm/matwm2/files/matwm2.desktop
new file mode 100644
index 000000000000..e15f8e95d0a0
--- /dev/null
+++ b/x11-wm/matwm2/files/matwm2.desktop
@@ -0,0 +1,5 @@
+[Desktop Entry]
+Version=1.0
+Name=matwm2
+Exec=matwm2
+Type=Application
diff --git a/x11-wm/matwm2/matwm2-0.0.96.ebuild b/x11-wm/matwm2/matwm2-0.0.96.ebuild
new file mode 100644
index 000000000000..9fe09c0c01f6
--- /dev/null
+++ b/x11-wm/matwm2/matwm2-0.0.96.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/matwm2/matwm2-0.0.96.ebuild,v 1.1 2010/01/04 14:52:50 ssuominen Exp $
+
+EAPI=2
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Simple EWMH compatible window manager with titlebars and frames"
+HOMEPAGE="http://www.gatorgitter.com/~maties/"
+SRC_URI="http://www.gatorgitter.com/~maties/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-Makefile.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ dobin ${PN} || die
+ doman ${PN}.1
+ dodoc BUGS ChangeLog default_matwmrc README TODO
+
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}"/${PN}.desktop || die
+
+ echo ${PN} > "${T}"/${PN}
+ exeinto /etc/X11/Sessions
+ doexe "${T}"/${PN} || die
+}
diff --git a/x11-wm/matwm2/metadata.xml b/x11-wm/matwm2/metadata.xml
new file mode 100644
index 000000000000..70ff4e25b830
--- /dev/null
+++ b/x11-wm/matwm2/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-wm</herd>
+ <maintainer>
+ <email>ssuominen@gentoo.org</email>
+ <name>Samuli Suominen</name>
+ </maintainer>
+</pkgmetadata>