summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom William Payne <twp@gentoo.org>2005-01-02 14:32:57 +0000
committerTom William Payne <twp@gentoo.org>2005-01-02 14:32:57 +0000
commit45b5ac301cd16b05168f9c41b472518f03e3972e (patch)
tree758e192473f4ec178f5b149c41a0af8985e63a08 /x11-wm/ion3
parentAdded a patch to fix bug #72814. (Manifest recommit) (diff)
downloadgentoo-2-45b5ac301cd16b05168f9c41b472518f03e3972e.tar.gz
gentoo-2-45b5ac301cd16b05168f9c41b472518f03e3972e.tar.bz2
gentoo-2-45b5ac301cd16b05168f9c41b472518f03e3972e.zip
Version bump.
Diffstat (limited to 'x11-wm/ion3')
-rw-r--r--x11-wm/ion3/ChangeLog7
-rw-r--r--x11-wm/ion3/Manifest2
-rw-r--r--x11-wm/ion3/files/digest-ion3-200501021
-rw-r--r--x11-wm/ion3/ion3-20050102.ebuild69
4 files changed, 78 insertions, 1 deletions
diff --git a/x11-wm/ion3/ChangeLog b/x11-wm/ion3/ChangeLog
index 70c2fb5b1129..60d8186ede68 100644
--- a/x11-wm/ion3/ChangeLog
+++ b/x11-wm/ion3/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-wm/ion3
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/ion3/ChangeLog,v 1.12 2005/01/01 21:08:14 twp Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/ion3/ChangeLog,v 1.13 2005/01/02 14:32:57 twp Exp $
+
+*ion3-20050102 (02 Jan 2005)
+
+ 02 Jan 2005; Tom Payne <twp@gentoo.org> +ion3-20050102.ebuild:
+ Version bump.
01 Jan 2005; Tom Payne <twp@gentoo.org> ion3-20041005.ebuild,
ion3-20041104.ebuild:
diff --git a/x11-wm/ion3/Manifest b/x11-wm/ion3/Manifest
index a6d81d4aaad6..3ee6c95ecc1d 100644
--- a/x11-wm/ion3/Manifest
+++ b/x11-wm/ion3/Manifest
@@ -1,9 +1,11 @@
MD5 9596129feaea284a4beb62c1f3cd8a33 ion3-20041005.ebuild 1602
MD5 1a2f03e50839cd1db9fd80f64943167c ion3-20041104.ebuild 1602
+MD5 78ee5af620d4f1618bb9d4e7e114da28 ion3-20050102.ebuild 1603
MD5 1a813cff2b0471ababc9a587c8dcf918 ChangeLog 1712
MD5 d992d28bec4a3bfd72b441145091a58e metadata.xml 244
MD5 e5e408ab1f83116c2138a26b20c86653 files/pwm3.desktop 170
MD5 77c936250963ebe695b1d532a1f2c679 files/digest-ion3-20041005 68
MD5 570ce937c79c725002d3109eb0c274d3 files/digest-ion3-20041104 68
MD5 00450ed1292b72e2be71b9860c4db6ee files/ion3.desktop 217
+MD5 77190ca80118b92a5f9ea71208de23ca files/digest-ion3-20050102 68
MD5 aac436d9230b2b3cda72feb184295c1a files/ion.desktop 214
diff --git a/x11-wm/ion3/files/digest-ion3-20050102 b/x11-wm/ion3/files/digest-ion3-20050102
new file mode 100644
index 000000000000..966e7cd4ebc3
--- /dev/null
+++ b/x11-wm/ion3/files/digest-ion3-20050102
@@ -0,0 +1 @@
+MD5 c0a5b7942da52e2c4ed59f5516d6964c ion-3ds-20050102.tar.gz 542053
diff --git a/x11-wm/ion3/ion3-20050102.ebuild b/x11-wm/ion3/ion3-20050102.ebuild
new file mode 100644
index 000000000000..a4a10305c3ce
--- /dev/null
+++ b/x11-wm/ion3/ion3-20050102.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/ion3/ion3-20050102.ebuild,v 1.1 2005/01/02 14:32:57 twp Exp $
+
+inherit eutils
+
+MY_PV=${PV/_p/-}
+MY_PN=ion-3ds-${MY_PV}
+DESCRIPTION="A tiling tabbed window manager designed with keyboard users in mind"
+HOMEPAGE="http://www.iki.fi/tuomov/ion/"
+SRC_URI="http://modeemi.cs.tut.fi/~tuomov/ion/dl/${MY_PN}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~ppc ~sparc ~x86 ~amd64 ~hppa"
+IUSE="xinerama"
+DEPEND="virtual/x11
+ app-misc/run-mailcap
+ >=dev-lang/lua-5.0.2
+ !x11-wm/ion3-svn"
+S=${WORKDIR}/${MY_PN}
+
+src_compile() {
+
+ autoreconf
+
+ local myconf=""
+
+ if has_version '>=x11-base/xfree-4.3.0'; then
+ myconf="${myconf} --disable-xfree86-textprop-bug-workaround"
+ fi
+
+ use hppa && myconf="${myconf} --disable-shared"
+
+ econf \
+ --sysconfdir=/etc/X11 \
+ `use_enable xinerama` \
+ ${myconf} || die
+
+ emake \
+ DOCDIR=/usr/share/doc/${PF} || die
+
+}
+
+src_install() {
+
+ make \
+ prefix=${D}/usr \
+ ETCDIR=${D}/etc/X11/ion3 \
+ SHAREDIR=${D}/usr/share/ion3 \
+ MANDIR=${D}/usr/share/man \
+ DOCDIR=${D}/usr/share/doc/${PF} \
+ LOCALEDIR=${D}/usr/share/locale \
+ LIBDIR=${D}/usr/lib \
+ MODULEDIR=${D}/usr/lib/ion3/mod \
+ LCDIR=${D}/usr/lib/ion3/lc \
+ VARDIR=${D}/var/cache/ion3 \
+ install || die
+
+ prepalldocs
+
+ echo -e "#!/bin/sh\n/usr/bin/ion3" > ${T}/ion3
+ echo -e "#!/bin/sh\n/usr/bin/pwm3" > ${T}/pwm3
+ exeinto /etc/X11/Sessions
+ doexe ${T}/ion3 ${T}/pwm3
+
+ insinto /usr/share/xsessions
+ doins ${FILESDIR}/ion3.desktop ${FILESDIR}/pwm3.desktop
+
+}