summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrad Teaford Cowan <bcowan@gentoo.org>2003-06-15 16:30:32 +0000
committerBrad Teaford Cowan <bcowan@gentoo.org>2003-06-15 16:30:32 +0000
commitf8568764ee3119fb56e132a668fcf3f839428338 (patch)
treed027cf2bd7be6d64223269aa715541f37f7f857e /x11-wm/icewm/icewm-1.2.8.ebuild
parentFix for bug #22861. (diff)
downloadgentoo-2-f8568764ee3119fb56e132a668fcf3f839428338.tar.gz
gentoo-2-f8568764ee3119fb56e132a668fcf3f839428338.tar.bz2
gentoo-2-f8568764ee3119fb56e132a668fcf3f839428338.zip
Version bump.
Diffstat (limited to 'x11-wm/icewm/icewm-1.2.8.ebuild')
-rw-r--r--x11-wm/icewm/icewm-1.2.8.ebuild74
1 files changed, 74 insertions, 0 deletions
diff --git a/x11-wm/icewm/icewm-1.2.8.ebuild b/x11-wm/icewm/icewm-1.2.8.ebuild
new file mode 100644
index 000000000000..547f957f228d
--- /dev/null
+++ b/x11-wm/icewm/icewm-1.2.8.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/icewm/icewm-1.2.8.ebuild,v 1.1 2003/06/15 16:30:17 bcowan Exp $
+
+DESCRIPTION="Ice Window Manager"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.icewm.org"
+IUSE="esd gnome imlib nls spell truetype"
+
+DEPEND="virtual/x11
+ esd? ( media-sound/esound )
+ gnome? ( gnome-base/gnome-libs )
+ imlib? ( >=media-libs/imlib-1.9.10-r1 )
+ nls? ( sys-devel/gettext )
+ truetype? ( >=media-libs/freetype-2.0.9 )"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc "
+
+src_compile(){
+ use esd \
+ && myconf="${myconf} --with-esd-config=/usr/bin/esd-config"
+
+ use nls \
+ && myconf="${myconf} --enable-nls --enable-i18n" \
+ || myconf="${myconf} --disable-nls --disable-i18n"
+
+ use imlib \
+ && myconf="${myconf} --with-imlib --without-xpm" \
+ || myconf="${myconf} --without-imlib --with-xpm"
+
+ use spell \
+ && myconf="${myconf} --enable-GtkSpell" \
+ || myconf="${myconf} --disable-GtkSpell"
+
+ use truetype \
+ && myconf="${myconf} --enable-gradients --with-antialias" \
+ || myconf="${myconf} --disable-xfreetype"
+
+ use x86 \
+ && myconf="${myconf} --enable-x86-asm" \
+ || myconf="${myconf} --disable-x86-asm"
+
+ use gnome \
+ && myconf="${myconf} --with-gnome-menus" \
+ || myconf="${myconf} --without-gnome-menus"
+
+ CXXFLAGS="${CXXFLAGS}" econf \
+ --with-xpm \
+ --with-libdir=/usr/share/icewm \
+ --with-cfgdir=/etc/icewm \
+ --with-docdir=/usr/share/doc/${PF}/html \
+ ${myconf} || die "configure failed"
+
+ emake || die "emake failed"
+}
+
+src_install(){
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS BUGS CHANGES COPYING FAQ PLATFORMS README* TODO VERSION
+ dohtml -a html,sgml doc/*
+
+ echo "#!/bin/bash" > icewm
+ echo "/usr/bin/icewm" >> icewm
+ exeinto /etc/X11/Sessions
+ doexe icewm
+}
+
+pkg_postinst() {
+ echo "Please note that the default icewm libdir has moved from"
+ echo "/usr/lib/icewm to /usr/share/icewm."
+}