summaryrefslogtreecommitdiff
path: root/x11-wm/i3
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2011-08-01 06:17:07 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2011-08-01 06:17:07 +0000
commita8d011cce607af09c967ebabf205310daf118f1a (patch)
treeea0a46ca8d102d0d53e822787d3b1751198cdf08 /x11-wm/i3
parentInitial import. Ebuild written by Kent Fredric <kentfredric@gmail.com> (commi... (diff)
downloadgentoo-2-a8d011cce607af09c967ebabf205310daf118f1a.tar.gz
gentoo-2-a8d011cce607af09c967ebabf205310daf118f1a.tar.bz2
gentoo-2-a8d011cce607af09c967ebabf205310daf118f1a.zip
Version bump, drop old, fix perl dependencies
(Portage version: 2.2.0_alpha49/cvs/Linux x86_64)
Diffstat (limited to 'x11-wm/i3')
-rw-r--r--x11-wm/i3/ChangeLog8
-rw-r--r--x11-wm/i3/files/i3-4.0-gentoo.diff165
-rw-r--r--x11-wm/i3/files/i3-gentoo.diff175
-rw-r--r--x11-wm/i3/i3-3e_p3.ebuild53
-rw-r--r--x11-wm/i3/i3-4.0.ebuild61
5 files changed, 233 insertions, 229 deletions
diff --git a/x11-wm/i3/ChangeLog b/x11-wm/i3/ChangeLog
index d3c911cb56b9..a5c8e221b30c 100644
--- a/x11-wm/i3/ChangeLog
+++ b/x11-wm/i3/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-wm/i3
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/i3/ChangeLog,v 1.2 2011/07/13 08:52:04 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/i3/ChangeLog,v 1.3 2011/08/01 06:17:07 xarthisius Exp $
+
+*i3-4.0 (01 Aug 2011)
+
+ 01 Aug 2011; Kacper Kowalik <xarthisius@gentoo.org> -i3-3e_p3.ebuild,
+ +i3-4.0.ebuild, +files/i3-4.0-gentoo.diff, -files/i3-gentoo.diff:
+ Version bump, drop old, fix perl dependencies
13 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> i3-3e_p3.ebuild:
Add missing dep on dev-util/pkgconfig
diff --git a/x11-wm/i3/files/i3-4.0-gentoo.diff b/x11-wm/i3/files/i3-4.0-gentoo.diff
new file mode 100644
index 000000000000..be0cb2a9cc1a
--- /dev/null
+++ b/x11-wm/i3/files/i3-4.0-gentoo.diff
@@ -0,0 +1,165 @@
+--- a/common.mk
++++ b/common.mk
+@@ -1,5 +1,5 @@
+ UNAME=$(shell uname)
+-DEBUG=1
++DEBUG=0
+ COVERAGE=0
+ INSTALL=install
+ ifndef PREFIX
+@@ -12,7 +12,7 @@
+ SYSCONFDIR=$(PREFIX)/etc
+ endif
+ endif
+-TERM_EMU=xterm
++TERM_EMU=urxvt
+ # The escaping is absurd, but we need to escape for shell, sed, make, define
+ GIT_VERSION:="4.0 (2011-07-31, branch \\\"master\\\")"
+ VERSION:=4.0
+@@ -103,9 +103,6 @@
+ # Extended debugging flags, macros shall be available in gcc
+ CFLAGS += -gdwarf-2
+ CFLAGS += -g3
+-else
+-CFLAGS += -O2
+-CFLAGS += -freorder-blocks-and-partition
+ endif
+
+ ifeq ($(COVERAGE),1)
+@@ -113,9 +110,6 @@
+ LIBS += -lgcov
+ endif
+
+-# Don’t print command lines which are run
+-.SILENT:
+-
+ # Always remake the following targets
+ .PHONY: install clean dist distclean
+
+--- a/Makefile
++++ b/Makefile
+@@ -22,24 +22,19 @@
+
+ # Depend on the specific file (.c for each .o) and on all headers
+ src/%.o: src/%.c ${HEADERS}
+- echo "CC $<"
+ $(CC) $(CPPFLAGS) $(CFLAGS) -DLOGLEVEL="((uint64_t)1 << $(shell awk '/$(shell basename $< .c)/ { print NR; exit 0; }' loglevels.tmp))" -c -o $@ $<
+
+ all: i3 subdirs
+
+ i3: src/cfgparse.y.o src/cfgparse.yy.o src/cmdparse.y.o src/cmdparse.yy.o ${FILES}
+- echo "LINK i3"
+ $(CC) $(LDFLAGS) -o $@ $^ $(LIBS)
+
+ subdirs:
+ for dir in $(SUBDIRS); do \
+- echo ""; \
+- echo "MAKE $$dir"; \
+ $(MAKE) -C $$dir; \
+ done
+
+ loglevels.h:
+- echo "LOGLEVELS"
+ for file in $$(ls src/*.c src/*.y src/*.l | grep -v 'cfgparse.\(tab\|yy\).c'); \
+ do \
+ echo $$(basename $$file .c); \
+@@ -51,29 +46,24 @@
+ echo "};") > include/loglevels.h;
+
+ src/cfgparse.yy.o: src/cfgparse.l src/cfgparse.y.o ${HEADERS}
+- echo "LEX $<"
+ flex -i -o$(@:.o=.c) $<
+ $(CC) $(CPPFLAGS) $(CFLAGS) -DLOGLEVEL="(1 << $(shell awk '/cfgparse.l/ { print NR }' loglevels.tmp))" -c -o $@ $(@:.o=.c)
+
+ src/cmdparse.yy.o: src/cmdparse.l src/cmdparse.y.o ${HEADERS}
+- echo "LEX $<"
+ flex -Pcmdyy -i -o$(@:.o=.c) $<
+ $(CC) $(CPPFLAGS) $(CFLAGS) -DLOGLEVEL="(1 << $(shell awk '/cmdparse.l/ { print NR }' loglevels.tmp))" -c -o $@ $(@:.o=.c)
+
+
+ src/cfgparse.y.o: src/cfgparse.y ${HEADERS}
+- echo "YACC $<"
+ bison --debug --verbose -b $(basename $< .y) -d $<
+ $(CC) $(CPPFLAGS) $(CFLAGS) -DLOGLEVEL="(1 << $(shell awk '/cfgparse.y/ { print NR }' loglevels.tmp))" -c -o $@ $(<:.y=.tab.c)
+
+ src/cmdparse.y.o: src/cmdparse.y ${HEADERS}
+- echo "YACC $<"
+ bison -p cmdyy --debug --verbose -b $(basename $< .y) -d $<
+ $(CC) $(CPPFLAGS) $(CFLAGS) -DLOGLEVEL="(1 << $(shell awk '/cmdparse.y/ { print NR }' loglevels.tmp))" -c -o $@ $(<:.y=.tab.c)
+
+
+ install: all
+- echo "INSTALL"
+ $(INSTALL) -d -m 0755 $(DESTDIR)$(PREFIX)/bin
+ $(INSTALL) -d -m 0755 $(DESTDIR)$(SYSCONFDIR)/i3
+ $(INSTALL) -d -m 0755 $(DESTDIR)$(PREFIX)/include/i3
+@@ -88,6 +78,7 @@
+ for dir in $(SUBDIRS); do \
+ $(MAKE) -C $$dir install; \
+ done
++ $(MAKE) -C man
+
+ dist: distclean
+ [ ! -d i3-${VERSION} ] || rm -rf i3-${VERSION}
+--- a/man/Makefile
++++ b/man/Makefile
+@@ -1,6 +1,8 @@
+ A2M:=a2x -f manpage --asciidoc-opts="-f asciidoc.conf"
+
+-all: i3.1 i3-msg.1 i3-input.1 i3-nagbar.1 i3-wsbar.1 i3-config-wizard.1 i3-migrate-config-to-v4.1
++mans=i3.1 i3-msg.1 i3-input.1 i3-nagbar.1 i3-wsbar.1 i3-config-wizard.1 i3-migrate-config-to-v4.1
++
++all: $(mans)
+
+ %.1: %.man asciidoc.conf
+ ${A2M} $<
+@@ -16,3 +18,9 @@
+
+ distclean: clean
+ rm -f *.1
++
++install:
++ $(INSTALL) -d -m 0755 $(DESTDIR)$(PREFIX)/share/man/man1
++ for man in $(mans); do \
++ $(INSTALL) -m 0644 $$man $(DESTDIR)$(PREFIX)/share/man/man1
++ done
+--- a/i3bar/common.mk
++++ b/i3bar/common.mk
+@@ -13,23 +13,11 @@
+
+ CFLAGS += -Wall
+ CFLAGS += -pipe
+-CFLAGS += -g
+
+ CPPFLAGS += -DI3BAR_VERSION=\"${GIT_VERSION}\"
+-CPPFLAGS += -Iinclude
++CFLAGS += -Iinclude -D_GNU_SOURCE
++CFLAGS += $(shell pkg-config --cflags xcb x11)
+
+-LDFLAGS += -lev
+-LDFLAGS += -lyajl
+-LDFLAGS += -lxcb
+-LDFLAGS += -lX11
+-LDFLAGS += -L/usr/local/lib
+-
+-ifeq ($(DEBUG),1)
+-CFLAGS += -g3
+-else
+-CFLAGS += -O2
+-endif
+-
+-.SILENT:
++LIBS += -lev -lyajl $(shell pkg-config --libs xcb x11)
+
+ .PHONY: install clean
+--- a/i3bar/Makefile
++++ b/i3bar/Makefile
+@@ -10,7 +10,7 @@
+
+ i3bar: ${FILES}
+ echo "LINK"
+- $(CC) -o i3bar ${FILES} ${LDFLAGS}
++ $(CC) $(LDFLAGS) -o i3bar ${FILES} $(LIBS)
+
+ doc:
+ echo ""
diff --git a/x11-wm/i3/files/i3-gentoo.diff b/x11-wm/i3/files/i3-gentoo.diff
deleted file mode 100644
index 003707e96190..000000000000
--- a/x11-wm/i3/files/i3-gentoo.diff
+++ /dev/null
@@ -1,175 +0,0 @@
---- common.mk
-+++ common.mk
-@@ -1,5 +1,5 @@
- UNAME=$(shell uname)
--DEBUG=1
-+DEBUG=0
- INSTALL=install
- PREFIX=/usr
- ifeq ($(PREFIX),/usr)
-@@ -17,8 +17,7 @@
- # We don’t want unused-parameter because of the use of many callbacks
- CFLAGS += -Wunused-value
- CFLAGS += -Iinclude
--CFLAGS += -I/usr/local/include
--CFLAGS += -DI3_VERSION=\"${GIT_VERSION}\"
-+CPPFLAGS += -DI3_VERSION=\"${GIT_VERSION}\"
-
- # Check if pkg-config is installed, because without pkg-config, the following
- # check for the version of libxcb cannot be done.
-@@ -33,27 +32,17 @@
- ifeq ($(shell pkg-config --exact-version=0.3.3 xcb-keysyms && echo 1),1)
- # xcb-keysyms fixed API from 0.3.3 to 0.3.4, so for some months, we will
- # have this here. Distributions should upgrade their libxcb in the meantime.
--CFLAGS += -DOLD_XCB_KEYSYMS_API
-+CPPFLAGS += -DOLD_XCB_KEYSYMS_API
- endif
-
--LDFLAGS += -lm
--LDFLAGS += -lxcb-keysyms
- ifeq ($(shell pkg-config --exists xcb-util || echo 1),1)
--CFLAGS += -DXCB_COMPAT
--LDFLAGS += -lxcb-atom
--LDFLAGS += -lxcb-aux
--LDFLAGS += -lxcb-event
-+CPPFLAGS += -DXCB_COMPAT
-+LIBS += -lxcb-atom -lxcb-aux -lxcb-event
- else
--LDFLAGS += -lxcb-util
-+LIBS += $(shell pkg-config --libs xcb-util)
- endif
--LDFLAGS += -lxcb-icccm
--LDFLAGS += -lxcb-xinerama
--LDFLAGS += -lxcb-randr
--LDFLAGS += -lxcb
--LDFLAGS += -lyajl
--LDFLAGS += -lX11
--LDFLAGS += -lev
--LDFLAGS += -L/usr/local/lib -L/usr/pkg/lib
-+LIBS += $(shell pkg-config --libs xcb-keysyms xcb-icccm xcb-xinerama xcb-randr xcb x11)
-+LIBS += -lyajl -lev -lm
-
- ifeq ($(UNAME),NetBSD)
- # We need -idirafter instead of -I to prefer the system’s iconv over GNU libiconv
-@@ -63,12 +52,12 @@
-
- ifeq ($(UNAME),OpenBSD)
- CFLAGS += -I${X11BASE}/include
--LDFLAGS += -liconv
-+LIBS += -liconv
- LDFLAGS += -L${X11BASE}/lib
- endif
-
- ifeq ($(UNAME),FreeBSD)
--LDFLAGS += -liconv
-+LIBS += -liconv
- endif
-
- # Fallback for libyajl 1 which did not include yajl_version.h. We need
-@@ -76,20 +65,15 @@
- CFLAGS += -idirafter yajl-fallback
-
- ifneq (,$(filter Linux GNU GNU/%, $(UNAME)))
--CFLAGS += -D_GNU_SOURCE
-+CPPFLAGS += -D_GNU_SOURCE
- endif
-
- ifeq ($(DEBUG),1)
- # Extended debugging flags, macros shall be available in gcc
- CFLAGS += -gdwarf-2
- CFLAGS += -g3
--else
--CFLAGS += -O2
- endif
-
--# Don’t print command lines which are run
--.SILENT:
--
- # Always remake the following targets
- .PHONY: install clean dist distclean
-
---- Makefile
-+++ Makefile
-@@ -20,20 +20,14 @@
-
- # Depend on the specific file (.c for each .o) and on all headers
- src/%.o: src/%.c ${HEADERS}
-- echo "CC $<"
-- $(CC) $(CFLAGS) -DLOGLEVEL="(1 << $(shell awk '/$(shell basename $< .c)/ { print NR }' loglevels.tmp))" -c -o $@ $<
-+ $(CC) $(CPPFLAGS) $(CFLAGS) -DLOGLEVEL="(1 << $(shell awk '/$(shell basename $< .c)/ { print NR }' loglevels.tmp))" -c -o $@ $<
-
- all: src/cfgparse.y.o src/cfgparse.yy.o ${FILES}
-- echo "LINK i3"
-- $(CC) -o i3 ${FILES} src/cfgparse.y.o src/cfgparse.yy.o $(LDFLAGS)
-- echo ""
-- echo "SUBDIR i3-msg"
-+ $(CC) $(LDFLAGS) -o i3 ${FILES} src/cfgparse.y.o src/cfgparse.yy.o $(LIBS)
- $(MAKE) TOPDIR=$(TOPDIR) -C i3-msg
-- echo "SUBDIR i3-input"
- $(MAKE) TOPDIR=$(TOPDIR) -C i3-input
-
- loglevels.h:
-- echo "LOGLEVELS"
- for file in $$(ls src/*.c src/*.y src/*.l | grep -v 'cfgparse.\(tab\|yy\).c'); \
- do \
- echo $$(basename $$file .c); \
-@@ -45,17 +39,14 @@
- echo "};") > include/loglevels.h;
-
- src/cfgparse.yy.o: src/cfgparse.l src/cfgparse.y.o ${HEADERS}
-- echo "LEX $<"
- flex -i -o$(@:.o=.c) $<
-- $(CC) $(CFLAGS) -DLOGLEVEL="(1 << $(shell awk '/cfgparse.l/ { print NR }' loglevels.tmp))" -c -o $@ $(@:.o=.c)
-+ $(CC) $(CPPFLAGS) $(CFLAGS) -DLOGLEVEL="(1 << $(shell awk '/cfgparse.l/ { print NR }' loglevels.tmp))" -c -o $@ $(@:.o=.c)
-
- src/cfgparse.y.o: src/cfgparse.y ${HEADERS}
-- echo "YACC $<"
- bison --debug --verbose -b $(basename $< .y) -d $<
-- $(CC) $(CFLAGS) -DLOGLEVEL="(1 << $(shell awk '/cfgparse.y/ { print NR }' loglevels.tmp))" -c -o $@ $(<:.y=.tab.c)
-+ $(CC) $(CPPFLAGS) $(CFLAGS) -DLOGLEVEL="(1 << $(shell awk '/cfgparse.y/ { print NR }' loglevels.tmp))" -c -o $@ $(<:.y=.tab.c)
-
- install: all
-- echo "INSTALL"
- $(INSTALL) -d -m 0755 $(DESTDIR)$(PREFIX)/bin
- $(INSTALL) -d -m 0755 $(DESTDIR)$(SYSCONFDIR)/i3
- $(INSTALL) -d -m 0755 $(DESTDIR)$(PREFIX)/include/i3
---- i3-msg/Makefile
-+++ i3-msg/Makefile
-@@ -11,15 +11,12 @@
-
- # Depend on the specific file (.c for each .o) and on all headers
- %.o: %.c ${HEADERS}
-- echo "CC $<"
-- $(CC) $(CFLAGS) -c -o $@ $<
-+ $(CC) $(CPPFLAGS) $(CFLAGS) -c -o $@ $<
-
- all: ${FILES}
-- echo "LINK i3-msg"
-- $(CC) -o i3-msg ${FILES} $(LDFLAGS)
-+ $(CC) $(LDFLAGS) -o i3-msg ${FILES} $(LIBS)
-
- install: all
-- echo "INSTALL"
- $(INSTALL) -d -m 0755 $(DESTDIR)$(PREFIX)/bin
- $(INSTALL) -m 0755 i3-msg $(DESTDIR)$(PREFIX)/bin/
-
---- i3-input/Makefile
-+++ i3-input/Makefile
-@@ -9,15 +9,12 @@
-
- # Depend on the specific file (.c for each .o) and on all headers
- %.o: %.c ${HEADERS}
-- echo "CC $<"
-- $(CC) $(CFLAGS) -c -o $@ $<
-+ $(CC) $(CPPFLAGS) $(CFLAGS) -c -o $@ $<
-
- all: ${FILES}
-- echo "LINK i3-input"
-- $(CC) -o i3-input ${FILES} $(LDFLAGS)
-+ $(CC) $(LDFLAGS) -o i3-input ${FILES} $(LIBS)
-
- install: all
-- echo "INSTALL"
- $(INSTALL) -d -m 0755 $(DESTDIR)$(PREFIX)/bin
- $(INSTALL) -m 0755 i3-input $(DESTDIR)$(PREFIX)/bin/
-
diff --git a/x11-wm/i3/i3-3e_p3.ebuild b/x11-wm/i3/i3-3e_p3.ebuild
deleted file mode 100644
index 94a637d6decc..000000000000
--- a/x11-wm/i3/i3-3e_p3.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/i3/i3-3e_p3.ebuild,v 1.2 2011/07/13 08:52:04 xarthisius Exp $
-
-EAPI=4
-
-inherit base versionator toolchain-funcs
-
-MY_PV=$(version_format_string '$1.$2-${3/p/bf}')
-MY_P=${PN}-${MY_PV}
-
-DESCRIPTION="An improved dynamic tiling window manager"
-HOMEPAGE="http://i3wm.org/"
-SRC_URI="http://i3wm.org/downloads/${MY_P}.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-CDEPEND="dev-libs/libev
- dev-libs/yajl
- x11-libs/libxcb
- x11-libs/libX11
- x11-libs/xcb-util"
-DEPEND="${CDEPEND}
- dev-util/pkgconfig
- sys-devel/flex
- sys-devel/bison
- x11-proto/xcb-proto"
-RDEPEND="${CDEPEND}
- x11-apps/xmessage"
-
-S=${WORKDIR}/${MY_P}
-
-DOCS=( GOALS TODO RELEASE-NOTES-${MY_PV} )
-PATCHES=( "${FILESDIR}"/${PN}-gentoo.diff )
-
-pkg_setup() {
- tc-export CC
-}
-
-src_install() {
- base_src_install
- doman man/*.1
- dohtml -r docs/*
-}
-
-pkg_postinst() {
- elog "${PN} by default uses x11-terms/rxvt-unicode as a default terminal."
- elog "Either merge it yourself or change proper bind in /etc/${PN}/config"
- elog "or ~/.i3/config"
-}
diff --git a/x11-wm/i3/i3-4.0.ebuild b/x11-wm/i3/i3-4.0.ebuild
new file mode 100644
index 000000000000..c9817f4c4628
--- /dev/null
+++ b/x11-wm/i3/i3-4.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/i3/i3-4.0.ebuild,v 1.1 2011/08/01 06:17:07 xarthisius Exp $
+
+EAPI=4
+
+inherit base versionator toolchain-funcs
+
+DESCRIPTION="An improved dynamic tiling window manager"
+HOMEPAGE="http://i3wm.org/"
+SRC_URI="http://i3wm.org/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+CDEPEND="dev-libs/libev
+ dev-libs/yajl
+ x11-libs/libxcb
+ x11-libs/libX11
+ x11-libs/xcb-util"
+DEPEND="${CDEPEND}
+ dev-util/pkgconfig
+ sys-devel/flex
+ sys-devel/bison
+ x11-proto/xcb-proto"
+RDEPEND="${CDEPEND}
+ dev-perl/AnyEvent-I3
+ dev-perl/IPC-Run
+ dev-perl/Try-Tiny
+ virtual/perl-Getopt-Long
+ x11-apps/xmessage"
+
+DOCS=( GOALS TODO RELEASE-NOTES-${PV} )
+PATCHES=( "${FILESDIR}"/${P}-gentoo.diff )
+
+pkg_setup() {
+ tc-export CC
+ ewarn "${PN} uses x11-terms/rxvt-unicode as a default terminal."
+ ewarn "If you wish to use another one merge ${PN} with:"
+ ewarn " TERM_EMU=<YOUR_TERM> emerge ${PN}"
+ ewarn "e.g. TERM_EMU=xterm"
+}
+
+src_prepare() {
+ base_src_prepare
+ sed -i -e "/echo \"/d" \
+ i3{bar,-config-wizard,-input,-msg,-nagbar}/Makefile || die
+}
+
+src_install() {
+ base_src_install
+ dohtml -r docs/*
+}
+
+pkg_postinst() {
+ elog "${PN} uses x11-terms/rxvt-unicode as a default terminal."
+ elog "Either merge it yourself or change proper bind in"
+ elog "/etc/${PN}/config or ~/.${PN}/config"
+}