summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTod Neidt <tod@gentoo.org>2002-01-25 07:51:59 +0000
committerTod Neidt <tod@gentoo.org>2002-01-25 07:51:59 +0000
commit6ffc046549537852c9436507f7ca6238c633dab0 (patch)
treeccce304b57f2937f470219a55f289b2fed1ec29a /x11-wm/flwm
parentlatest beta (diff)
downloadgentoo-2-6ffc046549537852c9436507f7ca6238c633dab0.tar.gz
gentoo-2-6ffc046549537852c9436507f7ca6238c633dab0.tar.bz2
gentoo-2-6ffc046549537852c9436507f7ca6238c633dab0.zip
updated syntax, added info so users can customize behavior and apperance (build only configuration)
Diffstat (limited to 'x11-wm/flwm')
-rw-r--r--x11-wm/flwm/files/digest-flwm-1.00-r21
-rw-r--r--x11-wm/flwm/flwm-1.00-r2.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/x11-wm/flwm/files/digest-flwm-1.00-r2 b/x11-wm/flwm/files/digest-flwm-1.00-r2
new file mode 100644
index 000000000000..0a879db8b0ba
--- /dev/null
+++ b/x11-wm/flwm/files/digest-flwm-1.00-r2
@@ -0,0 +1 @@
+MD5 75047b2ddcac30eecfb380773177d54d flwm-1.00.tgz 65536
diff --git a/x11-wm/flwm/flwm-1.00-r2.ebuild b/x11-wm/flwm/flwm-1.00-r2.ebuild
new file mode 100644
index 000000000000..8066ace745b9
--- /dev/null
+++ b/x11-wm/flwm/flwm-1.00-r2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Michael Conrad Tilstra <tadpol@gentoo.org> <tadpol@tadpol.org>
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/flwm/flwm-1.00-r2.ebuild,v 1.1 2002/01/25 07:51:59 tod Exp $
+
+S=${WORKDIR}/${P}
+
+SRC_URI="http://flwm.sourceforge.net/${P}.tgz"
+
+HOMEPAGE="http://flwm.sourceforge.net"
+
+DESCRIPTION="A lightweight window manager based on fltk"
+
+DEPEND=">=x11-base/xfree-4.0.1
+ >=x11-libs/fltk-1.0.11
+ opengl? ( virtual/opengl )"
+
+ #Configuration of the appearance and behavior of flwm
+ #must be done at compile time, i.e. there is
+ #no .flwmrc file or interactive configuring while
+ #running. To quote the man page, "gcc is your friend,"
+ #so this type of configuration must be done at compile
+ #time by editing the config.h file. I can't see any
+ #way to do this automagically so we'll echo a message
+ #in pkg_postinst to tell the user to 'ebuild unpack'
+ #and edit the config.h to their liking.
+
+src_compile() {
+
+ use opengl && export X_EXTRA_LIBS=-lGL
+
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --host=${CHOST} \ || die "Configuration Failed"
+
+ emake || die "Parallel Make Failed"
+
+}
+
+src_install() {
+
+ doman flwm.1
+ dodoc README flwm_wmconfig
+
+ into /usr
+ dobin flwm
+
+}
+
+pkg_postinst() {
+
+ echo "**********************************************"
+ echo "Customization of behaviour and appearance of"
+ echo "flwm requires manually editing the config.h"
+ echo "source file. If you want to change the defaults,"
+ echo "Do the following:"
+ echo ""
+ echo "ebuild ${P}.ebuild unpack"
+ echo "${EDITOR} ${S}/config.h "
+ echo "ebuild ${P} compile install qmerge"
+ echo ""
+ echo "**********************************************"
+
+}