summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2008-03-16 12:14:05 +0000
committerCédric Krier <cedk@gentoo.org>2008-03-16 12:14:05 +0000
commit3a2e369d1b16d3a277b7942c29e57baf71750b83 (patch)
tree62d24c0a69c8c82c92675927615e5abfafb2b120 /x11-wm/dwm
parentVersion bump (diff)
downloadgentoo-2-3a2e369d1b16d3a277b7942c29e57baf71750b83.tar.gz
gentoo-2-3a2e369d1b16d3a277b7942c29e57baf71750b83.tar.bz2
gentoo-2-3a2e369d1b16d3a277b7942c29e57baf71750b83.zip
Version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'x11-wm/dwm')
-rw-r--r--x11-wm/dwm/ChangeLog7
-rw-r--r--x11-wm/dwm/dwm-4.8.ebuild66
2 files changed, 72 insertions, 1 deletions
diff --git a/x11-wm/dwm/ChangeLog b/x11-wm/dwm/ChangeLog
index 98795a2ed60a..a8a9fe47042b 100644
--- a/x11-wm/dwm/ChangeLog
+++ b/x11-wm/dwm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-wm/dwm
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/dwm/ChangeLog,v 1.32 2008/02/08 14:23:58 cedk Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/dwm/ChangeLog,v 1.33 2008/03/16 12:14:05 cedk Exp $
+
+*dwm-4.8 (16 Mar 2008)
+
+ 16 Mar 2008; Cédric Krier <cedk@gentoo.org> +dwm-4.8.ebuild:
+ Version bump
08 Feb 2008; Cédric Krier <cedk@gentoo.org> metadata.xml:
Add desktop-wm as backup herd
diff --git a/x11-wm/dwm/dwm-4.8.ebuild b/x11-wm/dwm/dwm-4.8.ebuild
new file mode 100644
index 000000000000..9f7288b5357d
--- /dev/null
+++ b/x11-wm/dwm/dwm-4.8.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/dwm/dwm-4.8.ebuild,v 1.1 2008/03/16 12:14:05 cedk Exp $
+
+inherit toolchain-funcs savedconfig
+
+DESCRIPTION="a dynamic window manager for X11"
+HOMEPAGE="http://dwm.suckless.org/"
+SRC_URI="http://suckless.org/download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="x11-libs/libX11"
+RDEPEND=${DEPEND}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i \
+ -e "s/CFLAGS = -Os/CFLAGS += -g/" \
+ -e "s/LDFLAGS = -s/LDFLAGS += -g/" \
+ config.mk || die "sed failed"
+
+ if use savedconfig; then
+ restore_config config.h
+ fi
+}
+
+src_compile() {
+ local msg
+ use savedconfig && msg=", please check the configfile"
+ emake CC=$(tc-getCC) || die "emake failed${msg}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install || die "emake install failed"
+
+ insinto /usr/share/${PN}
+ newins config.h ${PF}.config.h
+
+ exeinto /etc/X11/Sessions
+ newexe "${FILESDIR}"/dwm-session dwm
+
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}"/dwm.desktop
+
+ dodoc README
+
+ save_config config.h
+}
+
+pkg_postinst() {
+ einfo "This ebuild has support for user defined configs"
+ einfo "Please read this ebuild for more details and re-emerge as needed"
+ einfo "if you want to add or remove functionality for ${PN}"
+ if ! has_version x11-misc/dmenu; then
+ elog "Installing ${PN} without x11-misc/dmenu"
+ einfo "To have a menu you can install x11-misc/dmenu"
+ fi
+ einfo "You can custom status bar with a script in HOME/.dwm/dwmrc"
+ einfo "the ouput is redirected to the standard input of dwm"
+}