summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Jackson <tsunam@gentoo.org>2006-12-19 21:52:25 +0000
committerJoshua Jackson <tsunam@gentoo.org>2006-12-19 21:52:25 +0000
commit615ef11ede21e6807ac8a4dd8b23984e0c4f88a9 (patch)
tree115e8e81ce9447d7c1c6075f0d7a7cdf93556786 /x11-wm/beryl-core
parentVersion bumping beryl to catch up with upstream #157727 (diff)
downloadgentoo-2-615ef11ede21e6807ac8a4dd8b23984e0c4f88a9.tar.gz
gentoo-2-615ef11ede21e6807ac8a4dd8b23984e0c4f88a9.tar.bz2
gentoo-2-615ef11ede21e6807ac8a4dd8b23984e0c4f88a9.zip
Version bumping beryl to catch up with upstream #157727
(Portage version: 2.1.1-r2)
Diffstat (limited to 'x11-wm/beryl-core')
-rw-r--r--x11-wm/beryl-core/ChangeLog9
-rw-r--r--x11-wm/beryl-core/beryl-core-0.1.3.ebuild39
-rw-r--r--x11-wm/beryl-core/files/beryl-core-gconf.patch48
-rw-r--r--x11-wm/beryl-core/files/digest-beryl-core-0.1.33
4 files changed, 98 insertions, 1 deletions
diff --git a/x11-wm/beryl-core/ChangeLog b/x11-wm/beryl-core/ChangeLog
index bbdbb4fada07..f06c99a924a3 100644
--- a/x11-wm/beryl-core/ChangeLog
+++ b/x11-wm/beryl-core/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-wm/beryl-core
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/beryl-core/ChangeLog,v 1.4 2006/11/15 04:04:47 tsunam Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/beryl-core/ChangeLog,v 1.5 2006/12/19 21:52:25 tsunam Exp $
+
+*beryl-core-0.1.3 (19 Dec 2006)
+
+ 19 Dec 2006; Joshua Jackson <tsunam@gentoo.org>
+ +files/beryl-core-gconf.patch, -beryl-core-0.1.1.ebuild,
+ -beryl-core-0.1.2.ebuild, +beryl-core-0.1.3.ebuild:
+ Version bump a week late for bug #157727; also general cleanup of old versions
*beryl-core-0.1.2 (15 Nov 2006)
diff --git a/x11-wm/beryl-core/beryl-core-0.1.3.ebuild b/x11-wm/beryl-core/beryl-core-0.1.3.ebuild
new file mode 100644
index 000000000000..d47eb29c5096
--- /dev/null
+++ b/x11-wm/beryl-core/beryl-core-0.1.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/beryl-core/beryl-core-0.1.3.ebuild,v 1.1 2006/12/19 21:52:25 tsunam Exp $
+
+inherit autotools
+
+DESCRIPTION="Beryl window manager for AIGLX and XGL"
+HOMEPAGE="http://beryl-project.org"
+SRC_URI="http://releases.beryl-project.org/${PV}/${P}.tar.bz2
+ http://releases.beryl-project.org/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE=""
+
+DEPEND=">=x11-base/xorg-server-1.1.1-r1
+ >=x11-libs/gtk+-2.8.0
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXrandr
+ x11-libs/startup-notification"
+
+RDEPEND="${DEPEND}
+ x11-apps/xdpyinfo"
+
+PDEPEND="~x11-plugins/beryl-plugins-${PV}"
+
+src_compile() {
+ epatch "${FILESDIR}"/${PN}-gconf.patch
+ eautoreconf
+
+ econf --with-berylmesadir="${WORKDIR}/beryl-mesa" || die "econf failed"
+ emake -j1 || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+}
diff --git a/x11-wm/beryl-core/files/beryl-core-gconf.patch b/x11-wm/beryl-core/files/beryl-core-gconf.patch
new file mode 100644
index 000000000000..6f7ce662a3f5
--- /dev/null
+++ b/x11-wm/beryl-core/files/beryl-core-gconf.patch
@@ -0,0 +1,48 @@
+Index: configure.ac
+===================================================================
+--- configure.ac (revision 1653)
++++ configure.ac (working copy)
+@@ -94,8 +94,20 @@
+ PKG_CHECK_MODULES(BERYL, $BERYL_REQUIRES)
+ AC_SUBST(BERYL_REQUIRES)
+ PKG_CHECK_MODULES(GLIB, "glib-2.0")
+-PKG_CHECK_MODULES(GCONF, "gconf-2.0")
+
++AC_ARG_ENABLE(gconf, [--enable-gconf Enable GConf backend for libberylsettings],
++ [beryl_gconf=$enableval],[beryl_gconf=no])
++
++if test "x$beryl_gconf" = "xyes"
++then
++ PKG_CHECK_MODULES(GCONF, "gconf-2.0")
++fi
++
++AM_CONDITIONAL(GCONF_BACKEND, test "x$beryl_gconf" = "xyes")
++if test "$beryl_gconf" = yes; then
++ AC_DEFINE(USE_GCONF, 1, [Build gconf backend])
++fi
++
+ AC_ARG_WITH( berylmesadir,
+ [ --with-berylmesadir Set beryl internal mesa path (needed for static linked beryl-xgl) [default=../beryl-mesa] ],
+ [ beryl_mesa_dir=${withval}],[ beryl_mesa_dir="../beryl-mesa" ])
+
+Index: settings-backends/Makefile.am
+===================================================================
+--- settings-backends/Makefile.am (revision 1653)
++++ settings-backends/Makefile.am (working copy)
+@@ -7,12 +7,14 @@
+ libini_la_LIBADD = @GLIB_LIBS@ @BERYL_LIBS@ ../libberylsettings/libberylsettings.la
+ libini_la_SOURCES = ini.c
+
++if GCONF_BACKEND
+ libgconf_la_LDFLAGS = -module -avoid-version -no-undefined
+ libgconf_la_LIBADD = @GCONF_LIBS@ @GLIB_LIBS@ @BERYL_LIBS@ ../libberylsettings/libberylsettings.la
+ libgconf_la_SOURCES = gconf.c
+-
++libgconf_module=libgconf.la
++endif
+ backenddir = $(plugindir)/backends
+
+ backend_LTLIBRARIES = \
+ libini.la \
+- libgconf.la
++ $(libgconf_module)
diff --git a/x11-wm/beryl-core/files/digest-beryl-core-0.1.3 b/x11-wm/beryl-core/files/digest-beryl-core-0.1.3
new file mode 100644
index 000000000000..fa0b2a28d1ed
--- /dev/null
+++ b/x11-wm/beryl-core/files/digest-beryl-core-0.1.3
@@ -0,0 +1,3 @@
+MD5 24caed8a8cb50fd30823a9ee182f85f4 beryl-core-0.1.3.tar.bz2 401682
+RMD160 a3950ee3b987673da049b7e5e9423a4e5ce492ca beryl-core-0.1.3.tar.bz2 401682
+SHA256 d5a543e41c5fe63410fd8c8e3a8e5c205a61ba29c74c518a6d218562ec012bc7 beryl-core-0.1.3.tar.bz2 401682