summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2013-04-10 09:46:27 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2013-04-10 09:46:27 +0000
commit5666dab696d7555f9503ff60cceea67dc9b6e75e (patch)
tree086795c874fbb120e0a37483708296230f8b9278 /x11-wm/afterstep
parentRevision bump: EAPI 5, correct dependency on sys-libs/ncurses, add patch to p... (diff)
downloadgentoo-2-5666dab696d7555f9503ff60cceea67dc9b6e75e.tar.gz
gentoo-2-5666dab696d7555f9503ff60cceea67dc9b6e75e.tar.bz2
gentoo-2-5666dab696d7555f9503ff60cceea67dc9b6e75e.zip
EAPI bump and libpng slot dependency
(Portage version: 2.2.0_alpha171/cvs/Linux x86_64, signed Manifest commit with key C74525F2)
Diffstat (limited to 'x11-wm/afterstep')
-rw-r--r--x11-wm/afterstep/ChangeLog8
-rw-r--r--x11-wm/afterstep/afterstep-2.2.11-r1.ebuild123
2 files changed, 130 insertions, 1 deletions
diff --git a/x11-wm/afterstep/ChangeLog b/x11-wm/afterstep/ChangeLog
index 3ab07114ce87..553f3f5335f5 100644
--- a/x11-wm/afterstep/ChangeLog
+++ b/x11-wm/afterstep/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-wm/afterstep
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/afterstep/ChangeLog,v 1.103 2013/04/06 01:04:10 naota Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/afterstep/ChangeLog,v 1.104 2013/04/10 09:46:27 voyageur Exp $
+
+*afterstep-2.2.11-r1 (10 Apr 2013)
+
+ 10 Apr 2013; Bernard Cafarelli <voyageur@gentoo.org>
+ +afterstep-2.2.11-r1.ebuild:
+ EAPI bump and libpng slot dependency
06 Apr 2013; Naohiro Aota <naota@gentoo.org>
+files/afterstep-2.2.11-configure.patch,
diff --git a/x11-wm/afterstep/afterstep-2.2.11-r1.ebuild b/x11-wm/afterstep/afterstep-2.2.11-r1.ebuild
new file mode 100644
index 000000000000..9c4a10458317
--- /dev/null
+++ b/x11-wm/afterstep/afterstep-2.2.11-r1.ebuild
@@ -0,0 +1,123 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/afterstep/afterstep-2.2.11-r1.ebuild,v 1.1 2013/04/10 09:46:27 voyageur Exp $
+
+EAPI=5
+inherit autotools eutils flag-o-matic
+
+DESCRIPTION="A feature rich NeXTish window manager"
+HOMEPAGE="http://www.afterstep.org/"
+SRC_URI="ftp://ftp.afterstep.org/stable/AfterStep-${PV}.tar.bz2
+ mirror://sourceforge/${PN}/AfterStep-${PV}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="alsa debug dbus gif gtk jpeg mmx nls png svg tiff xinerama"
+
+RDEPEND="media-libs/freetype
+ alsa? ( media-libs/alsa-lib )
+ dbus? ( sys-apps/dbus )
+ jpeg? ( virtual/jpeg )
+ gif? ( >=media-libs/giflib-4.1.0 )
+ gtk? ( x11-libs/gtk+:2 )
+ png? ( media-libs/libpng:0= )
+ svg? ( gnome-base/librsvg:2 )
+ tiff? ( media-libs/tiff:0 )
+ x11-libs/libICE
+ x11-libs/libXext
+ x11-libs/libSM
+ x11-libs/libXmu
+ x11-libs/libXt
+ x11-libs/libX11
+ x11-libs/libXpm
+ x11-libs/libXrender
+ xinerama? ( x11-libs/libXinerama )"
+DEPEND="${RDEPEND}
+ !!media-libs/libafterimage
+ x11-proto/xextproto
+ x11-proto/xproto
+ xinerama? ( x11-proto/xineramaproto )"
+
+S=${WORKDIR}/AfterStep-${PV}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.2.9-{alpha,ldflags,libpng15}.patch
+ epatch "${FILESDIR}"/${PN}-2.2.11-{execinfo,configure}.patch
+
+ sed -i -e '/^install:/s:install.alternative ::' Makefile.in || die
+ sed -i -e '/CFLAGS="-O3"/d' libAfter{Base,Image}/configure || die
+ sed -i -e '/STRIP_BINARIES/s:-s::' autoconf/configure.in || die #252119
+ sed -i -e '/--with-builtin-gif/s/$with_gif/no/' autoconf/configure.in || die #253259
+
+ pushd autoconf >/dev/null
+ eautoreconf
+ cp autoconf/config.h.in ./ || die
+ cp configure ../ || die
+ popd >/dev/null
+
+ pushd libAfterBase >/dev/null
+ eautoreconf
+ popd >/dev/null
+}
+
+src_configure() {
+ local myconf
+
+ use debug && myconf="--enable-gdb --enable-warn --enable-gprof
+ --enable-audit --enable-trace --enable-trace-x"
+
+ # Explanation of configure options
+ # ================================
+ # --with-helpcommand="xterm -e man" - Avoid installing xiterm
+ # --with-xpm - Contained in xfree
+ # --disable-availability - So we can use complete paths for menuitems
+ # --enable-ascp - The AfterStep ControlPanel is abandoned
+ # LDCONFIG - bug #265841
+
+ LDCONFIG=/bin/true econf \
+ $(use_enable alsa) \
+ $(use_enable mmx mmx-optimization) \
+ $(use_enable nls i18n) \
+ $(use_enable xinerama) \
+ $(use_with dbus dbus1) \
+ $(use_with gif) \
+ $(use_with gtk) \
+ $(use_with jpeg) \
+ $(use_with png) \
+ $(use_with tiff) \
+ $(use_with svg) \
+ --with-helpcommand="xterm -e man" \
+ --disable-availability \
+ --disable-staticlibs \
+ --enable-ascp=no \
+ ${myconf}
+}
+
+src_compile() {
+ # gcc: ../libAfterConf/libAfterConf.a: No such file or directory
+ # make[1]: *** [PrintDesktopEntries] Error 1
+ emake -j1
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ # Create a symlink from MonitorWharf to Wharf
+ rm "${D}"/usr/bin/MonitorWharf
+ dosym /usr/bin/Wharf /usr/bin/MonitorWharf
+
+ # Handle the documentation
+ dodoc ChangeLog INSTALL NEW* README* TEAM UPGRADE
+ cp -pPR TODO "${D}"/usr/share/doc/${PF}/
+ dodir /usr/share/doc/${PF}/html
+ cp -pPR doc/* "${D}"/usr/share/doc/${PF}/html
+ rm "${D}"/usr/share/doc/${PF}/html/{Makefile*,afterstepdoc.in}
+
+ insinto /usr/share/xsessions
+ newins AfterStep.desktop.final AfterStep.desktop
+
+ # For desktop managers like GDM or KDE
+ exeinto /etc/X11/Sessions
+ doexe "${FILESDIR}"/${PN}
+}