summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2011-10-30 01:12:31 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2011-10-30 01:12:31 +0000
commitbd09275b4b06efcf4218048fe271d730ec2f68c3 (patch)
tree2939a0284e99fb3b2c62c9d2cc040bf5948d8c80 /x11-themes
parentAdd tracker-0.12, gnome-contacts, gnome-documents, nautilus-tracker-tags, and... (diff)
downloadgentoo-2-bd09275b4b06efcf4218048fe271d730ec2f68c3.tar.gz
gentoo-2-bd09275b4b06efcf4218048fe271d730ec2f68c3.tar.bz2
gentoo-2-bd09275b4b06efcf4218048fe271d730ec2f68c3.zip
Bump to 3.2.1.2 from the gnome overlay.
(Portage version: 2.2.0_alpha71/cvs/Linux x86_64)
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/gnome-icon-theme/ChangeLog8
-rw-r--r--x11-themes/gnome-icon-theme/gnome-icon-theme-3.2.1.2.ebuild55
2 files changed, 62 insertions, 1 deletions
diff --git a/x11-themes/gnome-icon-theme/ChangeLog b/x11-themes/gnome-icon-theme/ChangeLog
index 6e3832db9e2e..74a2dee92a43 100644
--- a/x11-themes/gnome-icon-theme/ChangeLog
+++ b/x11-themes/gnome-icon-theme/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-themes/gnome-icon-theme
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/gnome-icon-theme/ChangeLog,v 1.205 2011/10/05 17:38:11 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gnome-icon-theme/ChangeLog,v 1.206 2011/10/30 01:12:31 tetromino Exp $
+
+*gnome-icon-theme-3.2.1.2 (30 Oct 2011)
+
+ 30 Oct 2011; Alexandre Rostovtsev <tetromino@gentoo.org>
+ +gnome-icon-theme-3.2.1.2.ebuild:
+ Bump to 3.2.1.2 from the gnome overlay.
05 Oct 2011; Kacper Kowalik <xarthisius@gentoo.org>
gnome-icon-theme-3.0.0.ebuild:
diff --git a/x11-themes/gnome-icon-theme/gnome-icon-theme-3.2.1.2.ebuild b/x11-themes/gnome-icon-theme/gnome-icon-theme-3.2.1.2.ebuild
new file mode 100644
index 000000000000..9265ddf661a1
--- /dev/null
+++ b/x11-themes/gnome-icon-theme/gnome-icon-theme-3.2.1.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gnome-icon-theme/gnome-icon-theme-3.2.1.2.ebuild,v 1.1 2011/10/30 01:12:31 tetromino Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+
+inherit gnome2 eutils autotools
+
+DESCRIPTION="GNOME default icon theme"
+HOMEPAGE="http://www.gnome.org/ http://people.freedesktop.org/~jimmac/icons/#git"
+
+SRC_URI="${SRC_URI}
+ branding? ( http://www.mail-archive.com/tango-artists@lists.freedesktop.org/msg00043/tango-gentoo-v1.1.tar.gz )"
+
+LICENSE="LGPL-3 CCPL-Attribution-ShareAlike-3.0
+ branding? ( CCPL-Sampling-Plus-1.0 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="branding"
+
+RDEPEND=">=x11-themes/hicolor-icon-theme-0.10"
+DEPEND="${RDEPEND}
+ >=x11-misc/icon-naming-utils-0.8.7
+ >=dev-util/pkgconfig-0.19
+ >=dev-util/intltool-0.40
+ sys-devel/gettext"
+
+# This ebuild does not install any binaries
+RESTRICT="binchecks strip"
+
+# FIXME: double check potential LINGUAS problem
+pkg_setup() {
+ DOCS="AUTHORS NEWS TODO"
+ G2CONF="${G2CONF}
+ --enable-icon-mapping
+ GTK_UPDATE_ICON_CACHE=$(type -p true)"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ if use branding; then
+ for i in 16 22 24 32 48; do
+ cp "${WORKDIR}"/tango-gentoo-v1.1/${i}x${i}/gentoo.png \
+ "${S}"/gnome//${i}x${i}/places/start-here.png \
+ || die "Copying gentoo logos failed"
+ done
+ fi
+
+ # Revert upstream commit that is wrongly updating icon cache, upstream bug #642449
+ EPATCH_OPTS="-R" epatch "${FILESDIR}/${PN}-2.91.7-update-cache.patch"
+ intltoolize --force --copy --automake || die "intltoolize failed"
+ eautoreconf
+}