summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Anderson <gentoofan23@gentoo.org>2008-06-27 17:04:20 +0000
committerThomas Anderson <gentoofan23@gentoo.org>2008-06-27 17:04:20 +0000
commitbce0f64d7cd75be93772b92c381d71fc4fc27872 (patch)
tree8d7dd1984c07f7729595dbb71fcad1a72e5cb8c0 /x11-themes
parent(#227821) Remove patch because ati 6.9 driver appears to work fine without it... (diff)
downloadgentoo-2-bce0f64d7cd75be93772b92c381d71fc4fc27872.tar.gz
gentoo-2-bce0f64d7cd75be93772b92c381d71fc4fc27872.tar.bz2
gentoo-2-bce0f64d7cd75be93772b92c381d71fc4fc27872.zip
Fix implicit declarations of gtk functions.
(Portage version: 2.1.4.4)
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/gtk-chtheme/ChangeLog6
-rw-r--r--x11-themes/gtk-chtheme/files/gtk-chtheme-0.3.1-implicit.patch12
-rw-r--r--x11-themes/gtk-chtheme/gtk-chtheme-0.3.1-r1.ebuild6
3 files changed, 21 insertions, 3 deletions
diff --git a/x11-themes/gtk-chtheme/ChangeLog b/x11-themes/gtk-chtheme/ChangeLog
index b8a4f2c44bc6..d11b65fec16f 100644
--- a/x11-themes/gtk-chtheme/ChangeLog
+++ b/x11-themes/gtk-chtheme/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-themes/gtk-chtheme
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-chtheme/ChangeLog,v 1.15 2008/06/27 13:25:11 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-chtheme/ChangeLog,v 1.16 2008/06/27 17:04:19 gentoofan23 Exp $
+
+ 27 Jun 2008; Thomas Anderson <gentoofan23@gentoo.org>
+ +files/gtk-chtheme-0.3.1-implicit.patch, gtk-chtheme-0.3.1-r1.ebuild:
+ Fix implicit declarations of gtk functions.
27 Jun 2008; Brent Baude <ranger@gentoo.org> gtk-chtheme-0.3.1-r1.ebuild:
stable ppc64, bug 215121
diff --git a/x11-themes/gtk-chtheme/files/gtk-chtheme-0.3.1-implicit.patch b/x11-themes/gtk-chtheme/files/gtk-chtheme-0.3.1-implicit.patch
new file mode 100644
index 000000000000..7d9f18cc6b55
--- /dev/null
+++ b/x11-themes/gtk-chtheme/files/gtk-chtheme-0.3.1-implicit.patch
@@ -0,0 +1,12 @@
+diff -aur gtk-chtheme-0.3.1-orig/Makefile gtk-chtheme-0.3.1/Makefile
+--- gtk-chtheme-0.3.1-orig/Makefile 2004-02-09 12:08:41.000000000 -0500
++++ gtk-chtheme-0.3.1/Makefile 2008-06-27 12:19:02.000000000 -0400
+@@ -4,7 +4,7 @@
+
+ LDFLAGS = $(shell pkg-config --libs gtk+-2.0)
+ CFLAGS += -Wall
+-CFLAGS += $(shell pkg-config --cflags gtk+-2.0) -DGTK_DISABLE_BROKEN -DGTK_DISABLE_DEPRECATED
++CFLAGS += $(shell pkg-config --cflags gtk+-2.0) -DGTK_DISABLE_BROKEN
+ CFLAGS += -DPROJNAME='"$(PROJNAME)"' -DVERSION='"$(VERSION)"'
+ CPPFLAGS =
+ CXXFLAGS =
diff --git a/x11-themes/gtk-chtheme/gtk-chtheme-0.3.1-r1.ebuild b/x11-themes/gtk-chtheme/gtk-chtheme-0.3.1-r1.ebuild
index 9d6b056f30d0..acda5d7ed496 100644
--- a/x11-themes/gtk-chtheme/gtk-chtheme-0.3.1-r1.ebuild
+++ b/x11-themes/gtk-chtheme/gtk-chtheme-0.3.1-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-chtheme/gtk-chtheme-0.3.1-r1.ebuild,v 1.4 2008/06/27 13:25:11 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-chtheme/gtk-chtheme-0.3.1-r1.ebuild,v 1.5 2008/06/27 17:04:19 gentoofan23 Exp $
-inherit toolchain-funcs
+inherit eutils toolchain-funcs
DESCRIPTION="GTK-2.0 Theme Switcher"
HOMEPAGE="http://plasmasturm.org/programs/gtk-chtheme/"
@@ -19,9 +19,11 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack ${A}
+ cd "${S}"
# QA: stop Makefile from stripping the binaries
sed -i -e "s:strip:true:" "${S}"/Makefile || die "sed failed."
+ epatch "${FILESDIR}"/${P}-implicit.patch
}
src_compile() {