summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRomain Perier <mrpouet@gentoo.org>2009-09-23 09:23:10 +0000
committerRomain Perier <mrpouet@gentoo.org>2009-09-23 09:23:10 +0000
commit85e5f41b6c7033f0ba21dd1d1b068dcdfb3f1978 (patch)
tree70b92d8ff3b650edaa8b93c5846694b640ba35a8 /x11-themes
parentRemoved gemhun, kyra, and licq-osd from tree. (diff)
downloadgentoo-2-85e5f41b6c7033f0ba21dd1d1b068dcdfb3f1978.tar.gz
gentoo-2-85e5f41b6c7033f0ba21dd1d1b068dcdfb3f1978.tar.bz2
gentoo-2-85e5f41b6c7033f0ba21dd1d1b068dcdfb3f1978.zip
Version bump per bug #285944, includes natively the system-lua patch, translations updates, import patch from upstream bug #594014 in order to fix a typo for system lua check (AM_CONDITIONNAL)
(Portage version: 2.2_rc41/cvs/Linux x86_64)
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/gtk-engines/ChangeLog11
-rw-r--r--x11-themes/gtk-engines/files/gtk-engines-2.18.3-fix-system-lua-check.patch21
-rw-r--r--x11-themes/gtk-engines/gtk-engines-2.18.3.ebuild37
3 files changed, 68 insertions, 1 deletions
diff --git a/x11-themes/gtk-engines/ChangeLog b/x11-themes/gtk-engines/ChangeLog
index 7e5e4cc8da56..b94712da6d29 100644
--- a/x11-themes/gtk-engines/ChangeLog
+++ b/x11-themes/gtk-engines/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for x11-themes/gtk-engines
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines/ChangeLog,v 1.147 2009/09/03 10:46:19 mrpouet Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines/ChangeLog,v 1.148 2009/09/23 09:23:09 mrpouet Exp $
+
+*gtk-engines-2.18.3 (23 Sep 2009)
+
+ 23 Sep 2009; Romain Perier <mrpouet@gentoo.org>
+ +gtk-engines-2.18.3.ebuild,
+ +files/gtk-engines-2.18.3-fix-system-lua-check.patch:
+ Version bump per bug #285944, includes natively the system-lua patch,
+ translations updates, import patch from upstream bug #594014 in order to
+ fix a typo for system lua check (AM_CONDITIONNAL).
03 Sep 2009; Romain Perier <mrpouet@gentoo.org>
gtk-engines-2.18.2-r1.ebuild, files/gtk-engines-2.18.2-system-lua.patch:
diff --git a/x11-themes/gtk-engines/files/gtk-engines-2.18.3-fix-system-lua-check.patch b/x11-themes/gtk-engines/files/gtk-engines-2.18.3-fix-system-lua-check.patch
new file mode 100644
index 000000000000..b6413f7ee249
--- /dev/null
+++ b/x11-themes/gtk-engines/files/gtk-engines-2.18.3-fix-system-lua-check.patch
@@ -0,0 +1,21 @@
+From 5a5eb6dd706179da9294e939ede807170b99c1a5 Mon Sep 17 00:00:00 2001
+From: Benjamin Berg <benjamin@sipsolutions.net>
+Date: Tue, 22 Sep 2009 09:43:28 +0000
+Subject: Correct the SYSTEM_LUA conditional check. (patch from bug #594014)
+
+---
+diff --git a/configure.ac b/configure.ac
+index 06f388c..9061044 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -47,7 +47,7 @@ AC_ARG_ENABLE(deprecated, [ --disable-deprecated disable deprecated function
+ AC_ARG_ENABLE(schemas, [ --disable-schema disable engine schemas], [schemas=$enableval], [schemas="yes"])
+ AC_ARG_WITH(system-lua, [ --with-system-lua link with system Lua library], [system_lua=$withval], [system_lua="no"])
+
+-AM_CONDITIONAL([SYSTEM_LUA], [test x$system_lua = xtrue])
++AM_CONDITIONAL([SYSTEM_LUA], [test x$system_lua = xyes])
+
+ BUILD_ENGINES=""
+ BUILD_THEMES=""
+--
+cgit v0.8.2
diff --git a/x11-themes/gtk-engines/gtk-engines-2.18.3.ebuild b/x11-themes/gtk-engines/gtk-engines-2.18.3.ebuild
new file mode 100644
index 000000000000..e73cacb4776e
--- /dev/null
+++ b/x11-themes/gtk-engines/gtk-engines-2.18.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines/gtk-engines-2.18.3.ebuild,v 1.1 2009/09/23 09:23:09 mrpouet Exp $
+
+EAPI="2"
+GCONF_DEBUG="no"
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="GTK+2 standard engines and themes"
+HOMEPAGE="http://www.gtk.org/"
+
+LICENSE="LGPL-2.1"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="accessibility lua"
+
+RDEPEND=">=x11-libs/gtk+-2.12
+ lua? ( dev-lang/lua )"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.31
+ >=dev-util/pkgconfig-0.9"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+pkg_setup() {
+ G2CONF="${G2CONF} --enable-animation $(use_enable lua) $(use_with lua system-lua)"
+ use accessibility || G2CONF="${G2CONF} --disable-hc"
+}
+src_prepare() {
+ gnome2_src_prepare
+ # Fix typo in AM_CONDITIONNAL for system lua feature,
+ # upstream bug #594014.
+ epatch "${FILESDIR}"/${P}-fix-system-lua-check.patch
+ intltoolize --automake --copy --force || die "intltoolize failed"
+ eautoreconf
+}