summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLukasz Strzygowski <lucass@gentoo.org>2008-02-19 19:55:43 +0000
committerLukasz Strzygowski <lucass@gentoo.org>2008-02-19 19:55:43 +0000
commit4f56c945c7e7abe47e33ddac0bfbec78b656a21e (patch)
treef8d1ae47687f8515eac3d2e306cc119351a91f3b /x11-themes
parentStable on amd64, bug #210396 (diff)
downloadgentoo-2-4f56c945c7e7abe47e33ddac0bfbec78b656a21e.tar.gz
gentoo-2-4f56c945c7e7abe47e33ddac0bfbec78b656a21e.tar.bz2
gentoo-2-4f56c945c7e7abe47e33ddac0bfbec78b656a21e.zip
Added patch to fix names of env vars (bug #210580). Minor cleanup.
(Portage version: 2.1.4.4)
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/fvwm-crystal/ChangeLog10
-rw-r--r--x11-themes/fvwm-crystal/fvwm-crystal-3.0.4.ebuild8
-rw-r--r--x11-themes/fvwm-crystal/fvwm-crystal-3.0.5-r1.ebuild57
-rw-r--r--x11-themes/fvwm-crystal/fvwm-crystal-3.0.5.ebuild4
4 files changed, 71 insertions, 8 deletions
diff --git a/x11-themes/fvwm-crystal/ChangeLog b/x11-themes/fvwm-crystal/ChangeLog
index a56d593f6bbc..ca3db9601f45 100644
--- a/x11-themes/fvwm-crystal/ChangeLog
+++ b/x11-themes/fvwm-crystal/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-themes/fvwm-crystal
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/fvwm-crystal/ChangeLog,v 1.48 2007/06/09 20:11:01 lucass Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/fvwm-crystal/ChangeLog,v 1.49 2008/02/19 19:55:43 lucass Exp $
+
+*fvwm-crystal-3.0.5-r1 (19 Feb 2008)
+
+ 19 Feb 2008; Lukasz Strzygowski <lucass@gentoo.org>
+ +fvwm-crystal-3.0.5-r1.ebuild:
+ Added patch to fix names of env vars (bug #210580). Minor cleanup.
09 Jun 2007; Lukasz Strzygowski <lucass@gentoo.org>
fvwm-crystal-3.0.5.ebuild:
diff --git a/x11-themes/fvwm-crystal/fvwm-crystal-3.0.4.ebuild b/x11-themes/fvwm-crystal/fvwm-crystal-3.0.4.ebuild
index ae301fb28147..d9c3a5b63a8c 100644
--- a/x11-themes/fvwm-crystal/fvwm-crystal-3.0.4.ebuild
+++ b/x11-themes/fvwm-crystal/fvwm-crystal-3.0.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/fvwm-crystal/fvwm-crystal-3.0.4.ebuild,v 1.7 2007/03/04 08:58:05 lucass Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/fvwm-crystal/fvwm-crystal-3.0.4.ebuild,v 1.8 2008/02/19 19:55:43 lucass Exp $
DESCRIPTION="Configurable and full featured theme for FVWM, with lots of transparency."
HOMEPAGE="http://fvwm-crystal.org/"
@@ -21,11 +21,11 @@ src_compile() {
src_install() {
einstall || die "einstall failed"
- dodoc AUTHORS COPYING README INSTALL NEWS ChangeLog doc/*
- cp -r addons ${D}/usr/share/doc/${PF}/
+ dodoc AUTHORS README INSTALL NEWS ChangeLog doc/*
+ cp -r addons "${D}/usr/share/doc/${PF}/"
exeinto /etc/X11/Sessions
- doexe ${FILESDIR}/fvwm-crystal
+ doexe "${FILESDIR}/fvwm-crystal"
insinto /usr/share/xsessions
doins addons/fvwm-crystal.desktop
diff --git a/x11-themes/fvwm-crystal/fvwm-crystal-3.0.5-r1.ebuild b/x11-themes/fvwm-crystal/fvwm-crystal-3.0.5-r1.ebuild
new file mode 100644
index 000000000000..eac6a8f527ca
--- /dev/null
+++ b/x11-themes/fvwm-crystal/fvwm-crystal-3.0.5-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/fvwm-crystal/fvwm-crystal-3.0.5-r1.ebuild,v 1.1 2008/02/19 19:55:43 lucass Exp $
+
+inherit eutils
+
+DESCRIPTION="Configurable and full featured theme for FVWM, with lots of transparency."
+HOMEPAGE="http://fvwm-crystal.org/"
+SRC_URI="http://download.gna.org/${PN}/${PV}/${P}.tar.gz
+ mirror://gentoo/${P}-envfix.patch.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+RDEPEND=">=x11-wm/fvwm-2.5.13
+ media-gfx/imagemagick
+ || ( x11-misc/stalonetray x11-misc/trayer )
+ || ( x11-misc/habak x11-misc/hsetroot )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${WORKDIR}/${P}-envfix.patch"
+}
+
+src_compile() {
+ einfo "There is nothing to compile."
+}
+
+src_install() {
+ einstall || die "einstall failed"
+
+ dodoc AUTHORS README INSTALL NEWS ChangeLog doc/*
+
+ insinto /usr/share/doc/${PF}
+ doins -r addons
+
+ exeinto /etc/X11/Sessions
+ doexe "${FILESDIR}"/fvwm-crystal
+
+ insinto /usr/share/xsessions
+ doins addons/fvwm-crystal.desktop
+}
+
+pkg_postinst() {
+ elog
+ elog "After installation, execute following commands:"
+ elog " $ cp -r /usr/share/doc/${PF}/addons/Xresources ~/.Xresources"
+ elog " $ cp -r /usr/share/doc/${PF}/addons/Xsession ~/.xinitrc"
+ elog
+ elog "Many applications can extend functionality of fvwm-crystal."
+ elog "They are listed in /usr/share/doc/${PF}/INSTALL.gz."
+ elog
+ ewarn "In this release, all hyphens (-) in names of env variables"
+ ewarn "used by FVWM-Crystal have been replaced by underscores (_)."
+ ewarn "You may need to update your configuration."
+}
diff --git a/x11-themes/fvwm-crystal/fvwm-crystal-3.0.5.ebuild b/x11-themes/fvwm-crystal/fvwm-crystal-3.0.5.ebuild
index 7e4d63e8b97f..0bb1ba9d39e1 100644
--- a/x11-themes/fvwm-crystal/fvwm-crystal-3.0.5.ebuild
+++ b/x11-themes/fvwm-crystal/fvwm-crystal-3.0.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/fvwm-crystal/fvwm-crystal-3.0.5.ebuild,v 1.2 2007/06/09 20:11:01 lucass Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/fvwm-crystal/fvwm-crystal-3.0.5.ebuild,v 1.3 2008/02/19 19:55:43 lucass Exp $
DESCRIPTION="Configurable and full featured theme for FVWM, with lots of transparency."
HOMEPAGE="http://fvwm-crystal.org/"
@@ -21,7 +21,7 @@ src_compile() {
src_install() {
einstall || die "einstall failed"
- dodoc AUTHORS COPYING README INSTALL NEWS ChangeLog doc/*
+ dodoc AUTHORS README INSTALL NEWS ChangeLog doc/*
insinto /usr/share/doc/${PF}
doins -r addons