summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-09-19 20:27:09 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-09-19 20:27:09 +0000
commit32227dde8b80bbb3026fc71488c09e3395dc165c (patch)
treeb5725bf00f801bd86d2658a6e3c20c027bd015de /x11-themes
parentPrevent sandbox violation with USE="opencl" wrt #472766 by Jason Lamb (diff)
downloadgentoo-2-32227dde8b80bbb3026fc71488c09e3395dc165c.tar.gz
gentoo-2-32227dde8b80bbb3026fc71488c09e3395dc165c.tar.bz2
gentoo-2-32227dde8b80bbb3026fc71488c09e3395dc165c.zip
Prevent sandbox violation with media-gfx/imagemagick and USE="opencl" wrt #485422 by "darkbasic"
(Portage version: 2.2.6/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/tango-icon-theme/ChangeLog10
-rw-r--r--x11-themes/tango-icon-theme/tango-icon-theme-0.8.90.ebuild12
2 files changed, 17 insertions, 5 deletions
diff --git a/x11-themes/tango-icon-theme/ChangeLog b/x11-themes/tango-icon-theme/ChangeLog
index cb34df9233a5..54ddaf5c9c2a 100644
--- a/x11-themes/tango-icon-theme/ChangeLog
+++ b/x11-themes/tango-icon-theme/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-themes/tango-icon-theme
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/tango-icon-theme/ChangeLog,v 1.57 2012/05/05 04:10:07 jdhore Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/tango-icon-theme/ChangeLog,v 1.58 2013/09/19 20:27:09 ssuominen Exp $
+
+ 19 Sep 2013; Samuli Suominen <ssuominen@gentoo.org>
+ tango-icon-theme-0.8.90.ebuild:
+ Prevent sandbox violation with media-gfx/imagemagick and USE="opencl" wrt
+ #485422 by "darkbasic"
05 May 2012; Jeff Horelick <jdhore@gentoo.org>
tango-icon-theme-0.8.90.ebuild:
@@ -242,4 +247,3 @@
+tango-icon-theme-0.6.3.ebuild:
New Package provided by Norman Jonas <bugs.gentoo.org@devport.codepilot.net>
closing bug #109137.
-
diff --git a/x11-themes/tango-icon-theme/tango-icon-theme-0.8.90.ebuild b/x11-themes/tango-icon-theme/tango-icon-theme-0.8.90.ebuild
index 2fc32fde06be..19a16aaeb69e 100644
--- a/x11-themes/tango-icon-theme/tango-icon-theme-0.8.90.ebuild
+++ b/x11-themes/tango-icon-theme/tango-icon-theme-0.8.90.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/tango-icon-theme/tango-icon-theme-0.8.90.ebuild,v 1.15 2012/05/05 04:10:07 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/tango-icon-theme/tango-icon-theme-0.8.90.ebuild,v 1.16 2013/09/19 20:27:09 ssuominen Exp $
EAPI=4
inherit gnome2-utils
@@ -29,6 +29,14 @@ DOCS="AUTHORS ChangeLog README"
src_prepare() {
sed -i -e '/svgconvert_prog/s:rsvg:&-convert:' configure || die #413183
+
+ # http://bugs.gentoo.org/472766
+ shopt -s nullglob
+ cards=$(echo -n /dev/dri/card* | sed 's/ /:/g')
+ if test -n "${cards}"; then
+ addpredict "${cards}"
+ fi
+ shopt -u nullglob
}
src_configure() {