summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-03-09 22:23:10 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-03-09 22:23:10 +0000
commitdc302d31687eb9fed3c337cee1eb1a4778c6b9b4 (patch)
tree35e071b41fee106276ebd2597539bdfc4f87010e /x11-themes/leonidas-backgrounds/leonidas-backgrounds-11.0.0.2.ebuild
parentInitial import of backgrounds ebuilds. (diff)
downloadgentoo-2-dc302d31687eb9fed3c337cee1eb1a4778c6b9b4.tar.gz
gentoo-2-dc302d31687eb9fed3c337cee1eb1a4778c6b9b4.tar.bz2
gentoo-2-dc302d31687eb9fed3c337cee1eb1a4778c6b9b4.zip
Initial import of backgrounds ebuilds.
(Portage version: 2.2.0_alpha26/cvs/Linux x86_64)
Diffstat (limited to 'x11-themes/leonidas-backgrounds/leonidas-backgrounds-11.0.0.2.ebuild')
-rw-r--r--x11-themes/leonidas-backgrounds/leonidas-backgrounds-11.0.0.2.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/x11-themes/leonidas-backgrounds/leonidas-backgrounds-11.0.0.2.ebuild b/x11-themes/leonidas-backgrounds/leonidas-backgrounds-11.0.0.2.ebuild
new file mode 100644
index 000000000000..cfd3580480aa
--- /dev/null
+++ b/x11-themes/leonidas-backgrounds/leonidas-backgrounds-11.0.0.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/leonidas-backgrounds/leonidas-backgrounds-11.0.0.2.ebuild,v 1.1 2011/03/09 22:23:10 flameeyes Exp $
+
+EAPI=3
+
+inherit versionator rpm
+
+SRC_PATH=development/15/source/SRPMS
+FEDORA=12
+
+MY_P="${PN}-$(get_version_component_range 1-3)"
+
+DESCRIPTION="Fedora official background artwork"
+HOMEPAGE="https://fedoraproject.org/wiki/F11_Artwork"
+
+SRC_URI="mirror://fedora-dev/${SRC_PATH}/${PN}-$(replace_version_separator 3 -).fc${FEDORA}.src.rpm"
+
+LICENSE="CCPL-Attribution-ShareAlike-2.0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="!x11-themes/fedora-backgrounds:11"
+DEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+SLOT="0"
+
+src_unpack() {
+ rpm_src_unpack
+
+ # as of 2010-06-21 rpm.eclass does not unpack the further lzma
+ # file automatically.
+ unpack ./${MY_P}.tar.lzma
+}
+
+src_compile() { :; }
+src_test() { :; }
+
+src_install() {
+ # This old version doesn't have a makefile to perform install.
+ dodoc Credits || die
+
+ insinto /usr/share/backgrounds/leonidas
+ doins -r leonidas* landscape lion || die
+
+ insinto /usr/share/gnome-background-properties
+ doins desktop-*.xml || die
+}