summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-04-28 13:54:39 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-04-28 13:54:39 +0000
commit3f1b36f1a6e811a088f877b3fc06fd5f33eaebe9 (patch)
treeb1473686c4d28b595970757ea42afd196dfdccf5 /x11-themes/gtk-engines-xfce
parentdo not die in pkg_setup for build related matters (diff)
downloadgentoo-2-3f1b36f1a6e811a088f877b3fc06fd5f33eaebe9.tar.gz
gentoo-2-3f1b36f1a6e811a088f877b3fc06fd5f33eaebe9.tar.bz2
gentoo-2-3f1b36f1a6e811a088f877b3fc06fd5f33eaebe9.zip
Version bump.
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'x11-themes/gtk-engines-xfce')
-rw-r--r--x11-themes/gtk-engines-xfce/ChangeLog9
-rw-r--r--x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.0.0-r200.ebuild32
-rw-r--r--x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.0.0-r300.ebuild32
3 files changed, 72 insertions, 1 deletions
diff --git a/x11-themes/gtk-engines-xfce/ChangeLog b/x11-themes/gtk-engines-xfce/ChangeLog
index 72b6fd1924dc..7c57f711e40b 100644
--- a/x11-themes/gtk-engines-xfce/ChangeLog
+++ b/x11-themes/gtk-engines-xfce/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-themes/gtk-engines-xfce
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-xfce/ChangeLog,v 1.141 2012/04/14 09:01:09 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-xfce/ChangeLog,v 1.142 2012/04/28 13:54:39 ssuominen Exp $
+
+*gtk-engines-xfce-3.0.0-r300 (28 Apr 2012)
+*gtk-engines-xfce-3.0.0-r200 (28 Apr 2012)
+
+ 28 Apr 2012; Samuli Suominen <ssuominen@gentoo.org>
+ +gtk-engines-xfce-3.0.0-r200.ebuild, +gtk-engines-xfce-3.0.0-r300.ebuild:
+ Version bump. This version is compatible with x11-libs/gtk+ >= 3.2.
14 Apr 2012; Samuli Suominen <ssuominen@gentoo.org>
-gtk-engines-xfce-2.99.1-r200.ebuild, -gtk-engines-xfce-2.99.1-r300.ebuild,
diff --git a/x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.0.0-r200.ebuild b/x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.0.0-r200.ebuild
new file mode 100644
index 000000000000..3ad9f2899bbe
--- /dev/null
+++ b/x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.0.0-r200.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.0.0-r200.ebuild,v 1.1 2012/04/28 13:54:39 ssuominen Exp $
+
+EAPI=4
+MY_PN=gtk-xfce-engine
+inherit xfconf
+
+DESCRIPTION="A port of Xfce engine to GTK+-2.x"
+HOMEPAGE="http://www.xfce.org/projects/"
+SRC_URI="mirror://xfce/src/xfce/${MY_PN}/${PV%.*}/${MY_PN}-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug"
+
+RDEPEND=">=dev-libs/glib-2.24
+ >=x11-libs/gtk+-2.20:2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+pkg_setup() {
+ XFCONF=(
+ --disable-gtk3
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README )
+}
diff --git a/x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.0.0-r300.ebuild b/x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.0.0-r300.ebuild
new file mode 100644
index 000000000000..7911563f5492
--- /dev/null
+++ b/x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.0.0-r300.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.0.0-r300.ebuild,v 1.1 2012/04/28 13:54:39 ssuominen Exp $
+
+EAPI=4
+MY_PN=gtk-xfce-engine
+inherit xfconf
+
+DESCRIPTION="A port of Xfce engine to GTK+-3.x"
+HOMEPAGE="http://www.xfce.org/projects/"
+SRC_URI="mirror://xfce/src/xfce/${MY_PN}/${PV%.*}/${MY_PN}-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug"
+
+RDEPEND=">=dev-libs/glib-2.24
+ >=x11-libs/gtk+-3.2:3"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+pkg_setup() {
+ XFCONF=(
+ --disable-gtk2
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README )
+}