summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2008-02-29 23:00:47 +0000
committerBen de Groot <yngwin@gentoo.org>2008-02-29 23:00:47 +0000
commit108b820153faef8e40975ff4618ad4b464fe3e4b (patch)
treebbbd1be025423ab6504242239953e239173ed215 /x11-themes/gtk-engines-qtcurve
parentAnother x11-themes/*qtcurve* version bump (diff)
downloadgentoo-2-108b820153faef8e40975ff4618ad4b464fe3e4b.tar.gz
gentoo-2-108b820153faef8e40975ff4618ad4b464fe3e4b.tar.bz2
gentoo-2-108b820153faef8e40975ff4618ad4b464fe3e4b.zip
Another x11-themes/*qtcurve* version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'x11-themes/gtk-engines-qtcurve')
-rw-r--r--x11-themes/gtk-engines-qtcurve/ChangeLog11
-rw-r--r--x11-themes/gtk-engines-qtcurve/files/build.patch11
-rw-r--r--x11-themes/gtk-engines-qtcurve/gtk-engines-qtcurve-0.56.2.ebuild36
3 files changed, 57 insertions, 1 deletions
diff --git a/x11-themes/gtk-engines-qtcurve/ChangeLog b/x11-themes/gtk-engines-qtcurve/ChangeLog
index cf50bb2ed282..a670f034238d 100644
--- a/x11-themes/gtk-engines-qtcurve/ChangeLog
+++ b/x11-themes/gtk-engines-qtcurve/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for x11-themes/gtk-engines-qtcurve
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-qtcurve/ChangeLog,v 1.11 2008/02/25 23:18:31 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-qtcurve/ChangeLog,v 1.12 2008/02/29 23:00:46 yngwin Exp $
+
+*gtk-engines-qtcurve-0.56.2 (29 Feb 2008)
+
+ 29 Feb 2008; Ben de Groot <yngwin@gentoo.org> +files/build.patch,
+ +gtk-engines-qtcurve-0.56.2.ebuild:
+ And another bugfix release version bump. This one should fix some issues with
+ Firefox 3 betas. From the website: To aid testing with Firefox 3, edit your
+ qtcurvestylerc and add the following line:
+ newFirefox=true
*gtk-engines-qtcurve-0.56.1 (25 Feb 2008)
diff --git a/x11-themes/gtk-engines-qtcurve/files/build.patch b/x11-themes/gtk-engines-qtcurve/files/build.patch
new file mode 100644
index 000000000000..62b0e55cfc84
--- /dev/null
+++ b/x11-themes/gtk-engines-qtcurve/files/build.patch
@@ -0,0 +1,11 @@
+--- style/qt_settings.c.orig 2008-02-29 23:31:03.000000000 +0100
++++ style/qt_settings.c 2008-02-29 23:31:39.000000000 +0100
+@@ -1381,7 +1381,7 @@
+ processMozillaApp(!opts->gtkButtonOrder, add_menu_colors, "firefox", TRUE);
+ else if(thunderbird)
+ processMozillaApp(!opts->gtkButtonOrder, add_menu_colors, "thunderbird", FALSE);
+- else if(mozThunderbird
++ else if(mozThunderbird)
+ processMozillaApp(!opts->gtkButtonOrder, add_menu_colors, "mozilla-thunderbird", FALSE);
+ #endif
+ qtSettings.app= (firefox && opts->newFirefox) ||
diff --git a/x11-themes/gtk-engines-qtcurve/gtk-engines-qtcurve-0.56.2.ebuild b/x11-themes/gtk-engines-qtcurve/gtk-engines-qtcurve-0.56.2.ebuild
new file mode 100644
index 000000000000..4f9fab849419
--- /dev/null
+++ b/x11-themes/gtk-engines-qtcurve/gtk-engines-qtcurve-0.56.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-qtcurve/gtk-engines-qtcurve-0.56.2.ebuild,v 1.1 2008/02/29 23:00:46 yngwin Exp $
+
+inherit eutils cmake-utils
+
+MY_P=${P/gtk-engines-qtcurve/QtCurve-Gtk2}
+
+DESCRIPTION="A set of widget styles for GTK2 based apps, also available for KDE3 and Qt4"
+HOMEPAGE="http://www.kde-look.org/content/show.php?content=40492"
+SRC_URI="http://home.freeuk.com/cpdrummond/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="mozilla"
+
+RDEPEND=">=x11-libs/gtk+-2
+ x11-libs/cairo"
+DEPEND="${RDEPEND}
+ >=dev-util/cmake-2.4"
+
+S=${WORKDIR}/${MY_P}
+DOCS="ChangeLog README TODO"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/build.patch
+}
+
+src_compile() {
+ local mycmakeargs="-DQTC_ADD_EVENT_FILTER=true"
+ use mozilla && mycmakeargs="-DQTC_MODIFY_MOZILLA=true -DQTC_MODIFY_MOZILLA_USER_JS=true"
+ cmake-utils_src_compile
+}