summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Legler <a3li@gentoo.org>2009-08-16 11:45:49 +0000
committerAlex Legler <a3li@gentoo.org>2009-08-16 11:45:49 +0000
commit159510e379989ee7c10eb529a83564edc289a286 (patch)
tree57675ddec713b35fb9191c16980b6ac93cd8f756 /x11-themes/gtk-engines-nodoka/gtk-engines-nodoka-0.7.2.ebuild
parentold (diff)
downloadgentoo-2-159510e379989ee7c10eb529a83564edc289a286.tar.gz
gentoo-2-159510e379989ee7c10eb529a83564edc289a286.tar.bz2
gentoo-2-159510e379989ee7c10eb529a83564edc289a286.zip
Initial commit. Thanks to Dan Murphy <dc.murphy@utoronto.ca> and John G. <giageo@gmail.com> for their ebuilds in bug 260572.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'x11-themes/gtk-engines-nodoka/gtk-engines-nodoka-0.7.2.ebuild')
-rw-r--r--x11-themes/gtk-engines-nodoka/gtk-engines-nodoka-0.7.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-themes/gtk-engines-nodoka/gtk-engines-nodoka-0.7.2.ebuild b/x11-themes/gtk-engines-nodoka/gtk-engines-nodoka-0.7.2.ebuild
new file mode 100644
index 000000000000..f97ee8248adc
--- /dev/null
+++ b/x11-themes/gtk-engines-nodoka/gtk-engines-nodoka-0.7.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-nodoka/gtk-engines-nodoka-0.7.2.ebuild,v 1.1 2009/08/16 11:45:49 a3li Exp $
+
+MY_P="gtk-nodoka-engine-${PV}"
+
+DESCRIPTION="GTK+ engine and themes developed by the Fedora Project"
+HOMEPAGE="https://fedorahosted.org/nodoka/"
+SRC_URI="https://fedorahosted.org/releases/n/o/nodoka/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="animation-rtl"
+
+RDEPEND=">=x11-libs/gtk+-2.8.0"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ econf \
+ --disable-dependency-tracking \
+ --enable-animation \
+ $(use_enable animation-rtl animationtoleft)
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc AUTHORS CREDITS ChangeLog NEWS README TODO || die "dodoc failed"
+}