summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-01-23 17:38:56 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-01-23 17:38:56 +0000
commitab18e0526c5dba6a5d607d92a9dde79bb7935ccc (patch)
treeb05b2205a7813800c3f10400a028051b095411f7 /x11-themes/fvwm-crystal
parentx86 stable per bug 386121 (diff)
downloadgentoo-2-ab18e0526c5dba6a5d607d92a9dde79bb7935ccc.tar.gz
gentoo-2-ab18e0526c5dba6a5d607d92a9dde79bb7935ccc.tar.bz2
gentoo-2-ab18e0526c5dba6a5d607d92a9dde79bb7935ccc.zip
Fix bad initialization of generate-menu wrt #345985. Use "emake install" with DESTDIR instead of "einstall".
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'x11-themes/fvwm-crystal')
-rw-r--r--x11-themes/fvwm-crystal/ChangeLog9
-rw-r--r--x11-themes/fvwm-crystal/files/fvwm-crystal-build.patch46
-rw-r--r--x11-themes/fvwm-crystal/fvwm-crystal-3.0.6-r2.ebuild64
3 files changed, 118 insertions, 1 deletions
diff --git a/x11-themes/fvwm-crystal/ChangeLog b/x11-themes/fvwm-crystal/ChangeLog
index e36d9471e333..19433926e898 100644
--- a/x11-themes/fvwm-crystal/ChangeLog
+++ b/x11-themes/fvwm-crystal/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-themes/fvwm-crystal
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/fvwm-crystal/ChangeLog,v 1.66 2012/01/23 10:14:59 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/fvwm-crystal/ChangeLog,v 1.67 2012/01/23 17:38:56 ssuominen Exp $
+
+*fvwm-crystal-3.0.6-r2 (23 Jan 2012)
+
+ 23 Jan 2012; Samuli Suominen <ssuominen@gentoo.org>
+ +fvwm-crystal-3.0.6-r2.ebuild, +files/fvwm-crystal-build.patch:
+ Fix bad initialization of generate-menu wrt #345985. Use "emake install" with
+ DESTDIR instead of "einstall".
23 Jan 2012; Samuli Suominen <ssuominen@gentoo.org>
fvwm-crystal-3.0.6-r1.ebuild:
diff --git a/x11-themes/fvwm-crystal/files/fvwm-crystal-build.patch b/x11-themes/fvwm-crystal/files/fvwm-crystal-build.patch
new file mode 100644
index 000000000000..60a098afa833
--- /dev/null
+++ b/x11-themes/fvwm-crystal/files/fvwm-crystal-build.patch
@@ -0,0 +1,46 @@
+--- Makefile
++++ Makefile
+@@ -10,15 +10,15 @@
+ all:
+ @echo "There is nothing to compile."
+
+-install: uninstall correctpath
++install: install-doc
+ @echo Installing fvwm-crystal $(RELEASE) to $(prefix)
+- mkdir -p $(prefix)/bin $(prefix)/share/fvwm-crystal/fvwm
++ mkdir -p $(DESTDIR)$(prefix)/bin $(DESTDIR)$(prefix)/share/fvwm-crystal/fvwm
+
+- install -m 755 bin/fvwm-crystal.apps bin/fvwm-crystal.wallpaper bin/fvwm-crystal bin/fvwm-crystal.generate-menu bin/fvwm-crystal.infoline bin/fvwm-crystal.mplayer-wrapper $(prefix)/bin
+- cp -d -r fvwm/* $(prefix)/share/fvwm-crystal/fvwm/
++ install -m 755 bin/fvwm-crystal.apps bin/fvwm-crystal.wallpaper bin/fvwm-crystal bin/fvwm-crystal.generate-menu bin/fvwm-crystal.infoline bin/fvwm-crystal.mplayer-wrapper $(DESTDIR)$(prefix)/bin
++ cp -d -r fvwm/* $(DESTDIR)$(prefix)/share/fvwm-crystal/fvwm/
+
+- mkdir -p $(prefix)/share/man/man1
+- cp -d -r man/* $(prefix)/share/man/man1
++ mkdir -p $(DESTDIR)$(prefix)/share/man/man1
++ cp -d -r man/* $(DESTDIR)$(prefix)/share/man/man1
+
+ uninstall:
+ @echo "Uninstalling previously installed fvwm-crystal"
+@@ -188,17 +188,12 @@
+ tar czf "../fvwm-crystal-minimal-$(RELEASE).tar.gz" "fvwm-crystal-minimal-$(RELEASE)"
+ rm -rf "fvwm-crystal-minimal-$(RELEASE)"
+
+-# It is needed to adjust some path inside fvwm-crystal.generate-menu since this file must know the install path
+-correctpath:
+- sed -i 's:FC_MENUBASEROOT="/usr/share:FC_MENUBASEROOT="$(prefix)/share:' bin/fvwm-crystal.generate-menu
+- sed -i 's:FC_ICONBASEROOT="/usr/share:FC_ICONBASEROOT="$(prefix)/share:' bin/fvwm-crystal.generate-menu
+-
+ uninstall-doc:
+ -rm -rf $(docdir)
+ -rm -rf $(addondir)
+
+ install-doc:
+- mkdir -p $(addondir) $(docdir)
+- install -m 644 addons/* $(addondir)
+- install -m 644 AUTHORS COPYING NEWS ChangeLog README INSTALL $(docdir)
+- install -m 644 doc/* $(docdir)
++ mkdir -p $(DESTDIR)$(addondir) $(DESTDIR)$(docdir)
++ install -m 644 addons/* $(DESTDIR)$(addondir)
++ install -m 644 AUTHORS NEWS ChangeLog README $(DESTDIR)$(docdir)
++ install -m 644 doc/* $(DESTDIR)$(docdir)
diff --git a/x11-themes/fvwm-crystal/fvwm-crystal-3.0.6-r2.ebuild b/x11-themes/fvwm-crystal/fvwm-crystal-3.0.6-r2.ebuild
new file mode 100644
index 000000000000..b1978470b27a
--- /dev/null
+++ b/x11-themes/fvwm-crystal/fvwm-crystal-3.0.6-r2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/fvwm-crystal/fvwm-crystal-3.0.6-r2.ebuild,v 1.1 2012/01/23 17:38:56 ssuominen Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2:2.7"
+
+inherit eutils python
+
+DESCRIPTION="Configurable and full featured theme for FVWM, with lots of transparency"
+HOMEPAGE="http://gna.org/projects/fvwm-crystal/"
+SRC_URI="http://download.gna.org/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="|| ( media-gfx/imagemagick[png] media-gfx/graphicsmagick[imagemagick,png] )
+ x11-apps/xwd
+ || ( x11-misc/habak x11-misc/hsetroot )
+ || ( x11-misc/stalonetray x11-misc/trayer )
+ >=x11-wm/fvwm-2.6.2[png]"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ find . -type d -name '.svn' -prune -exec rm -rf {} ';' || die
+ python_convert_shebangs -r 2 bin fvwm/scripts #317041
+ epatch \
+ "${FILESDIR}"/${PN}.apps.patch \
+ "${FILESDIR}"/${PN}-build.patch
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ addondir="/usr/share/doc/${PF}/addons" \
+ docdir="/usr/share/doc/${PF}" \
+ prefix="/usr" \
+ install
+
+ exeinto /etc/X11/Sessions
+ doexe "${FILESDIR}"/fvwm-crystal
+
+ insinto /usr/share/xsessions
+ doins addons/fvwm-crystal.desktop
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Configuration examples can be found in ${ROOT}usr/share/doc/${PF}/examples/"
+ einfo
+ einfo "Many applications can extend functionality of fvwm-crystal."
+ einfo "They are listed in the INSTALL file in ${ROOT}usr/share/doc/${PF}."
+ einfo
+ ewarn "In this release, all hyphens (-) in names of env variables"
+ ewarn "used by FVWM-Crystal have been replaced by underscores (_)."
+ ewarn "You may need to update your configuration."
+}