summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2009-04-19 19:41:18 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2009-04-19 19:41:18 +0000
commit6a5e86f0c9c6536962b257a0e72f759f4ae2aa16 (patch)
tree445f9d6dfa9dbd3f6db868a2e3de06bf40cf7a02 /x11-themes/crystal/crystal-2.0.3.ebuild
parentSnapshot of 2.6.8_pre, fixes bug #205803, based on the ebuild from the lisp o... (diff)
downloadgentoo-2-6a5e86f0c9c6536962b257a0e72f759f4ae2aa16.tar.gz
gentoo-2-6a5e86f0c9c6536962b257a0e72f759f4ae2aa16.tar.bz2
gentoo-2-6a5e86f0c9c6536962b257a0e72f759f4ae2aa16.zip
Add kde4 version (per bug #266789) and bump kde3 one.
(Portage version: 2.2_rc30/cvs/Linux i686)
Diffstat (limited to 'x11-themes/crystal/crystal-2.0.3.ebuild')
-rw-r--r--x11-themes/crystal/crystal-2.0.3.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/x11-themes/crystal/crystal-2.0.3.ebuild b/x11-themes/crystal/crystal-2.0.3.ebuild
new file mode 100644
index 000000000000..562d94935671
--- /dev/null
+++ b/x11-themes/crystal/crystal-2.0.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/crystal/crystal-2.0.3.ebuild,v 1.1 2009/04/19 19:41:18 scarabeus Exp $
+
+EAPI="2"
+
+inherit kde4-base
+
+DESCRIPTION="Crystal decoration theme for KDE4.x"
+HOMEPAGE="http://kde-look.org/content/show.php/Crystal?content=75140"
+SRC_URI="http://kde-look.org/CONTENT/content-files/75140-${P}.tar.bz2"
+
+IUSE="debug"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+
+src_install() {
+ kde4-base_src_install
+ mv "${D}"/usr/share/apps/kwin/crystal.desktop \
+ "${D}"/usr/share/apps/kwin/crystal-${SLOT}.desktop \
+ || die "moving desktop file failed"
+}