summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-10-31 22:54:25 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-10-31 22:54:25 +0000
commitcf2c26ac66d30c5024abf41082b27e752bdfbf1b (patch)
tree328f4b66fe747a5391ba616de3a05f87e0cfd927 /x11-terms
parentVersion bump. (diff)
downloadgentoo-2-cf2c26ac66d30c5024abf41082b27e752bdfbf1b.tar.gz
gentoo-2-cf2c26ac66d30c5024abf41082b27e752bdfbf1b.tar.bz2
gentoo-2-cf2c26ac66d30c5024abf41082b27e752bdfbf1b.zip
Version bump.
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/xterm/ChangeLog9
-rw-r--r--x11-terms/xterm/xterm-285.ebuild86
2 files changed, 93 insertions, 2 deletions
diff --git a/x11-terms/xterm/ChangeLog b/x11-terms/xterm/ChangeLog
index 9f7563fb5547..4c33d66a6dc3 100644
--- a/x11-terms/xterm/ChangeLog
+++ b/x11-terms/xterm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-terms/xterm
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/xterm/ChangeLog,v 1.364 2012/08/27 09:05:26 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/xterm/ChangeLog,v 1.365 2012/10/31 22:54:25 chithanh Exp $
+
+*xterm-285 (31 Oct 2012)
+
+ 31 Oct 2012; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +xterm-285.ebuild:
+ Version bump.
27 Aug 2012; Samuli Suominen <ssuominen@gentoo.org> -xterm-276.ebuild:
old
@@ -1342,4 +1348,3 @@
merged into xfree's source tree. This package follows xterm's development with
the goal of removing xterm's compilation within the xfree ebuild.
Ideally, this should work with utempter library in the near future.
-
diff --git a/x11-terms/xterm/xterm-285.ebuild b/x11-terms/xterm/xterm-285.ebuild
new file mode 100644
index 000000000000..ea1e5ea75cae
--- /dev/null
+++ b/x11-terms/xterm/xterm-285.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/xterm/xterm-285.ebuild,v 1.1 2012/10/31 22:54:25 chithanh Exp $
+
+EAPI=4
+inherit eutils multilib
+
+DESCRIPTION="Terminal Emulator for X Windows"
+HOMEPAGE="http://dickey.his.com/xterm/"
+SRC_URI="ftp://invisible-island.net/${PN}/${P}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="toolbar truetype unicode Xaw3d"
+
+COMMON_DEPEND="kernel_linux? ( sys-libs/libutempter )
+ kernel_FreeBSD? ( || ( >=sys-freebsd/freebsd-lib-9.0 sys-libs/libutempter ) )
+ >=sys-libs/ncurses-5.7-r7
+ x11-apps/xmessage
+ x11-libs/libX11
+ x11-libs/libXaw
+ x11-libs/libXft
+ x11-libs/libxkbfile
+ x11-libs/libXmu
+ x11-libs/libXrender
+ x11-libs/libXt
+ unicode? ( x11-apps/luit )
+ Xaw3d? ( x11-libs/libXaw3d )"
+RDEPEND="${COMMON_DEPEND}
+ media-fonts/font-misc-misc"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+ x11-proto/kbproto
+ x11-proto/xproto"
+
+pkg_setup() {
+ DEFAULTS_DIR="${EPREFIX}"/usr/share/X11/app-defaults
+}
+
+src_configure() {
+ # looking for reason why crosscompile failed? try restoring this:
+ # --x-libraries="${ROOT}usr/$(get_libdir)"
+ # -ssuominen, 2011
+
+ econf \
+ --libdir="${EPREFIX}"/etc \
+ --disable-full-tgetent \
+ --with-app-defaults=${DEFAULTS_DIR} \
+ --disable-setuid \
+ --disable-setgid \
+ --with-utempter \
+ --with-x \
+ $(use_with Xaw3d) \
+ --disable-imake \
+ --enable-256-color \
+ --enable-broken-osc \
+ --enable-broken-st \
+ --enable-exec-xterm \
+ $(use_enable truetype freetype) \
+ --enable-i18n \
+ --enable-load-vt-fonts \
+ --enable-logging \
+ $(use_enable toolbar) \
+ $(use_enable unicode mini-luit) \
+ $(use_enable unicode luit) \
+ --enable-wide-chars \
+ --enable-dabbrev \
+ --enable-warnings
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc README{,.i18n} ctlseqs.txt
+ dohtml xterm.log.html
+ domenu *.desktop
+
+ # Fix permissions -- it grabs them from live system, and they can
+ # be suid or sgid like they were in pre-unix98 pty or pre-utempter days,
+ # respectively (#69510).
+ # (info from Thomas Dickey) - Donnie Berkholz <spyderous@gentoo.org>
+ fperms 0755 /usr/bin/xterm
+
+ # restore the navy blue
+ sed -i -e "s:blue2$:blue:" "${ED}"${DEFAULTS_DIR}/XTerm-color
+}