summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-07-27 18:47:31 +0000
committerMichał Górny <mgorny@gentoo.org>2015-07-27 18:47:31 +0000
commitc71e7c0109bd1ad10eb22f8ea06dce49cefa886c (patch)
tree01e2e74c91a84f8626d0194c1cd6771e370d11b0 /x11-terms
parentUse fortran-2.eclass, bug #543204; drop old (diff)
downloadgentoo-2-c71e7c0109bd1ad10eb22f8ea06dce49cefa886c.tar.gz
gentoo-2-c71e7c0109bd1ad10eb22f8ea06dce49cefa886c.tar.bz2
gentoo-2-c71e7c0109bd1ad10eb22f8ea06dce49cefa886c.zip
Convert to python-any-r1
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/roxterm/ChangeLog9
-rw-r--r--x11-terms/roxterm/roxterm-2.9.3-r1.ebuild65
2 files changed, 72 insertions, 2 deletions
diff --git a/x11-terms/roxterm/ChangeLog b/x11-terms/roxterm/ChangeLog
index 89ffe7ff75d8..9151f47a11d4 100644
--- a/x11-terms/roxterm/ChangeLog
+++ b/x11-terms/roxterm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-terms/roxterm
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/roxterm/ChangeLog,v 1.73 2014/09/05 10:50:45 jauhien Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/roxterm/ChangeLog,v 1.74 2015/07/27 18:47:31 mgorny Exp $
+
+*roxterm-2.9.3-r1 (27 Jul 2015)
+
+ 27 Jul 2015; Michał Górny <mgorny@gentoo.org> +roxterm-2.9.3-r1.ebuild:
+ Convert to python-any-r1
*roxterm-2.9.3 (05 Sep 2014)
diff --git a/x11-terms/roxterm/roxterm-2.9.3-r1.ebuild b/x11-terms/roxterm/roxterm-2.9.3-r1.ebuild
new file mode 100644
index 000000000000..defc7fb06667
--- /dev/null
+++ b/x11-terms/roxterm/roxterm-2.9.3-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/roxterm/roxterm-2.9.3-r1.ebuild,v 1.1 2015/07/27 18:47:31 mgorny Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+inherit gnome2-utils python-any-r1 toolchain-funcs
+
+DESCRIPTION="A terminal emulator designed to integrate with the ROX environment"
+HOMEPAGE="http://roxterm.sourceforge.net/"
+SRC_URI="mirror://sourceforge/roxterm/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND=">=dev-libs/dbus-glib-0.100
+ >=dev-libs/glib-2.28
+ x11-libs/gtk+:3
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/vte:2.90"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ dev-libs/libxslt
+ dev-python/lockfile
+ virtual/pkgconfig
+ || ( media-gfx/imagemagick media-gfx/graphicsmagick[imagemagick] )
+ nls? ( app-text/po4a sys-devel/gettext )"
+
+src_configure() {
+ local myconf=(
+ CC="$(tc-getCC)"
+ CFLAGS="${CFLAGS}"
+ LDFLAGS="${LDFLAGS}"
+ --prefix=/usr
+ --docdir="/usr/share/doc/${PF}"
+ --destdir="${D}"
+ )
+
+ use nls || myconf+=( --disable-gettext --disable-po4a --disable-translations )
+ ./mscript.py configure "${myconf[@]}"
+}
+
+src_compile() {
+ ./mscript.py build
+}
+
+src_install() {
+ ./mscript.py install
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}