summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-06-26 17:30:06 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-06-26 17:30:06 +0000
commit8d5bc577d60c6af15a8150c38d9c37237450bd22 (patch)
treed46b6ce59b5b03a8e5a0b671a1374e021abb42eb /x11-terms
parentAdd Richard Jones as upstream in metadata.xml (diff)
downloadgentoo-2-8d5bc577d60c6af15a8150c38d9c37237450bd22.tar.gz
gentoo-2-8d5bc577d60c6af15a8150c38d9c37237450bd22.tar.bz2
gentoo-2-8d5bc577d60c6af15a8150c38d9c37237450bd22.zip
Version bump.
(Portage version: 2.2.0_alpha111/cvs/Linux x86_64)
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/xterm/ChangeLog7
-rw-r--r--x11-terms/xterm/xterm-281.ebuild86
2 files changed, 92 insertions, 1 deletions
diff --git a/x11-terms/xterm/ChangeLog b/x11-terms/xterm/ChangeLog
index c0c625121bfd..796b011b9b44 100644
--- a/x11-terms/xterm/ChangeLog
+++ b/x11-terms/xterm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-terms/xterm
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/xterm/ChangeLog,v 1.357 2012/06/24 19:47:33 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/xterm/ChangeLog,v 1.358 2012/06/26 17:30:06 ssuominen Exp $
+
+*xterm-281 (26 Jun 2012)
+
+ 26 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +xterm-281.ebuild:
+ Version bump.
24 Jun 2012; Agostino Sarubbo <ago@gentoo.org> xterm-279.ebuild:
Stable for x86, wrt bug #419473
diff --git a/x11-terms/xterm/xterm-281.ebuild b/x11-terms/xterm/xterm-281.ebuild
new file mode 100644
index 000000000000..51648a0d643e
--- /dev/null
+++ b/x11-terms/xterm/xterm-281.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/xterm/xterm-281.ebuild,v 1.1 2012/06/26 17:30:06 ssuominen Exp $
+
+EAPI=4
+inherit eutils multilib
+
+DESCRIPTION="Terminal Emulator for X Windows"
+HOMEPAGE="http://dickey.his.com/xterm/"
+SRC_URI="ftp://invisible-island.net/${PN}/${P}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="toolbar truetype unicode Xaw3d"
+
+COMMON_DEPEND="kernel_linux? ( sys-libs/libutempter )
+ kernel_FreeBSD? ( || ( >=sys-freebsd/freebsd-lib-9.0 sys-libs/libutempter ) )
+ >=sys-libs/ncurses-5.7-r7
+ x11-apps/xmessage
+ x11-libs/libX11
+ x11-libs/libXaw
+ x11-libs/libXft
+ x11-libs/libxkbfile
+ x11-libs/libXmu
+ x11-libs/libXrender
+ x11-libs/libXt
+ unicode? ( x11-apps/luit )
+ Xaw3d? ( x11-libs/libXaw3d )"
+RDEPEND="${COMMON_DEPEND}
+ media-fonts/font-misc-misc"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+ x11-proto/kbproto
+ x11-proto/xproto"
+
+pkg_setup() {
+ DEFAULTS_DIR="${EPREFIX}"/usr/share/X11/app-defaults
+}
+
+src_configure() {
+ # looking for reason why crosscompile failed? try restoring this:
+ # --x-libraries="${ROOT}usr/$(get_libdir)"
+ # -ssuominen, 2011
+
+ econf \
+ --libdir="${EPREFIX}"/etc \
+ --disable-full-tgetent \
+ --with-app-defaults=${DEFAULTS_DIR} \
+ --disable-setuid \
+ --disable-setgid \
+ --with-utempter \
+ --with-x \
+ $(use_with Xaw3d) \
+ --disable-imake \
+ --enable-256-color \
+ --enable-broken-osc \
+ --enable-broken-st \
+ --enable-exec-xterm \
+ $(use_enable truetype freetype) \
+ --enable-i18n \
+ --enable-load-vt-fonts \
+ --enable-logging \
+ $(use_enable toolbar) \
+ $(use_enable unicode mini-luit) \
+ $(use_enable unicode luit) \
+ --enable-wide-chars \
+ --enable-dabbrev \
+ --enable-warnings
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc README{,.i18n} ctlseqs.txt
+ dohtml xterm.log.html
+ domenu *.desktop
+
+ # Fix permissions -- it grabs them from live system, and they can
+ # be suid or sgid like they were in pre-unix98 pty or pre-utempter days,
+ # respectively (#69510).
+ # (info from Thomas Dickey) - Donnie Berkholz <spyderous@gentoo.org>
+ fperms 0755 /usr/bin/xterm
+
+ # restore the navy blue
+ sed -i -e "s:blue2$:blue:" "${ED}"${DEFAULTS_DIR}/XTerm-color
+}