summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRené Nussbaumer <killerfox@gentoo.org>2006-07-15 09:28:11 +0000
committerRené Nussbaumer <killerfox@gentoo.org>2006-07-15 09:28:11 +0000
commit7ccc4a6d2520798aabdd5482b842ea37311ee0e8 (patch)
tree7fa05a3fa6900c0d77a92e02bfe3947406c581bf /x11-terms
parentDropping 2.6.16* and 2.6.17*; Version bump (diff)
downloadgentoo-2-7ccc4a6d2520798aabdd5482b842ea37311ee0e8.tar.gz
gentoo-2-7ccc4a6d2520798aabdd5482b842ea37311ee0e8.tar.bz2
gentoo-2-7ccc4a6d2520798aabdd5482b842ea37311ee0e8.zip
Revision bump. Made ISO-14755 support now optional (USE-Flag).
(Portage version: 2.1.1_pre2-r2)
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/rxvt-unicode/ChangeLog8
-rw-r--r--x11-terms/rxvt-unicode/files/digest-rxvt-unicode-7.7-r33
-rw-r--r--x11-terms/rxvt-unicode/rxvt-unicode-7.7-r3.ebuild85
3 files changed, 95 insertions, 1 deletions
diff --git a/x11-terms/rxvt-unicode/ChangeLog b/x11-terms/rxvt-unicode/ChangeLog
index 6558425ccebb..b252c3667058 100644
--- a/x11-terms/rxvt-unicode/ChangeLog
+++ b/x11-terms/rxvt-unicode/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-terms/rxvt-unicode
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt-unicode/ChangeLog,v 1.74 2006/05/30 22:07:01 exg Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt-unicode/ChangeLog,v 1.75 2006/07/15 09:28:11 killerfox Exp $
+
+*rxvt-unicode-7.7-r3 (15 Jul 2006)
+
+ 15 Jul 2006; Rene Nussbaumer <killerfox@gentoo.org>
+ +rxvt-unicode-7.7-r3.ebuild:
+ Revision bump. Made ISO-14755 support now optional (USE-Flag).
30 May 2006; Emanuele Giaquinta <exg@gentoo.org> -rxvt-unicode-3.0.ebuild,
-rxvt-unicode-4.0.ebuild, -rxvt-unicode-5.1.ebuild:
diff --git a/x11-terms/rxvt-unicode/files/digest-rxvt-unicode-7.7-r3 b/x11-terms/rxvt-unicode/files/digest-rxvt-unicode-7.7-r3
new file mode 100644
index 000000000000..6cf357c57ea8
--- /dev/null
+++ b/x11-terms/rxvt-unicode/files/digest-rxvt-unicode-7.7-r3
@@ -0,0 +1,3 @@
+MD5 68298390375da1b34f89a0aa634c9b20 rxvt-unicode-7.7.tar.bz2 876369
+RMD160 6dd55a7a71207e774239ca0c362ae35d2dc88237 rxvt-unicode-7.7.tar.bz2 876369
+SHA256 04ecd2577ee0c210df610b4a5d870f2bda57c80962fb5b51ae9c4a94098c726c rxvt-unicode-7.7.tar.bz2 876369
diff --git a/x11-terms/rxvt-unicode/rxvt-unicode-7.7-r3.ebuild b/x11-terms/rxvt-unicode/rxvt-unicode-7.7-r3.ebuild
new file mode 100644
index 000000000000..ab4b68c0055c
--- /dev/null
+++ b/x11-terms/rxvt-unicode/rxvt-unicode-7.7-r3.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt-unicode/rxvt-unicode-7.7-r3.ebuild,v 1.1 2006/07/15 09:28:11 killerfox Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="rxvt clone with XFT and Unicode support"
+HOMEPAGE="http://software.schmorp.de/"
+SRC_URI="http://dist.schmorp.de/rxvt-unicode/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc-macos ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="truetype perl iso14755"
+
+# see bug #115992 for modular x deps
+RDEPEND="
+ || (
+ (
+ x11-libs/libX11
+ x11-libs/libXft
+ x11-libs/libXpm
+ x11-libs/libXrender
+ )
+ virtual/x11
+ )
+ dev-lang/perl
+ perl? ( sys-devel/libperl )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-devel/libtool
+ || (
+ (
+ x11-proto/xproto
+ x11-libs/libXt
+ )
+ virtual/x11
+ )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ local tdir=/usr/share/terminfo
+ sed -i -e \
+ "s~@TIC@ \(etc/rxvt\)~@TIC@ -o ${D}/${tdir} \1~" \
+ doc/Makefile.in
+ sed -i -e \
+ "s:-g -O3:${CXXFLAGS}:" \
+ configure
+ epatch ${FILESDIR}/scrolling-one-line.patch
+}
+
+src_compile() {
+ myconf=''
+
+ use iso14755 || myconf='--disable-iso14755'
+
+ econf \
+ --enable-everything \
+ $(use_enable truetype xft) \
+ $(use_enable perl) \
+ --disable-text-blink \
+ ${myconf} \
+ || die
+
+ emake || die
+
+ sed -i \
+ -e 's/RXVT_BASENAME = "rxvt"/RXVT_BASENAME = "urxvt"/' \
+ ${S}/doc/rxvt-tabbed || die "tabs sed failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+
+ dodoc README.FAQ Changes
+ cd "${S}"/doc
+ dodoc README* changes.txt etc/* rxvt-tabbed
+}
+
+pkg_postinst() {
+ einfo "urxvt now always uses TERM=rxvt-unicode so that the"
+ einfo "upstream-supplied terminfo files can be used."
+}
+