summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2008-09-30 16:24:04 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2008-09-30 16:24:04 +0000
commit6757bcf4adb03f1c40c9a1f6355a50cbc6aab919 (patch)
tree54cb101ba232a9db78b5fee6e4b41dc4c169b9ec /x11-terms
parentversion bump, thanks pavel (diff)
downloadgentoo-2-6757bcf4adb03f1c40c9a1f6355a50cbc6aab919.tar.gz
gentoo-2-6757bcf4adb03f1c40c9a1f6355a50cbc6aab919.tar.bz2
gentoo-2-6757bcf4adb03f1c40c9a1f6355a50cbc6aab919.zip
Fixed emake issue with USE='-gtk -imlib'. Fixed CC.
(Portage version: 2.2_rc11/cvs/Linux 2.6.26-gentoo-r1 x86_64)
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/mlterm/ChangeLog8
-rw-r--r--x11-terms/mlterm/mlterm-2.9.4-r3.ebuild (renamed from x11-terms/mlterm/mlterm-2.9.4-r1.ebuild)55
2 files changed, 37 insertions, 26 deletions
diff --git a/x11-terms/mlterm/ChangeLog b/x11-terms/mlterm/ChangeLog
index 8c1a58ed8784..ce2e0b61301f 100644
--- a/x11-terms/mlterm/ChangeLog
+++ b/x11-terms/mlterm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-terms/mlterm
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/mlterm/ChangeLog,v 1.63 2008/09/24 13:03:22 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/mlterm/ChangeLog,v 1.64 2008/09/30 16:24:04 matsuu Exp $
+
+*mlterm-2.9.4-r3 (30 Sep 2008)
+
+ 30 Sep 2008; MATSUU Takuto <matsuu@gentoo.org> -mlterm-2.9.4-r1.ebuild,
+ +mlterm-2.9.4-r3.ebuild:
+ Fixed emake issue with USE='-gtk -imlib'. Fixed CC. Removed old version.
*mlterm-2.9.4-r2 (24 Sep 2008)
diff --git a/x11-terms/mlterm/mlterm-2.9.4-r1.ebuild b/x11-terms/mlterm/mlterm-2.9.4-r3.ebuild
index e29ab4fc0fe2..5a75d977d6e0 100644
--- a/x11-terms/mlterm/mlterm-2.9.4-r1.ebuild
+++ b/x11-terms/mlterm/mlterm-2.9.4-r3.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/mlterm/mlterm-2.9.4-r1.ebuild,v 1.2 2008/09/24 13:03:22 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/mlterm/mlterm-2.9.4-r3.ebuild,v 1.1 2008/09/30 16:24:04 matsuu Exp $
-inherit eutils flag-o-matic
+inherit eutils toolchain-funcs
-IUSE="truetype gtk imlib bidi nls uim scim"
-#IUSE="${IUSE} m17n-lib iiimf"
+IUSE="truetype gtk imlib bidi nls uim scim m17n-lib"
+#IUSE="${IUSE} iiimf"
DESCRIPTION="A multi-lingual terminal emulator"
HOMEPAGE="http://mlterm.sourceforge.net/"
@@ -15,19 +15,21 @@ SLOT="0"
KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
LICENSE="BSD"
-RDEPEND="gtk? ( >=x11-libs/gtk+-2 )
- !gtk? ( imlib? ( >=media-libs/imlib-1.9.14 ) )
- truetype? ( =media-libs/freetype-2* )
- bidi? ( >=dev-libs/fribidi-0.10.4 )
- nls? ( sys-devel/gettext )
- uim? ( >=app-i18n/uim-0.3.4.2 )
- scim? ( || ( >=app-i18n/scim-1.4 app-i18n/scim-cvs ) )
- virtual/utempter
+RDEPEND="virtual/utempter
x11-libs/libX11
x11-libs/libICE
- x11-libs/libSM"
-DEPEND="${RDEPEND}"
-# m17n-lib? ( >=dev-libs/m17n-lib-1.2.0 )
+ x11-libs/libSM
+ gtk? ( >=x11-libs/gtk+-2 )
+ !gtk? ( imlib? ( >=media-libs/imlib-1.9.14 ) )
+ truetype? ( x11-libs/libXft )
+ bidi? ( >=dev-libs/fribidi-0.10.4 )
+ nls? ( virtual/libintl )
+ uim? ( >=app-i18n/uim-1.0 )
+ scim? ( >=app-i18n/scim-1.4 )
+ m17n-lib? ( >=dev-libs/m17n-lib-1.2.0 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
src_unpack() {
unpack ${A}
@@ -39,18 +41,21 @@ src_unpack() {
}
src_compile() {
- local myconf imagelib
+ local myconf
if use gtk ; then
- imagelib="gdk-pixbuf"
- elif use imlib ; then
- imagelib="imlib"
+ myconf="${myconf} --with-imagelib=gdk-pixbuf"
+ else
+ if use imlib ; then
+ myconf="${myconf} --with-imagelib=imlib"
+ else
+ myconf="${myconf} --with-imagelib=''"
+ fi
+ myconf="${myconf} --with-tools=mlclient,mlcc"
fi
- use gtk || myconf="${myconf} --with-tools=mlclient,mlcc"
-
- # m17n-lib, and iiimf aren't stable enough
- #myconf="${myconf} $(use_enable iiimf) $(use_enable m17n-lib m17nlib)"
+ # iiimf isn't stable enough
+ #myconf="${myconf} $(use_enable iiimf)"
econf --enable-utmp \
$(use_enable truetype anti-alias) \
@@ -58,9 +63,9 @@ src_compile() {
$(use_enable nls) \
$(use_enable uim) \
$(use_enable scim) \
- --with-imagelib="${imagelib}" \
+ $(use_enable m17n-lib m17nlib) \
${myconf} || die "econf failed"
- emake || die "emake failed"
+ emake CC="$(tc-getCC)" || die "emake failed"
}
src_install () {