summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-01-06 17:20:49 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-01-06 17:20:49 +0000
commit35fce9d365e98510249301c9c5bdbd931f4357ca (patch)
treef9380e54a1e765f584b73bfc6acc6adc09bd35b0 /x11-terms
parentx11-libs/libdrm: remove cruft and change elogs into ewarns (diff)
downloadgentoo-2-35fce9d365e98510249301c9c5bdbd931f4357ca.tar.gz
gentoo-2-35fce9d365e98510249301c9c5bdbd931f4357ca.tar.bz2
gentoo-2-35fce9d365e98510249301c9c5bdbd931f4357ca.zip
Version bump.
(Portage version: 2.1.6.4/cvs/Linux 2.6.28-gentoo i686)
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/evilvte/ChangeLog10
-rw-r--r--x11-terms/evilvte/evilvte-0.4.4_pre9.ebuild48
2 files changed, 56 insertions, 2 deletions
diff --git a/x11-terms/evilvte/ChangeLog b/x11-terms/evilvte/ChangeLog
index dd88c18ffa68..0e928dea5303 100644
--- a/x11-terms/evilvte/ChangeLog
+++ b/x11-terms/evilvte/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-terms/evilvte
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/evilvte/ChangeLog,v 1.7 2008/11/28 12:16:38 ssuominen Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/evilvte/ChangeLog,v 1.8 2009/01/06 17:20:49 ssuominen Exp $
+
+*evilvte-0.4.4_pre9 (06 Jan 2009)
+
+ 06 Jan 2009; Samuli Suominen <ssuominen@gentoo.org>
+ +evilvte-0.4.4_pre9.ebuild:
+ Version bump.
*evilvte-0.4.4_pre8 (28 Nov 2008)
diff --git a/x11-terms/evilvte/evilvte-0.4.4_pre9.ebuild b/x11-terms/evilvte/evilvte-0.4.4_pre9.ebuild
new file mode 100644
index 000000000000..61da1d840eae
--- /dev/null
+++ b/x11-terms/evilvte/evilvte-0.4.4_pre9.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/evilvte/evilvte-0.4.4_pre9.ebuild,v 1.1 2009/01/06 17:20:49 ssuominen Exp $
+
+MY_P=${P/_/\~}
+
+inherit toolchain-funcs
+
+DESCRIPTION="VTE based, super lightweight terminal emulator"
+HOMEPAGE="http://www.calno.com/evilvte"
+SRC_URI="http://www.calno.com/${PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/vte
+ >=x11-libs/gtk+-2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ if [[ -f /etc/${PN}/config.h ]]; then
+ cp /etc/${PN}/config.h src/ || die "copying config.h failed."
+ fi
+}
+
+src_compile() {
+ ./configure --prefix=/usr || die "./configure failed."
+ emake CC="$(tc-getCC)" OPTFLAGS="${CFLAGS}" || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc Changelog
+ insinto /etc/${PN}
+ doins src/config.h || die "doins failed."
+}
+
+pkg_postinst() {
+ elog "Edit /etc/${PN}/config.h and re-emerge for custom configuration."
+}