summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRené Nussbaumer <killerfox@gentoo.org>2006-11-08 20:35:16 +0000
committerRené Nussbaumer <killerfox@gentoo.org>2006-11-08 20:35:16 +0000
commit0e897efda50d411ea977254c83f62cc9af2c271b (patch)
tree6b6a624b92613b8f8eb1ef9acd545468baacca3b /x11-terms
parentVersion bump, thanks to James Cloos <cloos@jhcloos.com>, bug #142921 (diff)
downloadgentoo-2-0e897efda50d411ea977254c83f62cc9af2c271b.tar.gz
gentoo-2-0e897efda50d411ea977254c83f62cc9af2c271b.tar.bz2
gentoo-2-0e897efda50d411ea977254c83f62cc9af2c271b.zip
Version bump from upstream
(Portage version: 2.1.1-r1)
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/rxvt-unicode/ChangeLog8
-rw-r--r--x11-terms/rxvt-unicode/files/digest-rxvt-unicode-8.03
-rw-r--r--x11-terms/rxvt-unicode/rxvt-unicode-8.0.ebuild78
3 files changed, 88 insertions, 1 deletions
diff --git a/x11-terms/rxvt-unicode/ChangeLog b/x11-terms/rxvt-unicode/ChangeLog
index c9cc0efb28e6..891dae35ff65 100644
--- a/x11-terms/rxvt-unicode/ChangeLog
+++ b/x11-terms/rxvt-unicode/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-terms/rxvt-unicode
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt-unicode/ChangeLog,v 1.79 2006/08/12 15:12:29 killerfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt-unicode/ChangeLog,v 1.80 2006/11/08 20:35:16 killerfox Exp $
+
+*rxvt-unicode-8.0 (08 Nov 2006)
+
+ 08 Nov 2006; René Nussbaumer <killerfox@gentoo.org>
+ +rxvt-unicode-8.0.ebuild:
+ Version bump from upstream
12 Aug 2006; Rene Nussbaumer <killerfox@gentoo.org> metadata.xml:
Take over comaintainership
diff --git a/x11-terms/rxvt-unicode/files/digest-rxvt-unicode-8.0 b/x11-terms/rxvt-unicode/files/digest-rxvt-unicode-8.0
new file mode 100644
index 000000000000..276b2a0204e7
--- /dev/null
+++ b/x11-terms/rxvt-unicode/files/digest-rxvt-unicode-8.0
@@ -0,0 +1,3 @@
+MD5 e349f3d2bc8f4dfdf052cf63b4baa065 rxvt-unicode-8.0.tar.bz2 874877
+RMD160 f9e0c91b97454746b1356f638a02795aaf49befc rxvt-unicode-8.0.tar.bz2 874877
+SHA256 1dbd15914a1fdfa8e32876630a6cfbeda23f67326e544c3ee5dbd88a124b2e26 rxvt-unicode-8.0.tar.bz2 874877
diff --git a/x11-terms/rxvt-unicode/rxvt-unicode-8.0.ebuild b/x11-terms/rxvt-unicode/rxvt-unicode-8.0.ebuild
new file mode 100644
index 000000000000..ae5ee111e800
--- /dev/null
+++ b/x11-terms/rxvt-unicode/rxvt-unicode-8.0.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt-unicode/rxvt-unicode-8.0.ebuild,v 1.1 2006/11/08 20:35:16 killerfox Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="rxvt clone with XFT and Unicode support"
+HOMEPAGE="http://software.schmorp.de/"
+SRC_URI="http://dist.schmorp.de/rxvt-unicode/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc-macos ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="truetype perl iso14755"
+
+# see bug #115992 for modular x deps
+RDEPEND="
+ || (
+ (
+ x11-libs/libX11
+ x11-libs/libXft
+ x11-libs/libXpm
+ x11-libs/libXrender
+ )
+ virtual/x11
+ )
+ perl? ( dev-lang/perl )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ || (
+ (
+ x11-proto/xproto
+ )
+ virtual/x11
+ )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ local tdir=/usr/share/terminfo
+ sed -i -e \
+ "s~@TIC@ \(etc/rxvt\)~@TIC@ -o ${D}/${tdir} \1~" \
+ doc/Makefile.in
+}
+
+src_compile() {
+ myconf=''
+
+ use iso14755 || myconf='--disable-iso14755'
+
+ econf \
+ --enable-everything \
+ $(use_enable truetype xft) \
+ $(use_enable perl) \
+ --disable-text-blink \
+ ${myconf} \
+ || die
+
+ emake || die
+
+ sed -i \
+ -e 's/RXVT_BASENAME = "rxvt"/RXVT_BASENAME = "urxvt"/' \
+ ${S}/doc/rxvt-tabbed || die "tabs sed failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+
+ dodoc README.FAQ Changes
+ cd "${S}"/doc
+ dodoc README* changes.txt etc/* rxvt-tabbed
+}
+
+pkg_postinst() {
+ einfo "urxvt now always uses TERM=rxvt-unicode so that the"
+ einfo "upstream-supplied terminfo files can be used."
+}
+