summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2004-11-04 11:17:36 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2004-11-04 11:17:36 +0000
commit02d38cbd280f39b65b82437c18f9977add56f0b5 (patch)
treefe1a4071b21e7656639359965b29e453e988690c /x11-terms
parentStable on x86. (Manifest recommit) (diff)
downloadgentoo-2-02d38cbd280f39b65b82437c18f9977add56f0b5.tar.gz
gentoo-2-02d38cbd280f39b65b82437c18f9977add56f0b5.tar.bz2
gentoo-2-02d38cbd280f39b65b82437c18f9977add56f0b5.zip
version bump and 1.0.0 unmasking
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/pssh/ChangeLog12
-rw-r--r--x11-terms/pssh/files/digest-pssh-1.1.11
-rw-r--r--x11-terms/pssh/pssh-1.0.0.ebuild4
-rw-r--r--x11-terms/pssh/pssh-1.1.1.ebuild38
4 files changed, 52 insertions, 3 deletions
diff --git a/x11-terms/pssh/ChangeLog b/x11-terms/pssh/ChangeLog
index c7800c585e9f..258ad03c93d8 100644
--- a/x11-terms/pssh/ChangeLog
+++ b/x11-terms/pssh/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for x11-terms/pssh
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/pssh/ChangeLog,v 1.2 2004/09/03 14:06:07 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/pssh/ChangeLog,v 1.3 2004/11/04 11:17:36 voxus Exp $
+
+*pssh-1.0.0 (04 Nov 2004)
+
+ 04 Nov 2004; Konstantin Arkhipov <voxus@gentoo.org> :
+ 1.0.0 unmasked on x86.
+
+*pssh-1.1.1 (04 Nov 2004)
+
+ 04 Nov 2004; Konstantin Arkhipov <voxus@gentoo.org> +pssh-1.1.1.ebuild:
+ Version bump.
03 Sep 2004; David Holm <dholm@gentoo.org> pssh-1.0.0.ebuild:
Added to ~ppc.
diff --git a/x11-terms/pssh/files/digest-pssh-1.1.1 b/x11-terms/pssh/files/digest-pssh-1.1.1
new file mode 100644
index 000000000000..d7736841e644
--- /dev/null
+++ b/x11-terms/pssh/files/digest-pssh-1.1.1
@@ -0,0 +1 @@
+MD5 4c6ef9d91a8d2b2df3e08e3fd173dd7a pssh-1.1.1.tar.gz 33532
diff --git a/x11-terms/pssh/pssh-1.0.0.ebuild b/x11-terms/pssh/pssh-1.0.0.ebuild
index 28e46f5cb9ce..5c935403ef53 100644
--- a/x11-terms/pssh/pssh-1.0.0.ebuild
+++ b/x11-terms/pssh/pssh-1.0.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/pssh/pssh-1.0.0.ebuild,v 1.3 2004/09/03 14:06:07 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/pssh/pssh-1.0.0.ebuild,v 1.4 2004/11/04 11:17:36 voxus Exp $
DESCRIPTION="This package provides parallel versions of the openssh tools."
HOMEPAGE="http://www.theether.org/pssh/"
@@ -8,7 +8,7 @@ SRC_URI="http://www.theether.org/pssh/${P}.tar.gz"
SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="~x86 ~ppc"
+KEYWORDS="x86 ~ppc"
IUSE=""
DEPEND=">=dev-lang/python-2.2"
diff --git a/x11-terms/pssh/pssh-1.1.1.ebuild b/x11-terms/pssh/pssh-1.1.1.ebuild
new file mode 100644
index 000000000000..9ec032e60c88
--- /dev/null
+++ b/x11-terms/pssh/pssh-1.1.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/pssh/pssh-1.1.1.ebuild,v 1.1 2004/11/04 11:17:36 voxus Exp $
+
+DESCRIPTION="This package provides parallel versions of the openssh tools."
+HOMEPAGE="http://www.theether.org/pssh/"
+SRC_URI="http://www.theether.org/pssh/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+IUSE=""
+
+DEPEND=">=dev-lang/python-2.2"
+RDEPEND="net-misc/openssh"
+
+src_install() {
+ dodoc AUTHORS COPYING TODO COPYING
+
+# FIXME: how can i get current python version?
+ PY_VER=`ls /usr/lib | grep python | sort | tail -n 1`
+ PY_DIR=/usr/lib/${PY_VER}/site-packages
+
+ cd bin
+
+ for n in `ls`;
+ do
+ sed -e "s/python2\.2/${PY_VER/\./\\.}/" $n > $n.v
+ mv $n.v $n
+ done;
+
+ dobin {pnuke,prsync,pscp,pslurp,pssh}
+
+ cd ..
+
+ insinto ${PY_DIR}
+ doins `find lib -type f`
+}